Is oleaut.dll part of a normal windows xp installation

Discussion in 'other software & services' started by DCM, Jun 19, 2009.

Thread Status:
Not open for further replies.
  1. DCM

    DCM Registered Member

    Joined:
    May 25, 2004
    Posts:
    234
    I am having an error message pop up when starting Drive Image XML and have done everything they recommend to fix it except to register oleaut.dll.

    This file is not on my computer and I cannot find a copy anywhere to copy onto my hard drive.

    The program runs without it but seems to be much slower that it was before this error.

    I could try a windows XP repair but this is very time consuming and do not want to do it if the program is not there either.

    Does anyone here know if it is part of Windows and if so, could it be extracted from the install disk rather than running a Windows repair?

    Thanks
     
  2. Cudni

    Cudni Global Moderator

    Joined:
    May 24, 2009
    Posts:
    6,956
    Location:
    Somethingshire
    what is the exact error? is your xp install fully patched?
     
  3. GlobalForce

    GlobalForce Regular Poster

    Joined:
    Jun 30, 2004
    Posts:
    3,581
    Location:
    Garden State, USA
    "... seems to be much slower that it was before this error" - So what's changed, you update to sp3? Sounds like you need a runtime pkg.
     
  4. DCM

    DCM Registered Member

    Joined:
    May 25, 2004
    Posts:
    234
    When I start DriveImage XML (version 2.02), a message soon pops up saying:

    "Could not initialize Windows Shadow Service (VSS).
    Error: 80042318.
    Make sure VSSVC.exe is running.
    Click help for more information"

    VSSVC.exe is running when I check it on the task manager.

    When I click help, it suggests registering two files. They are;

    oleaut32.dll and
    oleaut.dll

    I registered oleaut32.dll but when I try it for oleaut.dll, a message pops saying that that dll file cannot be found. I have searched all my hard drives and the file is not on my computer.

    An internet search did not give any way to find and download this file.

    The program will continue to run on an alternate method but it seems much slower than when the Shadow Service is working. It used to work with no problems so apparently, something has deleted the oleaut.dll and I cannot find a way to replace it.

    Thanks for the responses.

    Any ideas?
     
  5. GlobalForce

    GlobalForce Regular Poster

    Joined:
    Jun 30, 2004
    Posts:
    3,581
    Location:
    Garden State, USA
    Forget about oleaut.dll for now. Concentrate on forwarding your svc-pack, oleaut32.dll version and quantity - not counting the dll_cache.
    Furthermore, has the other condition outlined in their FAQ concerning VSS been met - you can stop, disable, reboot and restart VSS?
     
    Last edited: Jun 19, 2009
  6. DCM

    DCM Registered Member

    Joined:
    May 25, 2004
    Posts:
    234
    Thanks for the replies.
     
  7. GlobalForce

    GlobalForce Regular Poster

    Joined:
    Jun 30, 2004
    Posts:
    3,581
    Location:
    Garden State, USA
    Yeah, you're right. When issues require effort they have a way of quickly losing priority.
     
  8. Rico

    Rico Registered Member

    Joined:
    Aug 19, 2004
    Posts:
    1,702
    Location:
    Texas
    Hi DCM,

    I was never successful getting DrivImage XML working properly, in trying to resolve I tried see:

    http://kb.backupassist.com/articles.php?aid=2971
    http://support.microsoft.com/kb/940184

    Note: I have "oleaut32.dll" but re-registering, did not help with DriveImage, I was missing "vssui.dll" got a copy of it online registered it & this was no help. I tried to get DriveImage working on another machine - no luck.

    I've abandoned my efforts regarding DriveImage XML & now use a superior product macrium reflect. I've backed up & restored using the free version, excellent product.

    see: http://www.macrium.com/reflectfree.asp

    Take Care
    Rico
     
Loading...
Thread Status:
Not open for further replies.