"Invalid argument encountered" with ESS in W7 Pro, what's up?

Discussion in 'ESET Smart Security' started by Xophile, Jul 1, 2010.

Thread Status:
Not open for further replies.
  1. Xophile

    Xophile Registered Member

    Joined:
    Feb 9, 2004
    Posts:
    161
    The last week I've experienced an error message with ESS on my W7 Pro 32-bit install.

    I run ESS in interactive mode and everytime I connect to a VPN i get a message box which says "Invalid argument encountered". After that I can't get rid of the window (for allow/deny) communication. It doesn't matter if I click allow/deny or if I try to make a rule. The window does not go away. I can click a button on the "Invalid argument encountered" window and then that one closes at least.

    Any thoughts on this matter?

    So far I've tried the following:
    1. disabling self defense at least allows me to get rid of the ESS interacctive ddialog window.
    2. Completely uninstall ESS, reboot, registry clean + file cleaning (in app data, roaming profile etc) manually
    3. Reboot
    4. Deleted my VPN-connection and reapplied it in a new connection = same problem

    When I reinstalled ESS I exported/imported my config file, can something have gotten wrong with my settings etc?

    Thankful for any response to this annoying issue.
     
  2. Cudni

    Cudni Global Moderator

    Joined:
    May 24, 2009
    Posts:
    6,956
    Location:
    Somethingshire
    Does the error occur after you import your previous config? If you run in other modes (auto etc) does the same occur?
     
  3. Xophile

    Xophile Registered Member

    Joined:
    Feb 9, 2004
    Posts:
    161
    Yes, the problem is still existing after a complete uninstall/install and export/import of my settings.

    I have yet tried automode etc and will report back. Even if that works, there must still be an issue with the interactive mode, right?
     
  4. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Please try a clean installation by running the ESET uninstall tool in safe mode and refrain from importing any previous configuration.
    Should the problem persist, post here a screenshot of the entire error message window. Also confirm or deny that the error occurs in other firewall modes.
     
  5. Xophile

    Xophile Registered Member

    Joined:
    Feb 9, 2004
    Posts:
    161
    Hello again, I'm very sorry for a late reply (vacation times...)

    I tried adding a rule for my VPN connection and I got the same errors message over and over again. After 3 reboots it finally worked. I longer get the error message and everythings fine. I didn't try the uninstall tool since I didnät need it.

    I still think it's a strange error message and maybe I can help you guys at Eset to understand what really caused it?
     
  6. Xophile

    Xophile Registered Member

    Joined:
    Feb 9, 2004
    Posts:
    161
    Updated: "Invalid argument encountered" with ESS in W7 Pro, what's up?

    Here we go again...

    Today I got the error message once again. If I click Allow or Deny nothing happens. I have disabled Self defense so I can terminate the egui.exe as a worksround though.

    Marcos and others: have you got any clues/suggestions?

    I have attached a screenshot of the error message
     

    Attached Files:

Thread Status:
Not open for further replies.