Internal USB WiFi problem.

Discussion in 'hardware' started by Searching_ _ _, Aug 17, 2008.

Thread Status:
Not open for further replies.
  1. Searching_ _ _

    Searching_ _ _ Registered Member

    Joined:
    Jan 2, 2008
    Posts:
    1,988
    Location:
    iAnywhere
    Hello,

    I have an internal (EDIT: not USB) mPCIe WiFi card that is having trouble.

    The problems began when I used an unprotected router (no password but default) and someone was sitting outside my house on a regular basis, leaching.

    The Wifi card would just stop, disappear from net connections, then I would refresh or turn off then on and refresh and it would be back.

    I switched from Vista to XP and it was still present, I could see other networks, but not my network. It is like my network was hidden from the device. I bought a new router and can only connect during setup via WiFi, strange, not ethernet. Ethernet became disabled during setup.

    FIXED: Now the device is no longer visible via hardware discovery tools, but still seems to be operating.

    [Edited]
    oddity
    [/Edited]

    I have tried several hardware discovery tools, Unknown Devices, UBCD ones. They do not show my WiFi device listed. They do show the PCI bus, USB Hub, NIC.

    I have the latest bios update, the card was working partially before and after the update.

    The WiFi card is removable, provided I find a micro philips.

    I thought that maybe it was a bios thing, and wanted to try resetting to the factory bios version. I have taken the laptop apart looking for a bios reset, there isn't one I can find.

    I have also tried updating the routers firmware. After updating and configuring the internet is thrown into a loop for a few minutes then self corrects.

    My router is visible from other computers, but not mine.
    I don't know how else to go about determining if it is a hardware or software issue.

    EDIT: I thought it was an internal USB, but apparently it is a miniPCIexpress slot.
    Hopefully I don't sound too much like a nutter. :)

    Hardware detection software did state that a pci express slot was available during most recent analysis.
    Should removing and reinserting the card be my first priority?
    If I do that, should I reboot in between removal and reinsertion?

    Your thoughts and assistance would be greatly appreciated,

    Searching
     
    Last edited: Aug 18, 2008
  2. Searching_ _ _

    Searching_ _ _ Registered Member

    Joined:
    Jan 2, 2008
    Posts:
    1,988
    Location:
    iAnywhere
    I was able to get the card working again. It would not take the Realtek drivers but once installed was able to update from MS. Only problem with the drivers are MS gave me 5.11 and the Realtek drivers are 6.11. The 5.11 driver is listed as USB 2.0

    I still have an invisible router.
    My computer is 3' from the router, it does not see it.
    I can see networks in my neighborhood but not the one next to me.
    Another computer that is 20' from the router sees it just fine.

    Is this a driver problem or a device issue?
    What can I do to resolve it?
    Can I manually install the 6.11 driver; copy, paste, move? Super manual.
    I know it probably would require registry editing.

    Edit: According to the net8187b.inf of the Realtek download, It is 5.11. So MS update must be correct then. Weird. Manufacturers page and Realtek page both list the latest driver as 6.11.

    I don't know if it is Hardware, Software or Leaching related problem.

    Edit: Talk about dumb luck. Searching for something else in another forum, I decided to try and help 1 out. Doing this may have given me some solid clues.

    This cat had a motherboard with an 8187L wifi device, only a desktop. Searching through the hardware specs for his device revealed this:

    enabling it to create a complete wireless home network in either AP or wireless client mode. Users will be able to play LAN games, connect to the Internet, access and share printers, and use Skype from anywhere within range


    The cards are diffferent designations, my card is 8187B, his is 8187L.
    But is it possible that these features are available for my card?
    If they are, then how do I alter/access these settings?
    I know Realtek makes wireless utility to view networks, maybe part and parcel to that.

    Update:
    From the Realtek site:
    Uses 93C46 (64*16-bit EEPROM) or 93C56 (128*16-bit EEPROM) to store resource configuration and ID parameter data

    Not sure if this is relevant to the leacher possibly hacking my stuff.
    Not sure if it is something I did. Or possibly both.
    Almost a year ago I installed Ubuntu. I didn't know what drivers to use. 8187L had a linux version, 8187B did not. Maybe there is something left over from the configuration from the 8187L linux driver install. The EEPROMs are usable storage...hmm. EEPROMs are above my head.

    Any thoughts or help,

    Searching
     
    Last edited: Aug 19, 2008
  3. Searching_ _ _

    Searching_ _ _ Registered Member

    Joined:
    Jan 2, 2008
    Posts:
    1,988
    Location:
    iAnywhere
    There is another thread in sister header, software, that I have a post in, I am not the OP there. It's called "Vista wireless problem".
    https://www.wilderssecurity.com/showthread.php?t=218157
    I believe that my problem is more hardware related that's why I have started a thread here.

    If anyone has any helpful advice, I am not affraid to experiment.
    In the mean time pounding the Google beat with my limited vocabulary. :D

    Thanks,

    Searching

    Update: Found this;

    NDISTest
    Wireless LAN test overview

    * New version of NDISTest 6.5
    o Written to natively support WLAN testing
    o Supports software AP over Realtek hardware
    o Hardware AP’s no longer required
    o AP PHY support for 802.11b and 802.11g
    + 802.11a available soon
    o AP supports WPA / WPA2 authentication and WEP / TKIP / AES encryption

    This is a Windows product for XP. Probably from MS dowloads. Maybe there is hope!
     
    Last edited: Aug 19, 2008
Loading...
Thread Status:
Not open for further replies.