Incorrect TCP Packet Checksum

Discussion in 'ESET Smart Security' started by mels, Jun 7, 2008.

Thread Status:
Not open for further replies.
  1. mels

    mels Registered Member

    Joined:
    Jun 7, 2008
    Posts:
    4
    I've seen this posted here before by a few people.
    I have been going back and forth between ESET support on this issue, and they say they cannot replicate my issue. In fact they don't acknowledge that it is an issue.

    I have a network of 2 workstations, 2 laptops and one 1 server/MC PC

    I can't:
    1) Move large files across then network from/to my Server. After a few seconds I can see the firewall logs start to fill with TCP checksum errors, then the transfer fails
    2) Backup any of my files to the server over the network - same thing as above.
    Really any app. that requires a saving/moving files across the network has this issue.

    The only way around this is the shutoff the firewall.
    I have tried adding rules to my backup software along with windows explorer and other apps. so that they are always allowed via TCP/UDP, but this does not help either.

    All Workstations and Server are Vista Ultimate x64 running ESET Smart Security v3.0.657.
    Laptops are Vista Ultimate x86 running ESET Smart Security v3.0.657.

    Thanks
     
  2. The_Cyborg

    The_Cyborg Registered Member

    Joined:
    Jun 13, 2008
    Posts:
    1
    I have exactly the same problem here.

    This is with two Vista Enterprise SP1 computers on a Gigabit connection. Only one of them is running Eset Smart Security. File copy operations to the computer running ESS are plagued with frequent pauses from several seconds up to minutes or even timeouts, accompanied with the "Incorrect TCP Packet Checksum" entries in the log file. Both computers are in the same subnet, which is marked as a Trusted Zone in ESS. Turning off the ESET firewall immediately resolves the problem.

    Does anyone have any information regarding this issue?

    Thanks!

    Steffen
     
  3. mels

    mels Registered Member

    Joined:
    Jun 7, 2008
    Posts:
    4
    I have been going back and forth with tech support on this issue. No resolve yet, just a bunch of emails asking me to try some setting and reboot.

    Bottom line, they need to admit there is an issue with the firewall and fix it.
     
  4. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    I don't think it's a false positive, I assume that the checksum of TCP packets is not actually correct for some reason. The best would be to get a log from Wireshark(Ethereal) for perusal where we could see the actual packets. Please create and send that log to support[at]eset.com with this thread's url enclosed.
     
  5. LazyPawn

    LazyPawn Registered Member

    Joined:
    Feb 22, 2007
    Posts:
    1
    Add me to the list, exactly the same problem and it's really annoying. The only way to copy large files is by disabling the firewall.
     
  6. mels

    mels Registered Member

    Joined:
    Jun 7, 2008
    Posts:
    4
    yup. Still nothing.
    I've sent in at 3 log files. To ESET support and nothing has been resolved yet.

    My case file has been open for almost a year.
     
  7. routerguy99

    routerguy99 Registered Member

    Joined:
    Sep 25, 2008
    Posts:
    108
    I tracked down why I am getting Incorrect TCP Packet Checksum in my log file. I have came accross MdnsResponder.exe loaded from \Bonjour\ in my program files.

    mDNSResponder starting', and then no input or output was accepted
    [udp] IP v4 udp fragmented packet reject

    So Nothing to worry about.
     
Thread Status:
Not open for further replies.