Incompatibility of LnS and Kaspersky Anti-Virus 7.0.1.321 ?

Discussion in 'LnS English Forum' started by qazwee, Jan 20, 2008.

Thread Status:
Not open for further replies.
  1. qazwee

    qazwee Registered Member

    Joined:
    Apr 8, 2007
    Posts:
    15
    Hi Frederic & co,

    I'm both Kaspersky AV and LnS user and on Kaspersky forum I have seen that someone had a BSOD after installing latest version of KAV.

    They also mentioned >>> this French forum thread <<< but because I don't speak French I really don't understand is the problem solved or not.

    So, before I update my AV software, I have to ask:
    - is the problem solved and...
    - is this something that I need to be concerned about or in other words is that problem occur only in rare occasion or is it a rule ?
     
  2. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi,

    Yes, one user reported a crash in the French forum with the last update of KAV.
    Then I reproduced the crash and I've created a patch for lnsfw1.sys to avoid the crash:
    http://looknstop.soft4ever.com/Beta/lnsfw1/LNSFW1-kapersky patch-x86.zip
    (unzip the file to c:\windows\system32\drivers)

    This is not really a fix, since the problem is not understood, and lnsfw1 just detects something not coherent during a connection establishment.

    I don't know if the problem is specific to the french update of KAV or if it applies to any version.
    When it occurs, it is systematic when updating the virus database.

    Regards,

    Frederic
     
  3. qazwee

    qazwee Registered Member

    Joined:
    Apr 8, 2007
    Posts:
    15
    Hi Frederic,

    I installed new KAV and it really crash imediately after I allowed database update.

    Simply LnS ask should KAV update module be allowed to connect, and after I click allow it shows BSOD.

    Also before that LnS asked for permission for a few other KAV modules/exe files and that went fine.

    After installing patch, you provided, all seems ok.

    Btw, I'm using English version of KAV on WinXP SP2, if that matters.
     
  4. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Of thanks, qazwee for your report.

    So the problem is general and not specific to the french version of KAV.

    Frederic
     
  5. egghead

    egghead Registered Member

    Joined:
    Aug 27, 2005
    Posts:
    443
    Location:
    The Netherlands
    Qui Frederic, the problem is general. I had the BSOD, I'm running the English version Windows XP Home SP2.

    Cordialement,

    Tête d'oeuf
     
  6. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    So, I guess you are using the lnsfw1.sys patch to avoid the BSOD ?

    Frederic
     
  7. egghead

    egghead Registered Member

    Joined:
    Aug 27, 2005
    Posts:
    443
    Location:
    The Netherlands
    No. I went back to KAV 7.0.0.125. This version with LnS runs without problems on my rig.

    When I have time I will reinstall the latest KAV version and the lnsfw patch.
     
  8. egghead

    egghead Registered Member

    Joined:
    Aug 27, 2005
    Posts:
    443
    Location:
    The Netherlands
    Frederic,

    I have just reinstalled KAV 701321 and the lnsfw1.sys patch.

    BSOD is gone and everything seems to run o.k :cool:

    merci beaucoup
     
  9. arran

    arran Registered Member

    Joined:
    Feb 5, 2008
    Posts:
    1,139
    I run KIS version 7.0.0.125 on xp sp2 and don't have any conflicting issues
    with LNS at all.
     
  10. fred22

    fred22 Registered Member

    Joined:
    Dec 6, 2004
    Posts:
    229
    Kaspersky Anti-Virus 7.0.1.321

    also happens with xp sp3 v.3300 and lns 2.06


    the patch did fix it :thumb:
     
    Last edited: Mar 2, 2008
  11. blackdog56

    blackdog56 Registered Member

    Joined:
    May 15, 2007
    Posts:
    8
    It also works with KAV 7.0.1.325, but has BSOD without the patch.

    edit.

    No BSOD if you disable Kaspersky's tm.ppl from connecting to the internet, but the web and mail scan counters don't work.. so not sure if it is actually scanning anything or not. tm.ppl = task monitor.
     
  12. Defenestration

    Defenestration Registered Member

    Joined:
    Jul 17, 2004
    Posts:
    1,086
    Frederic - Can you create an x64 version of the patched file please ?
     
  13. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    If the problem is the same for x64, yes, I can create the same patch.

    Could you send me a minidump file at lnssupport@soft4ever.com ?
    I just would like to be sure the same patch will apply.

    Thanks,

    Frederic
     
  14. Defenestration

    Defenestration Registered Member

    Joined:
    Jul 17, 2004
    Posts:
    1,086
    Sometimes it just reboots, other times it BSOD's. I'm having trouble getting it to BSOD at the moment, so would it be possible to send me the x64 patch anyway, and I will see if it helps. Of course, I will send you the minidump when I get one.
     
  15. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    For the Win32 case, the BSOD is systematic as soon as the virus database is updated in Kav.
    If you don't experiment that under x64, probably it is another issue.

    Did you remove yet the minidump files that were created ?

    Frederic
     
  16. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi,

    I've tested Look 'n' Stop 2.06p2 (with no patch) and Kav under Vista x64, and I didn't get any BSOD, when doing the online database update.

    However I've some errors in Kav log after files are downloaded ("error verifying loaded component / wai386"), and I've found this thread, where people are mentioning some BSOD (in addition to this update database issue).

    Frederic
     
  17. blackdog56

    blackdog56 Registered Member

    Joined:
    May 15, 2007
    Posts:
    8
    I can verify the the Look N' Stop 2.06p2 patch works with KAV 2009. Without it you get the BSOD.
     
  18. Defenestration

    Defenestration Registered Member

    Joined:
    Jul 17, 2004
    Posts:
    1,086
    Sorry for not replying sooner. I don't get any mini-dumps when the problem occurs. Often, it will just reboot without any BSOD.

    Can you create an x64 patch so I can just see if it does help on XP Pro x64 ?
     
  19. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi,

    I don't like providing patch without exaclty knowing the issue, but here it is:
    http://looknstop.soft4ever.com/Beta/lnsfw1/LNSFW1-x64-k1.zip

    Note: it contains another fix that was pending (x64 version only), so it will be difficult to say which one is fixing your issue (in case the crash disappears).
    If your issue was not systematic and not linked to Kapersky update but occurring at random, probably this other fix is the one you needed.
    That's why I would have preferred to get a minidump to verify the kind of crash (it could be also not related to Look 'n' Stop or lnsfw1).

    Regards,

    Frederic
     
  20. Andre22

    Andre22 Registered Member

    Joined:
    Jun 23, 2008
    Posts:
    1
    MERCI!

    Five hours of un/re/in-stalling the updates for KAV v7.0 and v8.0 ... before returning to v6.0 (which worked just fine with LNS).

    My problem was a simple crash and reboot every time KAV asked for an internet connection.

    This is what worked for me:

    - Downloaded the patch [ same as above ]
    http://looknstop.soft4ever.com/Beta/lnsfw1/LNSFW1-kapersky patch-x86.zip
    - Cleaned off KAV v6.0 with the removal tool [ used in Safe Mode ]
    - Rebooted
    - Un-installed LNS [ but left registry values / rules etc ]
    - Installed KAV 7.0.1.325
    - Rebooted
    - Closed down KAV
    - Re-installed LNS and applied the patch > c:\windows\system32\drivers
    - Rebooted [ NB: if you apply the patch at a later stage it's important you reboot ]
    - Tested with Mozilla / KAV internet updates went smoothly

    KAV 7.0.1.325 + Look N Stop 2.06 now working! [ WinXP Sp2 ]

    PS: Btw, thanks for the great FW!
     
Thread Status:
Not open for further replies.