IMON problem

Discussion in 'NOD32 version 2 Forum' started by SimonW, Mar 8, 2004.

Thread Status:
Not open for further replies.
  1. SimonW

    SimonW Registered Member

    Feb 22, 2004
    Leicester, UK
    I'm running NOD32 and LooknStop firewall. Currently whenever I run Shareaza P2P software after 'X' minutes (anywhere between 5 minutes and 5 hours) it crashes stating IMON.DLL as the cause of the problem.
    I guess I thought IMON was only for checking email in/out o_O so this is very odd. I have changed IMON setup and selected not to check Shareaza.Exe but it has not cured the problem. The only way I get it to run for any period of time is to disable IMON completely.
    I'm not sure I noticed this behaviour before changing to LooknStop though. Could the two apps be clashing and causing Shareaza to crash as a result? Does IMON do more than just email checking?

    (I might also try a different firewall but liked LnS due to its low resource overhead)
  2. sir_carew

    sir_carew Registered Member

    Sep 2, 2003
    Santiago, Chile
    I had Look'n'stop and that hasn't work properly in my pc with NOD. When I had scan using NOD, it crashed, but if I uninstall look... the problem dissapear, but it isn't the main matter, it's only a comment about both programs :D
    IMON scan incoming mail and also had a Internet Filter which prevent some worms for example: Nachi, SQLSlammer, etc.
    If you disable look... the problem disappear?. Try to move the slide bar from max protection to more compatible.
    PS: Also Kerio use few resources.
  3. Figaro

    Figaro Registered Member

    Dec 1, 2002
    I have the same problem, but when using eMule.
    The strange thing is that eMule v0.41b29 works fine, but any more recent version of eMule end up with imon.dll crashing in flames :(
    Tried excluding the eMule directory in NOD32 but that didn't help the slightest.

    P4 2.26 GHz @ 2.72 GHz
    Abit IC7-Max 3
    2 GB PC3200 Dual Channel (4x512 MB)
    Windows XP HE

    NOD32 updated (2004-03-12)
    ZoneAlarm Pro 4.5.538.001
  4. Disme

    Disme Registered Member

    Oct 27, 2003
    Hi all,

    I have the same problem with eMule...after some time it crashes with IMON.dll as cause.

    NOD32 Antivirus System information
    Virus signature database version:   1.672 (20040316)
    Dated:   Tuesday march 16 2004
    Virus signature database build:   4336
    Information on other scanner support parts
    Advanced heuristics module version:   1.007 (20040309)
    Advanced heuristics module build:   1053
    Internet filter version:   1.001 (20031104)
    Internet filter build:   1012
    Archive support module version:   1.012 (20040304)
    Archive support module build version:   1086
    Information on installed components
    NOD32 For Windows NT/2000/XP/2003 - Base
    Version:   2.000.9
    NOD32 For Windows NT/2000/XP/2003 - Internet support
    Version:   2.000.8
    NOD32 for Windows NT/2000/XP/2003 - Standard component
    Version:   2.000.9
    Operating system information
    Platform:   Windows XP
    Version:   5.1.2600 Service Pack 1
    Version of common control components:   5.82.2800
    RAM:   256 MB
    Processor:   Mobile Intel(R) Celeron(R) CPU 1.80GHz (1794 MHz)
    All the recent M$ updates installed.
    Firewall: Sygate Personal Firewall Pro v.2525.

    Please, anybody help me? I like NOD32 very much and would hate it if I had to change because of this! :'(

    Never had problems in the past, except lately my internet-connection goes down from time to time...may be related ...

    I already scanned with Adaware, Spybot S&D, Pest-Patrol, did a complete reformat no avail.

    Thanks in advance.

    Disme :cool:

    BTW; People using the trial version had no problem with 'imon.dll' while running the same e-Mule version. Could it be the new version 2009 fault?
  5. Paul Wilders

    Paul Wilders Administrator

    Jul 1, 2001
    The Netherlands

    Are you using one and the same Emule version as mentioned by Figaro? If so, looks like this last Emule version is causing problems.

    If so, please drop an email explaining what's going on.


  6. Disme

    Disme Registered Member

    Oct 27, 2003
    I use eMule0.30e sivka v10e9a, don't know what he uses, but guess it's not the same..
    I will try to set IMON settings to max compatability. After that I'll unistall my NOD32 and install the trial-version and see if I get the same crashes. If not I drop a mail to support.

    Thanks for your answer.

  7. glenncc

    glenncc Registered Member

    Feb 13, 2004
    I have just changed from LooknStop to Outpost firewall and I like it alot. It's much more userfriendly, and let's you know exactly what's going on. With LnS I was mostly guessing/hoping. And no conflicts at all with NOD.
    If you're thinking of changing firewalls, have a look at this - I did alot of checking and this is the goods.
  8. brazz

    brazz Guest

    same problem here...
  9. isochar

    isochar Guest

    Same problem with eMule v.42d.
  10. Figaro

    Figaro Registered Member

    Dec 1, 2002
    So, now we only have to figure out if it is IMON or eMule/Sharezaa's fault :)
    I.) Latest version of eMule works fine with other AV programs, at least the ones I've tried so far.
    II.) IMON doesn't crash when running older version of eMule...

    Could some change in the ED2K or Kademlia protocol trigger the IMON crash (Sharezaa also uses the ED2K protocol)?

    The changelogs for the different eMule versions are listed here.
    Incidentally, the first version of eMule that started to cause trouble was also the first official release, 0.42b.
  11. Marcos

    Marcos Eset Staff Account

    Nov 22, 2002
    It seems installing the latest version of imon.dll fixes the problem (confirmed by Figaro). If you experience the same problem, please drop an email to
  12. Thorz

    Thorz Registered Member

    Dec 29, 2003
    Hey guys

    I am having a problem that can be related to this one also. It is when using Bittorrent (the Bittornado Shadow's Experimental Client, very popular). When NOD32 is active the bittorrent client hangs after some time of working. When I disable IMON and AMON the problem dissapears. Bittorrent has never failed before, it started to have problems after installing NOD32. I have updated to the last version of the client and the problem is there.

    Any idea would be very apreciated, thanks.
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.