IMON problem

Discussion in 'NOD32 version 2 Forum' started by evilone, Aug 2, 2007.

Thread Status:
Not open for further replies.
  1. evilone

    evilone Registered Member

    Joined:
    Aug 2, 2007
    Posts:
    3
    Hi all,

    I recently ran the windows troubleshooter to check up my pc.
    What it finally did(I kinda confirmed it) was that it detected some blocking from Nod32, and unregistered something.(I have absolutely no idea :doubt: )

    And now IMON doesnt startup, i tried manually enabling it but all I get is "error occurred while registering IMON to the system". And the status window shows "Internet protection is not running".

    I have tried reinstalling it and all. Doesnt help. I also tried to look into the event log, but the event that imon failed to load doesnt show up either :-(

    Any ideas?

    TIA
     
  2. ASpace

    ASpace Guest

    Hi !

    Welcome to Wilders!

    Try this:
    1) Download the latest fresh version of NOD32 v 2.7 for your operating system
    Trial version or Full paid version

    2) Open Control Panel-> Add/Remove programs and Uninstall NOD32

    3) Reboot when prompt

    4) After restart , go to C:\Program files and manually delete the folder ESET

    5) Repair Winsock
    Windows XP SP2 and Windows Vista

    Goto Start –> Run
    type cmd and click OK.
    Type netsh winsock reset
    Press ENTER . Restart immediately !

    N.B. ! There is a space between the commands , example netshSPACEwinsockSPACEreset
    N.B. ! If you use Windows Vista , you must first run cmd as Administrator!



    6) Install NOD32 from the file you downloaded in step 1
    Use "Typical" install

    7) Make sure you have stable internet connection and NOD32 (nod32krn.exe) is allowed to go through your firewall. Then Update NOD32 !


    Report back your results :thumb:
     
  3. evilone

    evilone Registered Member

    Joined:
    Aug 2, 2007
    Posts:
    3
    Hi,

    Thanks for the ultra fast response!
    But i have tried all the steps that you have mentioned. Including the winxpsockfix and sock reset.

    I guess there is something in windows which is preventing the imon dll to be registered. Maybe some setting in registry?

    BTW, i was looking around and saw ESS. i was amazed and installed it!

    So I guess my problem is not happening while i test out the new beta :)

    Regards
     
  4. ASpace

    ASpace Guest


    So now you have Eset Smart Security , right . That's great . There is no IMON/Winsock layer protection in it (but it does have web scanning) .
    I am not sure if you want to try it (it may be good for your computer) ... if you use Win Me / XP /Vista you can uninstall ESS and run System Restore which should restore your computer to previous state and will reverse all "bad" changes you have made . This will make no more problems . However if you are happy with your ESS , you can miss that option

    Regards! :thumb:
     
Thread Status:
Not open for further replies.