IE 6 disabled Active-X popup fix?

Discussion in 'other security issues & news' started by squinteyes, Apr 8, 2006.

Thread Status:
Not open for further replies.
  1. squinteyes

    squinteyes Registered Member

    Joined:
    Apr 8, 2006
    Posts:
    9
    I was browsing around and found this and was wondering if this seems like a legitimate fix for that annoying popup saying your ActiveX is disabled.


    1. Get yourself a resource editor, like "Resource Hacker": http://www.angusj.com/resourcehacker/
    2. Search for the file "shdoclc.dll", usually located in c:\windows\system32\ or c:\winnt\system32\
    3. Load shdoclc.dll in Resource Hacker, go to "String Table" and go to element #503
    4. In the right window you now see some of the IE alerts, simply delete the line 8033 !!!
    5. Click on "Compile Script"
    6. Save as shdoclc.dll in a different directory
    7. Replace the old versions in ..\system32\ AND in ..\system32\dllcache\ with your new one, if necessary in safemode.
    8.That's all. You will never ever see the stupid pop-up again.


    I don't mind following directions.I just want to know that the people who are giving them know what they're talking about.
     
  2. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    thanx. i hope it works
     
  3. Jaws

    Jaws Registered Member

    Joined:
    Apr 4, 2005
    Posts:
    210
    Hi squinteyes,

    First post I see, welcome to Wilders.

    Good find, though you don't say where you got the info from. I've also read something about hacking the shdoclc.dll to “fix” this problem.

    But ...

    Not wanting to dampen your enthusiasm for getting rid of an admittedly annoying popup but it's there for precisely the reason you disable activeX in the first place -- to show that your security setting are working. Without the warning you wouldn't know if parts of a web page are "broken" because of your settings.

    Then again, a possibly simpler approach would be a tiny program mention first by inceni60 HERE, called Autoclose.

    Regards
     
  4. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    wait, so this fix jsut remove teh alert? activex remains disabled?

    shoot, i read too fast...again
     
  5. squinteyes

    squinteyes Registered Member

    Joined:
    Apr 8, 2006
    Posts:
    9
  6. Rasheed187

    Rasheed187 Registered Member

    Joined:
    Jul 10, 2004
    Posts:
    8,010
    Location:
    The Netherlands
    Thanks for the heads up squinteyes, I´ve tested it in VMware and it does seem to work. Now I can disable ActiveX without seeing this stupid alert ever again. And besides even with ActiveX enabled you sometimes would still see the alert, never knew why, but I´m glad it´s gone now. :D
     
Loading...
Thread Status:
Not open for further replies.