Identity Shield Stops Working

Discussion in 'Prevx Releases' started by GreekGuy, Jan 1, 2013.

Thread Status:
Not open for further replies.
  1. GreekGuy

    GreekGuy Registered Member

    Joined:
    Oct 6, 2011
    Posts:
    41
    Location:
    Toronto, CANADA
    Hi,

    HAPPY NEW YEAR!!!

    At random times, the Identity Shield stops working on my system (win 7 x64). I know the Identity Shield has turned itself off because whenever I go on any web page the yellow key no longer appears on the "W" icon in the tray.

    I tested that the Identity Shield was indeed not working with use of Zemana's key_sim application. As well, during the period when the Identity Shield was not working, I was able to block the EICAR test virus; so, I believe the virus checking/blocking parts of Webroot were still working.

    Shutting Webroot down and restarting it, turns the Identity Shield back on and everything works fine until the next time the Identity Shield shut itself down.

    (BTW, whenever the Identity Shield stops working, so does the right-click Scan With Webroot functionality. I don't know if this is a related bug.)

    A search of the web shows similar complaints from other users.

    Any thoughts on what's causing the Identity Shield to shut down?

    Thanks,
     
  2. Techfox1976

    Techfox1976 Registered Member

    Joined:
    Jul 22, 2010
    Posts:
    749
    Check your logs (System Tools -> Reports -> Scan Log - Save As... ) for a line that reads:
    Fri 2012-12-07 22:24:24.0635 Terminated abruptly in the last session
    around the time that the failure occurred. This is the trigger for the old problem.

    I went to clean up hundreds of game updater entries from my firewall applications by hand and the userspace process died as a result. I don't know if that could have any impact, but it resulted in two system tray icons and one of them was fake and vanished when moused over. Could potentially also impact the thing if something is wrong.

    Also, was the browser the active window at the time?
     
  3. GreekGuy

    GreekGuy Registered Member

    Joined:
    Oct 6, 2011
    Posts:
    41
    Location:
    Toronto, CANADA
    Hi Techfox.

    Yes, the browser window was active (Google Chrome)

    I found the entry "Terminated abruptly...." in the scan log. Unfortunately, to be honest with you, I don't know what I'm looking at. There doesn't seem to be any entry that explains the Identity Shield shutdown that I can understand.
     
  4. Techfox1976

    Techfox1976 Registered Member

    Joined:
    Jul 22, 2010
    Posts:
    749
    It the termination coordinates with the ID shield stopping working, then it's related to the lack of User process to System process communication recovery when it terminates abruptly. That is what was causing the inability to right-click scan. Might also impact the ID shield if those log entries are around the same time as the ID shield stopping.

    This is kinda diagnostics. There's no solid answers for this because I don't think anybody else has had this issue to fix.
     
  5. PrevxHelp

    PrevxHelp Former Prevx Moderator

    Joined:
    Sep 14, 2008
    Posts:
    8,242
    Location:
    USA/UK
    Could you let me know if you're doing anything in particular around the time when it stops working and how frequently it tends to happen? We may be able to set up a debug session but it could end up being quite time consuming to diagnose as we haven't seen this elsewhere with the newer releases.
     
  6. GreekGuy

    GreekGuy Registered Member

    Joined:
    Oct 6, 2011
    Posts:
    41
    Location:
    Toronto, CANADA
    I was doing nothing out of the ordinary when I noticed the yellow lock missing from the "W", just browsing using Chrome.

    It looks like the Identity Shield seems to shut itself down every three or four days. To correct the problem, I simply shutdown Webroot and restart it by clicking on the shortcut located on my desktop.

    Today, for example, the Identity Shield crashed at 11:17am EST according to the Scan Logs. It's been working fine since.

    Unfortunately, I cannot pinpoint a specific action that I've done on my end to cause the Identity Shield to stop working (and the right click menus to stop functioning.)

    To be honest, this is not a big deal as long as the Virus Protection part of Webroot continues to function after the Identity Shield shuts itself down. I believe this is indeed the case. If not, please let me know ASAP, so I can start shopping around for a replacement.
     
  7. PrevxHelp

    PrevxHelp Former Prevx Moderator

    Joined:
    Sep 14, 2008
    Posts:
    8,242
    Location:
    USA/UK
    The malware protection will definitely still be active. Could you let me know if you see two W icons in your tray when this happens or if the one icon just removes the padlock? And, could you tell me if you have the browser open for a long period of time before this happens?

    Also, what is your WSA build number? We have made improvements in this area so if you're on an old build, it's possible that you're experiencing issues we've fixed.

    Thanks!
     
  8. GreekGuy

    GreekGuy Registered Member

    Joined:
    Oct 6, 2011
    Posts:
    41
    Location:
    Toronto, CANADA
    That's good news. I really didn't want to replace Webroot because I'm really liking its small footprint and low system impact.

    Just one W icon is visible in the tray.

    Chrome browser was open at least three hours before the Identity Shield crashed at 11:17am today.

    v8.0.2.96
     
Thread Status:
Not open for further replies.