How to turn off caching of uploads via browser?

Discussion in 'ESET Smart Security' started by ladhani, May 26, 2009.

Thread Status:
Not open for further replies.
  1. ladhani

    ladhani Registered Member

    Joined:
    May 26, 2009
    Posts:
    5
    Hello,

    Since I upgraded to ESET Smart Security (ESS) version 4, we have the following issue:

    We are using in our company a number of browser applications for uploading (BIG) documents to our servers (Flash / PHP uploaders).

    Since we upgraded from version 3 to version 4, the upload progress bar in the browser application does not work correctly. It immediately shows 100% upload ready with an impossible high upload speed. And next nothing happens in the Browser application for a very long time. After some time, the browser application continues (upload ready).

    What ESET 4 seems to do, it directly catches the uploaded file, first storing it locally for scanning and than uploading it on the background to our servers.

    This is very disturbing for us as our employees think that the browser has frozen up as they see the upload progress bar directly at 100% and nothing seems to happen (for a long time).

    My question is how to turn off in ESET ESS the local caching of uploaded files via the browser?

    We also had this issue on some PCs using the Kaspersky Suite but here it is possible to turn off the local caching of files being uploaded via the browser. So the files were directly uploaded to our servers and the upload progress bar in the browser application showed the actual progress value (and not a fake impossible value of uploading to a local cache).


    I hope sincerily that in ESS 4 this is also possible otherwise we will have to stop using ESS 4...(which would be a big dissapointment).
     
  2. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    ESET does not check outgoing http communication and thus does not have any direct effect on this. What OS are you using?
     
    Last edited: May 27, 2009
  3. ladhani

    ladhani Registered Member

    Joined:
    May 26, 2009
    Posts:
    5

    OS = Vista 64 Ultimate.
    Browser = IE7 or FF3 (same behaviour)
    Flash plugin = Flash 10
    ESS = 4.0.424.0

    I am afraid ESS DOES do local caching of file uploads via a Flash Webapplication.

    Proof:

    I found that when I turn of the HTTP-filter in advanced settings for HTTP-scanner, the upload works again normal. The upload progressbar in the Flash application shows a correct progress and normal upload speed values.

    However, when I turn on the HTTP scanner, the upload progess bar immediatly goes to 100%, showing impossible high speed values and the browser freezes until on the background the upload is handled by ESS.

    I can also see that ESS is handling the upload on the background by looking at the activity graph in ESS (network activity). I can clearly see the background uploading in the graph while in the browser webapplication, the progress bar immediately and always shows 100%.


    Here you can try / test this your self:

    http://www.tinywebgallery.com/en/tfu/web_demo2.php

    The upload size of this Flash uploader is limited to 300 KB but if you squeeze your netwerk speed, you will see that the progress bar does work correctly with HTTP-filter turned OFF and goes directly to 100% if you turn the filter on again.



    Do you need more info?

    Then please let me know.
     
    Last edited: May 27, 2009
  4. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    It rather sounds like a problem with Windows platform filtering on your system or the applications you use don't work correctly with it.
     
  5. Cudni

    Cudni Global Moderator

    Joined:
    May 24, 2009
    Posts:
    6,956
    Location:
    Somethingshire
    if you disable web access module does the same happen?
     
  6. ladhani

    ladhani Registered Member

    Joined:
    May 26, 2009
    Posts:
    5
    A - Then please explain me why the problem can be turned on and off by simply changing an advanced setting in ESS 4 (turning on / off HTTP filtering).

    B - We have been using ESS 3 for one year now on multiple computers and never had this problem.


    The ONLY thing we did, is remove ESS 3 and install ESS 4. NO OTHER CHANGES.


    This problem also happens with Kasperksy antivirus but can be controlled a bit better by more refined settings (cancel virus checking for HTTP uploads).

    Doing more than 15 years IT System administration, I can pretty much assure you that this problem is probaly caused by ESS 4 caching HTTP upload locally and next doing the upload on the background.

    Did you try:


    http://www.tinywebgallery.com/en/tfu/web_demo2.php

    The upload size of this Flash uploader is limited to 300 KB but if you squeeze your netwerk speed, you will see that the progress bar does work correctly with HTTP-filter turned OFF and goes directly to 100% if you turn the filter on again.
     
  7. ladhani

    ladhani Registered Member

    Joined:
    May 26, 2009
    Posts:
    5

    A crude solution for this issue is indeed to completely disable HTTP - scanning (Advanced config -> Antivirus -> webaccess -> HTTP -> disable HTTP contol).

    But I suppose this means that all HTTP monitoring is disabled? So not only the web upload but also download?

    I also tried to enable HTTP scanning and add our server domains to the sites not be be scanned. But this does not solve the problem. All uploads are first locally cached and uploaded on the background.

    So the only solution for now seems to be to totaly disable HTTP scanning.....
     
  8. Cudni

    Cudni Global Moderator

    Joined:
    May 24, 2009
    Posts:
    6,956
    Location:
    Somethingshire
    small price to pay, and for the time being, for keeping the users happy without slowdowns. They are still protected with real monitoring
     
Thread Status:
Not open for further replies.