How to skip bad sectors? (maybe a boot parameter?)

Discussion in 'Acronis Disk Director Suite' started by oliversl, Mar 1, 2007.

Thread Status:
Not open for further replies.
  1. oliversl

    oliversl Registered Member

    Joined:
    Mar 1, 2007
    Posts:
    2
    Hi,
    I'm using Disk Director 9 in a new PCI-e motherboard.

    I'm copying my old partition from an PATA (ATA-100) disk to a new SATA2 (300mbit/s) disk

    The process is a little slow and I have bad sectors in my old partition. Thats not a problem because I already run chkdsk /r in order to mark the bad sector and not use them in the NTFS file system.

    My question is if there is an option in order to automatically skip all bad sectors?

    I need this because when the dialog windows appears and says that it could not read sector NN, the computer freeze.

    Thanks
    Oliver
     
  2. MudCrab

    MudCrab Imaging Specialist

    Joined:
    Nov 3, 2006
    Posts:
    6,483
    Location:
    California
    I haven't used DD 9 (only DD 10) and I haven't use the copy partition option.

    However, I have run into hard drives that are in the process of failing. How many times did you run chkdsk /r on the drive? I recently replaced a drive for a client because it always found new bad sectors every time chkdsk was run. This may be what's happening in your case. If you can get several run throughs with chkdsk without any new errors popping up then try the copy again. Otherwise, it's probably just banging into new ones when you go to copy and causing it to freeze.
     
  3. oliversl

    oliversl Registered Member

    Joined:
    Mar 1, 2007
    Posts:
    2
    It seems that DD9 still tries to copy a bad block marked as bad block
     
Thread Status:
Not open for further replies.