How to setup JanusVM

Discussion in 'privacy technology' started by scott1256ca, Feb 23, 2011.

Thread Status:
Not open for further replies.
  1. scott1256ca

    scott1256ca Registered Member

    Joined:
    Aug 18, 2009
    Posts:
    144
    I installed vmware player on a linux mint system (but I don't think the OS here is the issue).
    I tried the setup video they provided but there is a problem with it.
    I can setup a user and password, but it gets to a screen asking for

    1) Show IP Information
    2) Configure IP Information
    3) Configure Anonymity ...
    4) VPN User Management
    5) Create New Circuit
    6) Shutdown/Reboot
    7) Quit

    Then the video just suddenly starts to reboot into a windows env. They do not show what to enter at this screen. I've tried to pause and play the video here, but if they show a response to the above, i sure can't see it.

    I've tried to shutdown, reboot, and quit, all of which do not launch the janusvm session. They also have some batch scripts they suggest to run, but these don't start the actual janusvm session either.

    So what do I do at this screen?

    Thanks
     
  2. JConLine

    JConLine Registered Member

    Joined:
    Apr 16, 2009
    Posts:
    107
    I know this is not what you are asking but fyi I installed Oracle VirtualBox to LinuxMint and I've had absolutely no problems. Intalled it and then installed a Mint VM using a LiveCD and everything just works.

    Jim
     
  3. goldenone

    goldenone Registered Member

    Joined:
    May 31, 2007
    Posts:
    17
    Start JanusVM, wait for it to boot.
    THEN IN WINDOWS (not JanusVM), the video is showing you how to create a PPTP VPN connection to JanusVM. So go create a PPTP VPN connection to JanusVM from windows, then we you connect the VPN to JanusVM, all you traffic routes through Tor.

    Enjoy.
     
  4. scott1256ca

    scott1256ca Registered Member

    Joined:
    Aug 18, 2009
    Posts:
    144
    ok, I should have looked through that video a little further.

    So at least that shows me where linux vs. windows is important. I have found a couple of things talking about setting up pptp on linux, but they give me errors

    I tried this (had to translate to English, so perhaps I missed something obvious) which seems to be based on this
    but I get an error.
    either
    pppd: In file /etc/ppp/peers/JanusVM: unrecognized option '--loglevel'
    or if I change
    pty “pptp --loglevel 1 <ip address I put in here> --nolaunchpppd”
    to
    pty “pptp <ip address I put in here> --nolaunchpppd”

    I get

    pppd: In file /etc/ppp/peers/JanusVM: unrecognized option '<ip address I put in here>'
    either running
    $> sudo pon JanusVM
    or
    $> sudo pppd call JanusVM
    same error either way
    I may try this again later, but unless someone sees a very obvious problem with what I did, I'm giving up for now.

    Other suggestions I've seen for linux are either old or install virtualbox instead of vmware player or install some kde vpn software, neither of which I'm interested in pursuing right now.

    Thanks anyway.
     
Loading...
Thread Status:
Not open for further replies.