How do you manually edit policy configs?

Discussion in 'Other ESET Home Products' started by edwin3333, Feb 17, 2009.

Thread Status:
Not open for further replies.
  1. edwin3333

    edwin3333 Registered Member

    Joined:
    Aug 29, 2007
    Posts:
    244
    I uploaded a CFG.XML into my policy server.

    As usual, the server takes those items I have delete=1 (removal of exclusions) and turns them into delete=0 so it adds them. Opposite of what I want.

    When pushing configs, I know I have to manually modify the cfg.xml EVERY single time I change it so the delete remains =1

    But how to I manually modify imported policy files to get the same effect?

    Thanks!
     
  2. SmackyTheFrog

    SmackyTheFrog Registered Member

    Joined:
    Nov 5, 2007
    Posts:
    767
    Location:
    Lansing, Michigan
    The policies are stored in All Users\Application Data\ESET\ESET Remote Administrator\Server\storage\Policy_Configuration as numbered .dat files. The data inside is still XML, you should be able to search through them and modify the data so that flag is set correctly. There is also the All Users\Application Data\ESET\ESET Remote Administrator\Server\cache\policy folder that contains a duplicate cached copy of your policies. I would try stopping the Eset services, clearing the folder out, and then restarting and hopefully your manually edited policies will propigate down to your cache and hit the clients.
     
  3. edwin3333

    edwin3333 Registered Member

    Joined:
    Aug 29, 2007
    Posts:
    244
    Thank you. Hopefully eSet will fix this bug one day :)
     
  4. SmackyTheFrog

    SmackyTheFrog Registered Member

    Joined:
    Nov 5, 2007
    Posts:
    767
    Location:
    Lansing, Michigan
    I ended up calling this one in, a tech reproduced the issue with delete flag not being set correctly, and the issue has been escalated. It is disappointing that the moderators aren't picking up on the bugs reported here and passing them up the chain.
     
Thread Status:
Not open for further replies.