How do remove programs from the "Open With..." context menu?

Discussion in 'other software & services' started by Close_Hauled, Jul 12, 2006.

Thread Status:
Not open for further replies.
  1. Close_Hauled

    Close_Hauled Registered Member

    Joined:
    Apr 24, 2004
    Posts:
    1,015
    Location:
    California
    I could swear that doing this is real simple, but I cannot figure it out.


    I want to remove all but one program from the "Open With..." context menu for TIF and TIFF files. I could swear that you could do this with the "Folder Options" control panel, but I cannot. I have even tried deleting the file types, and recreating them. But the other applications automatically reappear. Is this information in the registry? If so, where?
     
  2. Texcritter

    Texcritter Registered Member

    Joined:
    May 6, 2005
    Posts:
    1,985
    Location:
    Teesside, North East England
    Hi Close Hauled
    One way of doing it

    Right click file
    In the context menu choose open with
    Select the choose program option
    Select the program and tick the box Always use this program
    to open this kind of file

    Hope this helps
     
  3. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
  4. Close_Hauled

    Close_Hauled Registered Member

    Joined:
    Apr 24, 2004
    Posts:
    1,015
    Location:
    California
    What I want to do is remove the other programs in the list except one.

    The OpenWithList key for TIF files can be found here:

    Code:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.tif
    Windows insists on adding "Windows Picture and Fax Viewer", "Internet Explorer", and "Paint" to the list. I just want one program in there, which is a company internal program for viewing TIF files.

    This is close, but I need to be specific to TIF files only. This approach will stop that application from showing up at all for all files.
     
  5. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    why do u need apps removed from the open with dialog box for .tiff files? just associate a program with .tiff and you wont have to worry about open with.
     
  6. Close_Hauled

    Close_Hauled Registered Member

    Joined:
    Apr 24, 2004
    Posts:
    1,015
    Location:
    California
    For some reason the program will not open the TIF files if other applications are in the context menu. It comes up with an error message that says "Cannot Open File". I do not know why it does this, but I have confirmed that that is the way it works.

    The one guy that I know who knows how to fix it is on vacation. So I am trying to figure it out on my own.
     
  7. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    so if even you recreate the .tiff file type (in folder options), it still wont open properly with the program?
     
  8. Bubba

    Bubba Updates Team

    Joined:
    Apr 15, 2002
    Posts:
    11,271
    Hey CH,

    Have you attempted to look in the below reg location where .tif file extensions Open With entries are stored :doubt:

    HKCR\.tif\OpenWithList
     
  9. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    maybe u can go to HKCR and delete the .tif and .tiff. then open a tiff picture with the program u want. see if itll work then.

    u can also see if opening .tiff with a different program works properly.
     
  10. GroverH

    GroverH Registered Member

    Joined:
    May 10, 2006
    Posts:
    2,405
    Location:
    Massachusetts, USA
    Another alternative might be to add a new listing to the Context menu.
    You could have your company program listed as the top item in the Context menu.
     

    Attached Files:

  11. iceni60

    iceni60 ( ^o^)

    Joined:
    Jun 29, 2004
    Posts:
    5,116
  12. Rmus

    Rmus Exploit Analyst

    Joined:
    Mar 16, 2005
    Posts:
    3,943
    Location:
    California
    This is because the programs automatically install a filetype in HKEY_CLASSES_ROOT\Applications\

    Whereupon Windows builds the Open With key on startup by scanning all of the shell\open\command registry keys.

    An old trick is to to add a NoOpenWith REG_SZ value name to the application's subkey. For example, the following sample registry entry excludes MyProgram.exe from the Open With Dialog box:

    HKEY_CLASSES_ROOT
    ...
    Applications
    ...
    MyProgram.exe ---> add new String Value - NoOpenWith

    Windows will bypass this key and it will not appear in the Open With Menu.

    regards,

    rich
     
  13. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    i suggested that, but Close_Haul only wanted teh programs removed in the Open With box for one file type. that method removes it from the Open With dialog for all files.
     
  14. Rmus

    Rmus Exploit Analyst

    Joined:
    Mar 16, 2005
    Posts:
    3,943
    Location:
    California
    OK - I see that now.

    I would then try GroverH's solution.
     
  15. GroverH

    GroverH Registered Member

    Joined:
    May 10, 2006
    Posts:
    2,405
    Location:
    Massachusetts, USA
    Close_Hauled:
    Troubleshooting:
    1. The number of programs (or their names) listed in the "Open With" context menu should have no bearing on whether the programs function.
    2. From the Start/programs menu, open your company program. Then from inside the program, do a "file open" and browse to and open the image in question. If it fails to open, then either the program or the image has a problem. If it fails to open, then open another image editing program and re-open the same image again with the alternate program. If the image opens, then it would appear that the company program is at fault. If the image fails to open with the alternate program, then the image is at fault.
    3. It is also possible that the syntax is wrong on the "open with" option listing the company program". The command line program info should be enclosed in quotes and have a suffix of "%1" also inclosed in quotes--such as sample below:
    "C:\Program Files\Adobe\Photoshop Elements\PhotoshopElements.exe" "%1"
    Note the "%1" may or maynot require quotes--depending upon the program.
    4. All of the above changes are accessible thru the "Folder Options/File type/.tif extension/advanced" options You can make the Company program as the default value by clicking the program name and the default option setting.
     
Loading...
Thread Status:
Not open for further replies.