how do i get Privoxy to use a proxy?

Discussion in 'privacy technology' started by iceni60, Jan 4, 2006.

Thread Status:
Not open for further replies.
  1. iceni60

    iceni60 ( ^o^)

    Joined:
    Jun 29, 2004
    Posts:
    5,116
    hi, i just installed JAP and i want to tell Privoxy to use it. i found something in the config file under 5.1. forward and there's an example like this there:


    forward / anon-proxy.example.org:8080
    forward :443 .

    i think JAP uses port 4001 so if i have my browser setup to use Privoxy (811:cool: then will this be correct?

    forward / 127.0.0.1:4001
    forward :443 .
     
  2. Brinn

    Brinn Registered Member

    Joined:
    Aug 5, 2004
    Posts:
    181
    Location:
    Canada
    This is what I have for my Tor setup:
    Tor requires you to use SOCKS4a because it would leak DNS queries otherwise. I don't know if that's an issue with JAP. I think you could use the config as you have it and log your traffic while you do some test surfing and see how it goes.
     
  3. iceni60

    iceni60 ( ^o^)

    Joined:
    Jun 29, 2004
    Posts:
    5,116
    thanks, so this line below is only needed to stop the dns leak?, it just looks like it's telling it to use socks for port 53 like it forgets to otherwise, do you know if it's needed because of a bug? :
    forward-socks4a :53 127.0.0.1:9050 .

    i'll try what i wrote in the first post.
     
  4. Brinn

    Brinn Registered Member

    Joined:
    Aug 5, 2004
    Posts:
    181
    Location:
    Canada
    I did have a problem with DNS leaks but that appears specific to Tor. I've never used JAP but I can't find any links to problems in that regard. Anyway, that configuration was slightly altered from one I downloaded from Kye-U's site. I changed it so https requests don't go through Tor.
     
  5. iceni60

    iceni60 ( ^o^)

    Joined:
    Jun 29, 2004
    Posts:
    5,116
    it didn't work. i didn't have any access to the internet at all, it was totally dead. i think i had a 303 error, not sure though.

    i only guessed at port 4001 because that's what it is with Windows. here's a picture of the config file i edited.

    do you think this might work? probably not
    forward / *.*:4001
    forward :443 .
     

    Attached Files:

  6. iceni60

    iceni60 ( ^o^)

    Joined:
    Jun 29, 2004
    Posts:
    5,116
    i think i'll look it up. i just didn't think it would be easy to find, i've never heard of anyone using JAP on Linux, i like it that's why i want to use it.
     
  7. iceni60

    iceni60 ( ^o^)

    Joined:
    Jun 29, 2004
    Posts:
    5,116
    i just changed it to this (with a dot after 4001):
    forward / 127.0.0.1:4001 .
    forward :443 .

    now it's not being chained to Privoxy o_O i stopped and restarted everything but nothing has changed to how it was before. i'll try it agian tomorrow. thanks for the help.
     
  8. Brinn

    Brinn Registered Member

    Joined:
    Aug 5, 2004
    Posts:
    181
    Location:
    Canada
    I'm afraid I don't know enough about JAP to suggest how to configure Privoxy for it. I did get something out of this thread however. I played around with my config, first changing it to:
    I was trying to see if there was a DNS leak with this browsing http pages without that line that dealt with port 53. None occurred until I reached this page:

    http://www.darlor-watch.com/omega_watches_1.html

    I was wondering why this page was special. It turns out this page has links to secure Paypal pages and that caused a DNS leak (one which I had introduced by changing the config). So I changed it to:

    Basically eliminating the last 2 lines. No more DNS leaking that I could find. It may be that those lines were a vestige required in earlier versions of Tor/Privoxy/Firefox. Or it could be that there's a situation I haven't run into yet. I'll keep the original config as is, just in case.

     
  9. iceni60

    iceni60 ( ^o^)

    Joined:
    Jun 29, 2004
    Posts:
    5,116
    hi, your original config was like this:
    forward-socks4a / 127.0.0.1:9050 .
    forward :443 .
    forward-socks4a :53 127.0.0.1:9050 .

    not

    forward-socks4a / 127.0.0.1:9050 .
    forward-socks4a :443 127.0.0.1:9050 .
    forward-socks4a :53 127.0.0.1:9050 .

    just thought i'd point it out :D
     
  10. iceni60

    iceni60 ( ^o^)

    Joined:
    Jun 29, 2004
    Posts:
    5,116
    P2K can you help me? :'(

    if my version of JAP (anon-proxy) uses port 4001 should this work?

    forward / 127.0.0.1:4001 .
    forward :443 .

    my browser is set to use Privoxy:

    127.0.0.1:8118
     
  11. Brinn

    Brinn Registered Member

    Joined:
    Aug 5, 2004
    Posts:
    181
    Location:
    Canada
    Original as in the one I downloaded. :p If you don't forward https requests through the proxy, you'd get a DNS leak on any http page that has an https element in it (such as a link to Paypal). That could give away your IP on the remote end and a DNS query would go to your ISP's server on your end.

    Maybe you should try:

    forward-socks4a / 127.0.0.1:4001 .
     
  12. iceni60

    iceni60 ( ^o^)

    Joined:
    Jun 29, 2004
    Posts:
    5,116
    well, that just shows how much help i need! and how little i've really thought about it.

    i'm using Opera and i don't see a setting to use a socks. i think i might have to download something else to get it socksified. i find it too complicated to think about browser settings, proxy settings and anon-proxy settings never mind adding another proxy for socks support.

    i don't think jap has the leak though, i've never heard of it.

    i tried this but it doesn't work.

    forward / 127.0.0.1:4001 .

    i'll have a look at the jap forum.
     
Loading...
Thread Status:
Not open for further replies.