How can I prevent NoScript updating and resetting Firefox to default settings?

Discussion in 'other software & services' started by estervantes, Mar 19, 2010.

Thread Status:
Not open for further replies.
  1. estervantes

    estervantes Registered Member

    Joined:
    Nov 15, 2007
    Posts:
    44
    How can I prevent NoScript updating and resetting Firefox to default settings?
    I have tried Firefox Tools, Options, Advanced and unchecked Automatic Updates but to no avail as No Script always resets Firefox to default settings and directs me to its homepage during it frequent updates. And almost all of these updates are very minor and seem to serve as a pretext for NoSript to have its page opened. Apart from deleting NoSript, is there anything I can do to prevent its frequent updating?

    I know that "about:config" can be used to prevent browser redirection to the NoSript homepage, but what about the resetting to default settings? Does the updating avoid this fix by resetting Firefox to default settings?

    Thanks for your help.
     
  2. mvario

    mvario Registered Member

    Joined:
    Sep 16, 2008
    Posts:
    339
    Location:
    Haddonfield, IL
    I'd like to help, bu I've used NoScript for a couple of years now and haven't experienced any of those things.

    NoScript doesn't update all that often for me.

    When NoScript does update it has never reset any of my FireFox (or NoScript) settings.

    If I uncheck "Automatically check for updates to Addons" then Firefox doesn't check for updates for any of my addons, including NoScript.

    As for showing the release notes page after a NoScript update, they make it very easy to disable that on the Notifications tab by unchecking the box next to "Display the release notes on updates". I have that unchecked and never see the release notes page when it updates.

    I can't say why you experience the behavior with NoScript that you do, but I would guess there is probably something else at work, perhaps a conflict with another addon.
     
    Last edited: Mar 19, 2010
  3. HAN

    HAN Registered Member

    Joined:
    Feb 24, 2005
    Posts:
    2,080
    Location:
    USA
    Something is corrupt. I would save your bookmarks, make a note of the extensions you use and start totally fresh again, making extra sure your current/old profile is gone after you have uninstalled FF. It's happened to me once or twice over time and a fresh install has fixed all oddities...
     
  4. estervantes

    estervantes Registered Member

    Joined:
    Nov 15, 2007
    Posts:
    44
    Han and Mvario...thanks for your advice.

    I have edited Firefox about:config to stop redirection to the NoScript homepage and also I have unchecked "Display Release Notes on Update" as part of No Script options. I hope these changes are sufficient. If that doesn't work, I'll follow your advice and reinstall as suggested.
     
  5. lotuseclat79

    lotuseclat79 Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    5,096
    NoScript never updates automatically for me. I use the separate Firefox Add-on extension named, Update Notifier 3.0.11. It notifies me when there are updates to my extensions.

    No extension is updated unless I perform the action of installing all updates (a right-click option) to the update notifier icon for Firefox, or separately from the Tools>Add-ons window from Firefox.

    Last I checked, NoScript did not reset to default settings on update for me. Note: I use the Linux version of Firefox on Ubuntu 9.10 (Karmic Koala).

    -- Tom
     
Loading...
Thread Status:
Not open for further replies.