Hotmail Full Session SSL has arrived

Discussion in 'other software & services' started by BoerenkoolMetWorst, Nov 5, 2010.

Thread Status:
Not open for further replies.
  1. BoerenkoolMetWorst

    BoerenkoolMetWorst Registered Member

    Joined:
    Dec 22, 2009
    Posts:
    3,771
    Location:
    Outer space
    As the thread title states, Full Session SSL is finally here for Hotmail :) It's not available in the options yet, but if you go to httpS://hotmail.com, then it will use full session SSL and you can set it to SSL as default.

    If anyone could help me out, when trying to set SSL as default it gives an error message: (freely translated from Dutch) This Windows Live ID cannot automatically use HTTPS because this function is not available for this type of account.
    I have a standard email account so I don't know what could be wrong :S
     
  2. CloneRanger

    CloneRanger Registered Member

    Joined:
    Jan 4, 2006
    Posts:
    4,833
    I heard they were progressively rolling it out, so :thumb:

    I always use their HTTPS to login, and today that's all i got, not full session :(

    I also have a standard email account so I don't know what's going on either ?
     
  3. Cudni

    Cudni Global Moderator

    Joined:
    May 24, 2009
    Posts:
    6,956
    Location:
    Somethingshire
    I've got the same message like you did. The only thing I can think of is that I'm indeed using LiveMail + other things listed as possible cause why https can't be enabled automatically. On the other hand it could simple be a bug
     
  4. BoerenkoolMetWorst

    BoerenkoolMetWorst Registered Member

    Joined:
    Dec 22, 2009
    Posts:
    3,771
    Location:
    Outer space
    According to MS, if the automatic use of SSL gives that error, then it is because SSL is not fully 'rolled out' yet on the server of your account. Anyway, mine is now and it works :)

    @cloneranger
    For full session SSL you have to go to https://hotmail.com, then it will redirect you to a secure connection after loggin in. If that doesn't work you could also try adding *.live.com to the HTTPS enforcing list of NoScript if you use it.
     
  5. CloneRanger

    CloneRanger Registered Member

    Joined:
    Jan 4, 2006
    Posts:
    4,833
    @ BoerenkoolMetWorst

    Hi, i'll try the EXACT www etc you gave https://hotmail.com & let you know what happened.

    As i mentioned i do use HTTPS to log into hotmail but it's this one https://login.live.com/login.srf I would have expected that to work ! So i'll see what the other one does.

    Thanks :)
     
  6. Warlockz

    Warlockz Registered Member

    Joined:
    Oct 30, 2008
    Posts:
    642
    Are you using a proxy or VPN?

    Full-session SSL for Hotmail is here!
    HTTPS-on-Hotmail_thumb.png
    After you login this is the settings page to enable full SSL
    https://account.live.com/ManageSSL

    I tried this and it protected just about everything in windows live account but I couldn't access my mail until I disabled it, does anybody else have this issue?
     
  7. Warlockz

    Warlockz Registered Member

    Joined:
    Oct 30, 2008
    Posts:
    642
    Smash the last post, I just logged into my live account and it automatically asked me if I would like to use the full SSL feature, now I can access mail with SSL Protection without any problems.

    I think their just updating servers and your problems will be solved soon.

    Make sure to login threw the live site and it should ask if you want to use Full SSL right after you login.

    https://login.live.com/
     
  8. BoerenkoolMetWorst

    BoerenkoolMetWorst Registered Member

    Joined:
    Dec 22, 2009
    Posts:
    3,771
    Location:
    Outer space
    @Warlockz
    As I said in my second post, it works for me now, and didn't before because the server wasn't fully updated.

    @CloneRanger
    Any results?
     
  9. CiX

    CiX Registered Member

    Joined:
    Feb 22, 2010
    Posts:
    404
  10. J_L

    J_L Registered Member

    Joined:
    Nov 6, 2009
    Posts:
    8,516
    Ugh, still the same damned error message: Your Windows Live ID can't use HTTPS automatically because this feature is not available for your account type.
     
  11. acuariano

    acuariano Registered Member

    Joined:
    Nov 4, 2005
    Posts:
    786
    yeah me too,got the same error message
     
  12. BoerenkoolMetWorst

    BoerenkoolMetWorst Registered Member

    Joined:
    Dec 22, 2009
    Posts:
    3,771
    Location:
    Outer space
    @CiX
    That is because you are on bl142w.blu142.mail.live.com but the certificate is specifically for mail.live.com, that is quite negligent from MS, but as the domains are both from MS, there shouldn't be any harm in allowing them.

    @J L
    @acuariano
    That is because the servers where your accounts are located are not yet fully upgraded, until they are you could just click continue to Hotmail every time and then you also have full session SSL, but you just have to click one time extra every time you login.
     
  13. CloneRanger

    CloneRanger Registered Member

    Joined:
    Jan 4, 2006
    Posts:
    4,833
    For the first time, today i actually got the full SSL option :thumb: Except as others have said

    hot.gif

    Don't know why some of the text is wonky, maybe i need to allow more scripts and/or requests ?

    Anyway i went ahead and to my surprise i was logged in all the time in full SSL :)

    We'll see how it goes.
     
  14. BoerenkoolMetWorst

    BoerenkoolMetWorst Registered Member

    Joined:
    Dec 22, 2009
    Posts:
    3,771
    Location:
    Outer space
    Possibly, I have live.com, hotmail.com and wlxrs.com allowed, otherwise hotmail won't work properly for me.
     
  15. Cudni

    Cudni Global Moderator

    Joined:
    May 24, 2009
    Posts:
    6,956
    Location:
    Somethingshire
    check the user agent string, it might not be standard
     
  16. CloneRanger

    CloneRanger Registered Member

    Joined:
    Jan 4, 2006
    Posts:
    4,833
    OK thanks :)

    Good thinking, i did & normal :thumb:

    *

    Fuuny thing, i have several accounts & some sailed through just fine, but the others showed the error, but still worked ! And this was with the same browser & settings etc ?

    I guess it's just teething problems ?
     
  17. BoerenkoolMetWorst

    BoerenkoolMetWorst Registered Member

    Joined:
    Dec 22, 2009
    Posts:
    3,771
    Location:
    Outer space
    Like I already said 3 times :D before in this thread, if it gives that error it is because the server your account is stored on is not yet fully updated with the new full session SSL. So some of your accounts are on servers already updated, and some not ;)
     
  18. CloneRanger

    CloneRanger Registered Member

    Joined:
    Jan 4, 2006
    Posts:
    4,833
    Indeed you did ;)

    Like I already said 1 time before in this thread

    :D
     
Loading...
Thread Status:
Not open for further replies.