HitmanPro.ALERT Support and Discussion Thread

Discussion in 'other anti-malware software' started by erikloman, May 25, 2012.

  1. digmor crusher

    digmor crusher Registered Member

    Joined:
    Jul 6, 2012
    Posts:
    908
    Location:
    Canada
    Some bugs.

    After installation I entered the license key, no problems.

    Next time I started computer the Exploit Mitigations were off and the license key was gone, entered license key again, no problems.

    Next time I started computer icon was gone from task bar and Chrome would not open.

    Uninstalled for now, I will not use anything that does not work perfectly on my computer.
     
  2. deugniet

    deugniet Registered Member

    Joined:
    Nov 25, 2013
    Posts:
    982
    Twice a BSOD this morning during startup laptop (W7 64 bits). Uninstalled CTP4.
     
  3. Brandonn2010

    Brandonn2010 Registered Member

    Joined:
    Jan 10, 2011
    Posts:
    1,853
    Yep me too, where do I send my minidumps?
     
  4. DouweG

    DouweG Registered Member

    Joined:
    Jan 30, 2013
    Posts:
    13
    Location:
    Netherlands
    Hi Mark and Erik,

    Keep up the good work!
    I reïnstalled W7 pro last month because I had a lot of BSOD's. HMPA CTP3 gave a BSOD a couple of times last week. Unfortunately I didn't get a minidump to send you (I instructed windows to make them, so I still have to find out why it didn't make any).
    HMPA CPT4 is working fine so far! I just bought a new lincense for 3 years now because the old one almost ended.

    I have to turn of control flow integrity when I want to print from adobe reader 11 with my canon MG3250 printer. Need this to be fixed or should control flow integrity be turned off here?
    Thanks,

    Douwe
     
  5. deugniet

    deugniet Registered Member

    Joined:
    Nov 25, 2013
    Posts:
    982
    Erik, sent you a mail with Wer-info of yesterday's BSOD.
     
  6. DouweG

    DouweG Registered Member

    Joined:
    Jan 30, 2013
    Posts:
    13
    Location:
    Netherlands
    Hi Erik,

    I just send you a minidump file (which windows succesfully made now) because I just got a BSOD. When I get a BSOD, it only happens when HMPA CTP3 or 4 is installed and HMP scans. It always happens in the last minisecond of scanning at 99 % (a short moment right before HMP is finished).

    Douwe
     
  7. BoerenkoolMetWorst

    BoerenkoolMetWorst Registered Member

    Joined:
    Dec 22, 2009
    Posts:
    4,540
    Location:
    Outer space
    I don't know if this is intentional behaviour or not, but when I disable all migitations for a process, they are enabled again after a reboot.
     
  8. erikloman

    erikloman Developer

    Joined:
    Jun 4, 2009
    Posts:
    3,152
    Location:
    Hengelo, The Netherlands
    That is a bug. Thanks for reporting :thumb:
     
  9. erikloman

    erikloman Developer

    Joined:
    Jun 4, 2009
    Posts:
    3,152
    Location:
    Hengelo, The Netherlands
    HitmanPro.Alert 3 CTP4 build 91

    Thank you all for reporting on the CTP4 release. Much appreciated and the sole reason for publishing builds here at Wilders Security Forum. You guys are proficient in finding and reporting issues (including providing dumps).

    In an effort trying to find the cause of the BSOD, I found a problem resulting the Alert service to crash (and restart). This crash may lead to slowdown when starting a new process.
    While the crash of the service is not the root cause of the reported BSOD, it may still be the trigger for the BSOD to occur.

    I also fixed a bug where disabling mitigation is not remembered between reboots (as reported here).

    Download
    http://test.hitmanpro.com/hmpalert3b91.zip

    Please let me know this version runs on your computer :thumb:
     
  10. Adric

    Adric Registered Member

    Joined:
    Feb 1, 2006
    Posts:
    1,459
    For the previous Beta, the SafetyNotifications checkmark may at some time disappear and you will no longer get the flyout. Setting the check mark doesn't work because the next time you look at the setting, it is no longer checked. As mentioned before, there is no green box around the GUI even when checked. This is on W7
    SafetyN.jpg
     
    Last edited: Oct 5, 2014
  11. erikloman

    erikloman Developer

    Joined:
    Jun 4, 2009
    Posts:
    3,152
    Location:
    Hengelo, The Netherlands
    This happens when the service has crashed. Try build 91 (see above) to see if this is resolved.
     
  12. Adric

    Adric Registered Member

    Joined:
    Feb 1, 2006
    Posts:
    1,459
    Total system slow-down on W7 with CTP91. This version is worse than the last. I see crashes in the event viewer, but no dumps. System is becoming unusable.. I managed to stop the service, but the system is still slow as molasses.
     

    Attached Files:

    Last edited: Oct 5, 2014
  13. erikloman

    erikloman Developer

    Joined:
    Jun 4, 2009
    Posts:
    3,152
    Location:
    Hengelo, The Netherlands
    As stated before, process slow down when service crashes. It should not crash though. Grmbl. I will take a look at the above issue.

    Note: I run this build on several systems without issues. But that was also the case with build 90. The bug seems to trigger in combination with other security software.
     
    Last edited: Oct 5, 2014
  14. Adric

    Adric Registered Member

    Joined:
    Feb 1, 2006
    Posts:
    1,459
    Okay, the funny thing is, when I stopped the service, the slow-down on my system did not stop even though HMPA was disabled. Once I restarted the service, the OS was no longer slow. Go figure. You should try and test with those programs that I sent you. In my case, they seem to be a catalyst for HMPA's bad behavior
     
  15. Peter2150

    Peter2150 Global Moderator

    Joined:
    Sep 20, 2003
    Posts:
    20,590
    If you didn't take MBAE off that could be the problem. You might try it again with MBAE uninstalled.

    Pete
     
  16. deugniet

    deugniet Registered Member

    Joined:
    Nov 25, 2013
    Posts:
    982
    Ok, installed build 91. Ill report back if a BSOD should (re)occur (I hope not).
     
  17. Adric

    Adric Registered Member

    Joined:
    Feb 1, 2006
    Posts:
    1,459
    Erik, sending you another W7 BSOD for CTP91. Wanted to launch fileman and bang... Not sure how it is related, but the crash was in the Named Pipe File System (npfs.sys)

    Edit: Sending another one your way. This time for hmpalert.sys
     
  18. Tarnak

    Tarnak Registered Member

    Joined:
    Feb 5, 2007
    Posts:
    4,960
    I am running v3.0.15 build 91. But, had a hiccup on uninstalling build 90.

    ScreenShot_HMP.A_3.0.15 build 90_uninstall_01.gif
     
  19. erikloman

    erikloman Developer

    Joined:
    Jun 4, 2009
    Posts:
    3,152
    Location:
    Hengelo, The Netherlands
    HitmanPro.Alert 3 CTP4 build 92

    :eek: I made a mistake in build 91 causing the Alert service to crash when launching apps from a short path (for example, C:\some.exe).

    Hereby build 92.

    Download
    http://test.hitmanpro.com/hmpalert3b92.zip

    Please let me know this version runs on your computer :thumb:
     
  20. Peter2150

    Peter2150 Global Moderator

    Joined:
    Sep 20, 2003
    Posts:
    20,590
    Will test in a couple of hours. I've encountered a network issue and thought I knew what it was, so I need to test more thoroughly.

    Pete
     
  21. deugniet

    deugniet Registered Member

    Joined:
    Nov 25, 2013
    Posts:
    982
    Installed build 92, no problems so far (W7 64 bits).
     
  22. TheQuest

    TheQuest Registered Member

    Joined:
    Jun 9, 2003
    Posts:
    2,304
    Location:
    Kent. UK by the sea
    Build 92 CTP4 seem to be working [near] perfectly so for, i.e. no BSOD :thumb:

    Take Care
    TheQuest :cool:
     
  23. XIII

    XIII Registered Member

    Joined:
    Jan 12, 2009
    Posts:
    1,059
    Yes, that was with build 90, but it happens with build 92 as well:
    Code:
    Faulting application name: iTunes.exe, version: 11.4.0.18, time stamp: 0x54045c47
    Faulting module name: hmpalert.dll, version: 3.0.15.92, time stamp: 0x54315e16
    Exception code: 0x80000001
    Fault offset: 0x00004355
    Faulting process id: 0x1698
    Faulting application start time: 0x01cfe0dad26c3d18
    Faulting application path: C:\Program Files (x86)\iTunes\iTunes.exe
    Faulting module path: C:\Windows\SysWOW64\hmpalert.dll
    Will send a dump via WeTransfer and PM the password.
     
  24. digmor crusher

    digmor crusher Registered Member

    Joined:
    Jul 6, 2012
    Posts:
    908
    Location:
    Canada
    Pete, I did uninstall MBAE, just too lazy to update my sig.:rolleyes:
     
  25. Adric

    Adric Registered Member

    Joined:
    Feb 1, 2006
    Posts:
    1,459
    The last build fixed the problems I've been having. Still no green border around the browser GUI though,:D
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.