High CPU usage after long idle times

Discussion in 'ESET Smart Security' started by caqde, Mar 28, 2012.

Thread Status:
Not open for further replies.
  1. caqde

    caqde Registered Member

    Joined:
    Oct 7, 2011
    Posts:
    5
    When my computer is running idle for a while (no screen saver) ekrn.exe will use 50% of my processor for a randomly long period of time after waking the computer up. I have been trying to find out what it is doing during this time period the only things I have found out are that it is writing to epfwdata.bin and HipsRules.bin in the ProgramData directory according to the resource monitor. Which is not normal as it doesn't do this at any other time or at least not for long periods of time. Process Explorer also shows 3 DLL files that are using excessively large amounts of CPU cycles during this time ekrnEpfw.dll + 0x13d20 and two that are tagged as ekrnAmon.dll + 0xcf50. The cycle usage for these (Amon) is in the couple of Trillions while the Epfw is in the Hundreds of Trillions. Epfw spends most of its time in the kernal (75%) while the others spend 90%+ in user.

    I'm not sure why it is doing this and I have tried shutting off or disabling certain applications I use along with disabling Eset (AV+Firewall) to no avail it doesn't seem to be looking at any particular file on my computer.

    System:

    Eset Smart Security 5.0.95.0 (VS 700:cool: Valid License
    Windows 7 x64 SP1 Current patches
    Phenom II 925 (2.8ghz x4 no OC)
    16GB DDR3
    Asus M5A99X
    XFX HD5770 1GB (no OC)
     
  2. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Do you use a memory card reader? Does disabling real-time protection and (or) HIPS make a difference?
     
  3. caqde

    caqde Registered Member

    Joined:
    Oct 7, 2011
    Posts:
    5
    No memory card reader, no USB based storage devices have been connected to the computer during this time period. I have disabled realtime protection before. I will try disabling HIPS during the night to see if it makes a difference and see if it acts up when I go to use it again.
     
  4. caqde

    caqde Registered Member

    Joined:
    Oct 7, 2011
    Posts:
    5
    Well I disabled HIPS and it seems to have fixed the problem. Although I would prefer to be able to keep HIPS enabled as it is part of the AV software. Is there a way to get HIPS setup so that it works without using so much unnecessary computing power when nothing is going on.
     
Thread Status:
Not open for further replies.