Help with xbox connection to PC

Discussion in 'ESET Smart Security' started by growman, Jun 16, 2011.

Thread Status:
Not open for further replies.
  1. growman

    growman Registered Member

    Joined:
    Jun 16, 2011
    Posts:
    4
    Hi,

    Ive just upgraded to windows 7 after using XP for a fair few years (with everything work as I wanted) but I now have a problem

    I'm trying to connect my xbox up with my computer via two programs, Windows media centre and Tversity. Tversity worked flawlessly in XP but for some reason neither are connecting if ess is on (firewall side) if its off they both connect.

    Both computer and xbox are in the "address excuded from active protection (IDS)" and programs allowed in the rules for both directions TCP and UPD.

    As I am aware it is the latest version of ESS (downloaded from website yesterday).

    Like I said above if I turn the firewall off they both connect without a problem, but I dont really want to turn firewalls off so I can watch movies / play music on the xbox.

    If anyone has any ideas I would be greatfull.

    Below are some of the kinds of logs Im getting so far.

    Code:
    16/06/2011 15:10:30	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    16/06/2011 14:56:27	No usable rule found	65.175.38.194:80	192.168.1.64:50142	TCP			
    16/06/2011 14:55:18	Communication denied by rule	192.168.1.64:51573	239.255.255.250:1900	UDP	Block incoming SSDP (UPNP) requests	C:\ProgramData\TVersity\Media Server\MediaServer.exe	NT AUTHORITY\SYSTEM
    16/06/2011 14:55:16	Communication denied by rule	::1.:50117	::1.:2869	TCP	Block outgoing ICSLAP (UPNP) requests	C:\Program Files\Windows Media Player\wmpnetwk.exe	NT AUTHORITY\NETWORK SERVICE
    16/06/2011 14:54:27	Communication denied by rule	192.168.1.64:1900	239.255.255.250:1900	UDP	Block incoming SSDP (UPNP) requests	C:\ProgramData\TVersity\Media Server\MediaServer.exe	NT AUTHORITY\SYSTEM
    16/06/2011 14:33:36	Packet blocked by active defense (IDS)	192.168.1.69	192.168.1.69	ARP			
    The no usable rule found is constant (every 2 seconds)

    Cheers
     
  2. dwomack

    dwomack Eset Staff Account

    Joined:
    Mar 2, 2011
    Posts:
    588
    It may help to set your Firewall filtering mode to "Interactive Mode" and try connecting. Each time the ESET window pops up, click 'Remember action (create rule)' and then 'ALLOW'. Once you have a good connection, then you can reset the firewall filtering mode to 'Automatic mode with exceptions' to save the rules you just created.

    You should also verify that under the protection mode, you're set to 'Allow Sharing' and also that UPnP is selected under the list of 'Allowed services'.

    All of these steps are covered in the following KB Article:

    http://kb.eset.com/esetkb/index?page=content&id=SOLN2141
     
  3. growman

    growman Registered Member

    Joined:
    Jun 16, 2011
    Posts:
    4
    Hi,

    Sorry I was just on my way back to edit my post to inform that upnp is ticked in the IDS (actually everything is lol)
    I do use interactive mode (and have also tried learning mode)
    My Xbox's IP is also in the trusted zone

    Edit
    And allow sharing is on :)
     
  4. growman

    growman Registered Member

    Joined:
    Jun 16, 2011
    Posts:
    4
    Is there any reason why Eset SS would ignore an IP in the IDS, because that is what its doing and I believe thats why I cant connect to the xbox via the pc.

    This has only happend since installing windows 7 64bit, is there a known issue with this?

    Its the same in ESS 5 RC as I thougt it might be related to ESS 4 so uninstalled and re-installed 5 fresh but still with no luck and still the same things in the logs

    Code:
    17/06/2011 13:05:44	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    17/06/2011 13:05:42	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    17/06/2011 13:05:36	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    17/06/2011 13:03:40	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    17/06/2011 13:03:38	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    17/06/2011 13:03:32	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    17/06/2011 13:01:33	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    17/06/2011 13:01:29	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    17/06/2011 13:01:26	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    17/06/2011 12:59:29	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    17/06/2011 12:59:25	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    17/06/2011 12:59:22	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    17/06/2011 12:59:14	Packet blocked by active defense (IDS)	192.168.1.69	192.168.1.69	ARP			
    17/06/2011 12:59:13	Packet blocked by active defense (IDS)	192.168.1.69	192.168.1.69	ARP			
    17/06/2011 12:59:12	Packet blocked by active defense (IDS)	192.168.1.69	192.168.1.69	ARP			
    17/06/2011 12:59:11	Packet blocked by active defense (IDS)	192.168.1.69	192.168.1.69	ARP			
    17/06/2011 12:59:10	Packet blocked by active defense (IDS)	192.168.1.69	192.168.1.69	ARP			
    17/06/2011 12:59:09	Packet blocked by active defense (IDS)	192.168.1.69	192.168.1.69	ARP			
    17/06/2011 12:57:17	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    17/06/2011 12:57:16	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    17/06/2011 12:57:16	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    17/06/2011 12:55:18	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    17/06/2011 12:55:17	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    17/06/2011 12:55:11	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    17/06/2011 12:53:39	Packet blocked by active defense (IDS)	192.168.1.69	192.168.1.69	ARP			
    17/06/2011 12:53:38	Packet blocked by active defense (IDS)	192.168.1.69	192.168.1.69	ARP			
    17/06/2011 12:53:37	Packet blocked by active defense (IDS)	192.168.1.69	192.168.1.69	ARP			
    17/06/2011 12:53:36	Packet blocked by active defense (IDS)	192.168.1.69	192.168.1.69	ARP			
    17/06/2011 12:53:35	Packet blocked by active defense (IDS)	192.168.1.69	192.168.1.69	ARP			
    17/06/2011 12:53:34	Packet blocked by active defense (IDS)	192.168.1.69	192.168.1.69	ARP			
    
    Two attempts to connect above

    Its just like I have NETBIOS Name service unticked in the settings but I still get them being blocked too

    Code:
    17/06/2011 13:07:27	Communication denied by rule	192.168.1.64:137	95.100.194.70:137	UDP	Block NETBIOS Name Service requests	System	
    17/06/2011 13:07:27	Communication denied by rule	192.168.1.64:137	95.100.194.70:137	UDP	Block NETBIOS Name Service requests	System	
    17/06/2011 13:07:27	Communication denied by rule	192.168.1.64:137	95.100.194.70:137	UDP	Block NETBIOS Name Service requests	System	
    
     
    Last edited: Jun 17, 2011
  5. growman

    growman Registered Member

    Joined:
    Jun 16, 2011
    Posts:
    4
    Thank you for your help, NOT

    For anybody else who has had this problem.....

    DO NOT RING SUPPORT (well especially in the UK) they spent half an hour remotely connected to my computer to only fail (yes they got it connect, but when i tried to connect again later on last night it failed, again, and again, and again. My suspicion is that while I was at the xbox following what I was told (trying to connect and relaying what it was saying) that the firewall was turned off to give the xbox enough time to connect then turned back on again.) they had messed up the firewall that much that even in interactive mode programs that did not have a rule were allowed to connect!

    Heres what Ive done....

    In the logs I noticed a IP keep croping up.....

    Code:
    19/06/2011 01:14:57	No usable rule found	192.168.1.65	224.0.0.22	IGMP		System	
    
    (If you notice on my first post the majority of the log was this IP addy)

    I googled it to find a wiki page
    http://en.wikipedia.org/wiki/Multicast_address

    To find this information out

    So I added a rule to allow any coms on any port for any application to that IP

    I disabled the ARP in the IDS

    I also have my Xbox's IP in the exclude from IDS (even though with the above enabled I get packets blocked registering from the xbox IP)

    It works and with out any problems so far.


    Granted its taken me a few days to figure this out with so called support thinking they know how to do it and failing with the biggest style I have ever known, but at least its working now.
     
Thread Status:
Not open for further replies.