[Help] Sandboxie Recovery doesn't work at all?

Discussion in 'sandboxing & virtualization' started by Hodor123, Aug 22, 2020.

  1. Hodor123

    Hodor123 Registered Member

    Joined:
    Aug 21, 2020
    Posts:
    1
    Location:
    California
    Hi guys, I can't seem to get recovery with sandboxie to work - was hoping someone here could help with it.

    Specifically I'm running an app that will creates and overwrites a text file (.txt) numerous times in it's life time, which resides in the %AppData% directory.

    If possible, I want the file to be recovered on change.
    If not, when the app exit (and manually) is also fine.

    I tried adding the specific sub directory in Sandbox Settings -> Recovery -> Quick Recovery.
    Also made sure [.txt] is not in immediate recovery exclusion list.

    However, only once the app exits (not during though) I get a prompt about recovery,
    And even then when clicking Recover, the file isn't being recovered.

    Any ideas?

    p.s.
    I'm running Sandboxie as another user (Created a shortcut with `C:\Windows\System32\runas.exe /savecreds /user:\theruser "D:\Program Files\Sandboxie\Start.exe D:\App\MyApp.exe"`), if it matters.
     
  2. Brummelchen

    Brummelchen Registered Member

    Joined:
    Jan 3, 2009
    Posts:
    3,583
    %appdata% is limited to the corresponding user, no one else (except users with admin rights but in that case sandboxie is futile)
     
  3. bo elam

    bo elam Registered Member

    Joined:
    Jun 15, 2010
    Posts:
    5,831
    Location:
    Nicaragua
    Try allowing Direct File Access to the text file in Sandbox settings.

    Sandbox settings>Resource access>File access>Direct access, Click Add progran to add the program that creates the text file, Click Add , for navigating to the text file, select to add it.

    Bo
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.