Help me for: eTrust PestPatrol

Discussion in 'other anti-virus software' started by woobook, Nov 8, 2005.

Thread Status:
Not open for further replies.
  1. woobook

    woobook Registered Member

    Joined:
    Oct 27, 2005
    Posts:
    131
    My system is XP, and I have eTrust PestPatrol one free. When I login a limited account, it said:
    <<
    The 'User Account' that you logged into the computer with, does not have the required settings to enable eTrust PestPatrol to change files on your computer. This means eTrust PestPatrol is unable to create logs, change registry settings or quarantine pests. You must consult the computer owner to enable eTrust PestPatrol to run with this user account.
    >>
    Then I read the Help document of eTrust PestPatrol, in part Troubleshooting, User Permissions, it said:
    <<
    To run eTrust PestPatrol with full functionality, you must have the following read/write permissions:
    -----------------------------------
    * Write permission to HKEY_CLASSES_ROOT hierarchy in your computer's registry
    * Create or write permission to the directory where you installed eTrust PestPatrol directory (typically C:\Program Files\CA\eTrust PestPatrol)
    * Create or write permission to C:\Documents and Settings\All Users
    ----------------------------------
    Note: Without these permissions you cannot create log entries or quarantine pests.
    >>

    But I still don't know how to do, anybody help me?
     
  2. Cscampxp

    Cscampxp Registered Member

    Joined:
    Oct 25, 2005
    Posts:
    34
    Are you logged on as a "User" or "Administrator"? If you're logged on as "User" then that means that you just have a limited account. Meaning you don't have permissions to modify system settings and in your case unable to create logs, change registry settings and quarantine pests.

    You can either log off and log back in as "Administrator" or as a "Power User" for example that has read and write permissions to a program.

    or you can do a secondary logon "run as"....Right click the Pest Patrol icon and then select "run as" ..select following user and use your Administrator account and Password and then hit ok. You should be able to use Pest Patrol with no problem after that.
     
    Last edited: Nov 9, 2005
  3. woobook

    woobook Registered Member

    Joined:
    Oct 27, 2005
    Posts:
    131
    Thanks for your reply.
    I usually log on limited user account to surf. I think that PestPatrol should startup when I log on. So according PestPatrol Help document, I log on Administrator account and run the regedit. In the regedit I don't know how to
    "Create or write permission to ..." like the guard said above.
     
  4. Cscampxp

    Cscampxp Registered Member

    Joined:
    Oct 25, 2005
    Posts:
    34
    It's a good practice that you use a limited account when you're just surfing. For added security, you should also use a password when logging in your "User" account that's if you haven't done that already. Nway, There's a lot ways we can do to solve your problem...You'll be glad to hear that you dont have to (regedit) edit the registry to have read and write permissions. I wouldnt even recommend doing that unless you really know what you're doing. A simple mistake in the registry can make your system very unstable.

    But First, i need to know which XP operating system are you running? XP Home or XP Pro? When you say limited account... do you mean a "User" with limited permissions or a "Guest" account?

    When you said "you think PestPatrol should start up when you log on" Do you mean it doesnt start when you're logged on as what? a "user" or both as a "User" and "Administrator"? Assuming that you installed it with your Administrator Account...Did you set it to run on start-up when it was installed? coz by default, PestPatrol is set to "stop" active protection...If it is, then you're going to have to log in using your Admin account...open Pest Patrol, then go to Advanced Settings, and then go in Active Protection and check the "Start active protection when my computer starts"...hit apply and then okay.
    Now everytime you start your computer PestPatrol will start whether or not you're logged on as a "User" or as an "Administrator" or even just a "Guest"

    But like what i said before, if you're still logged on as a "User" you're Pest Patrol will run on start-up but you still wont be able to change the settings in Pest Patrol. This is when "permissions" comes in...This is why i asked you if you're using XP Home or XP Professional?

    If you're using XP home, as long as you're using a "Guest" account, you're not going to be able to change the settings in PestPatrol or pretty much everything else coz it's just a limited account. However, like what i said, you can do a secondary logon..."run as" Have you tried doing thato_O Once you're logged on as a "Guest or one with limited account" you can right click an application icon...in your case, right click the PestPatrol icon and then select "run as" ..the following account: use your Administrator account and Password and hit ok. After doing that you should be able to have "full control" which includes read and write permissions of PestPatrol App. Another way, is you can simply create another account with Administrative rights.

    YOu can do the same thing If you're using XP Pro...but in XP Pro you can also set "permissions" for pretty much every document, folder and even an Application. Log in using your Admin account and set these permissions by right clicking a document, folder or Program icon (right-click PestPatrol icon)and click the properties...go to the "Security" tab. Simply add the "User" account in the list...and in the permissions allow "Full control" and click ok. Now everytime you're logged on as a "User" you have full control of the program. No need to log off and log back in as an Admin or no need to do "run as"...Remember! you can only set these permissions if you're using XP Pro.

    Hopefully i got your question right. if not then just let me know.
     
    Last edited: Nov 10, 2005
  5. woobook

    woobook Registered Member

    Joined:
    Oct 27, 2005
    Posts:
    131
    Thanks Cscampxp, your explain is very clearly.
    My computer system is XP Home. I have an administer account which is used to install some software and update system, and I also have some limited accounts which are used in some different use. I almost dont use the function "run as" so I closed this service.
    I install PestPatrol in administer account, and already start the Active protection. When I log on a limited user account, the windows start up and a "pop-up" alert show me :
    -----------------------------------------------------------------
    The 'User Account' that you logged into the computer with, does not have the required settings to enable eTrust PestPatrol to change files on your computer. This means eTrust PestPatrol is unable to create logs, change registry settings or quarantine pests. You must consult the computer owner to enable eTrust PestPatrol to run with this user account.
    -----------------------------------------------------------------
    After I click "OK", then PestPatrol begin to run and its icon appears in the taskbar. The Active protection is running, also I can run the scan. It is enough, if I find any pest, I can clear it.
    But now, I don't want the "alert" pop-up at the start up, I want it begin running without my clicking the "OK". So I dont know how to do.

    Another question is, if I use the computer myself, do I still need to use a password for a limited user account?
     
Loading...
Thread Status:
Not open for further replies.