Hellgate: London Connection Issues

Discussion in 'ESET Smart Security' started by Anth-Unit, Nov 5, 2007.

Thread Status:
Not open for further replies.
  1. Anth-Unit

    Anth-Unit Registered Member

    Joined:
    Oct 13, 2006
    Posts:
    108
    After installing Eset Smart Security I've been experiencing a disconnect at random time within the game. It happens usually 5-10 minutes after connecting to the game. I've added the game and the games folder to the exclusion list and that didn't seem to fix things. I'm running in interactive filtering mode and have allowed everything related to hellgate to connect to the internet. I didn't have this problem prior to installing Eset Smart Security.

    One thing I noticed from looking at the firewall logs:

    The connections that hellgate seems to be making:

    http://img.photobucket.com/albums/v602/anthunit/connections.jpg

    Ok, look at the red text. It says that it has detected an attack coming from this ip, which seems to be the same one that the Hellgate: London client is connecting to.

    http://img.photobucket.com/albums/v602/anthunit/Blocked.jpg

    The strange thing is that this is the only item of its kind in the log. All the other times I've been disconnected, it didn't record anything. I'm not sure if any of the other items in the log are related, but the application being blocked in most of them is c:\windows\system32\svchost.exe. This particular item comes up whether im playing hellgate or not.

    Is there anything else I can do to stop this from happening?

    *update*

    The message in red has started to show up every time I get disconnected.

    It says: 11/5/2007 10:55:14 PM Detected Reverse TCP Desynchronization attack 72.172.236.39:4306 192.168.0.162:50238 TCP

    Is there any way I can stop ESS from blocking this connection?
     
    Last edited: Nov 5, 2007
  2. Anth-Unit

    Anth-Unit Registered Member

    Joined:
    Oct 13, 2006
    Posts:
    108
    Help please!
     
  3. Pfipps

    Pfipps Registered Member

    Joined:
    May 15, 2007
    Posts:
    181
    I don't know why eset forgot to put in a game mode setting. I am sure competitors look at each others programs.
     
  4. Ocwan

    Ocwan Registered Member

    Joined:
    Oct 11, 2006
    Posts:
    8
    Location:
    In a house, on some street
    Do you know what port numers the game uses?

    Have you added those to the firewall?

    Try turning off the firewall completely and play the game, if it works then I would find out what ports the game needs to play on the WAN side and add that to the firewall.
     
  5. Anth-Unit

    Anth-Unit Registered Member

    Joined:
    Oct 13, 2006
    Posts:
    108
    As far as I know, all I'm required to do is allow it to connect out when I'm prompted to by the eset security. It's able to connect out, it just seems to be blocking something that the game is sending to me so I get disconnected. And it does work perfectly when I disable the firewall.
     
  6. Ocwan

    Ocwan Registered Member

    Joined:
    Oct 11, 2006
    Posts:
    8
    Location:
    In a house, on some street
    Hello,
    Exactly, you gave the ports permission to connect outward; you have not given the firewall permission to "allow" inward.

    Client / Server applications (Good ones) always change ports for security reasons. Once a connection is established, either of the two will initiate a new port number, the reason for "port rotations" is so that something else or someone cannot "packet" or "sniff" the communications. (Server will ask the client "meet me on 10,465", client will accept and move to that new port, over time the client may ask the server "meet me on 4095" making it tough to sniff data streams.

    As far as gaming, I am sure the ports are solid as there is no gain from someone sniffing the packets from your game, its not like its online banking :)

    Try adding a filter to allow ports 4306 and 50238 TCP and UDP and see if that works.

    Cheers
    P.S. If those are NOT the correct ports for your game, I would research what ports it in fact does need.
     
  7. Anth-Unit

    Anth-Unit Registered Member

    Joined:
    Oct 13, 2006
    Posts:
    108

    I'll try this, but ESS has always asked me in the past if I want to allow an application to accept inbound connections. It's done it with several other games without issue. Why would this particular game be any different? It's even worked for me in games where I have to be the host (which is not the case with Hellgate: London). The problem I seem to be having is that ESS is detecting an attack coming from the Hellgate servers which causes my connection to get dropped. Like I said above, it runs fine for a while but once it detects the "Reverse TCP Desynchronization attack" I lose my connection to the servers.
     
  8. rexpart

    rexpart Eset Staff

    Joined:
    Jun 21, 2007
    Posts:
    7
    Location:
    Bratislava, Slovakia
    Hello,
    just untick the "Reverse TCP Desynchronization attack" option in firewall settings (Personal Firewall > IDS and advanced options > Intrusion detection) and see if it makes difference.
     
  9. divedog

    divedog Registered Member

    Joined:
    Jun 7, 2004
    Posts:
    265
    Location:
    Seabeck WA
    I had the same problem with BF2 and BF2142. The problem was there with 2.7 and 3.0. The solution for me after much beating my head against a brick wall was to install Avira in a second snapshot using FDISR no more problem. Not sure if I will renew with NOD when my liscence is up IMHO they have had issues with on line gaming for a long time.
     
Thread Status:
Not open for further replies.