Heavy CPU load when scanning.

Discussion in 'NOD32 version 2 Forum' started by jrspie, Apr 2, 2007.

Thread Status:
Not open for further replies.
  1. jrspie

    jrspie Registered Member

    Joined:
    Oct 9, 2006
    Posts:
    37
    I don't remember seeing this before. I just started scanning my pc and noticed my CPU usage was 100% for more than 5 minutes. Then it varied widely and then stayed between 90 & 100%.
    Quit the scan for now.
    Is this normal or could I have done something wrong when I installed and setup to BS's settings?
    Thanks,
    J.
     
  2. freewill07

    freewill07 Registered Member

    Joined:
    Apr 4, 2007
    Posts:
    3
    I also noticed that once. It was kind of around 90 - 100%. Very annoying.

    regards
     
  3. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,376
    Perhaps there could be 2 or 3 levels of advanced heuristics in the future - one with worser detection capabilities and smaller impact on CPU and one with as best detection capabilities as possible but with a higher impact on CPU (current level).
     
  4. Brian N

    Brian N Registered Member

    Joined:
    Jul 7, 2005
    Posts:
    2,148
    Location:
    Denmark
    When I scan (with everything enabled) it jumps back & forth between 25-80%.
    Your issue could be hardware related or the buggy Vista OS.
     
  5. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,376
    It's pretty normal that an in-depth emulation of complex runtime packed files takes CPU time. What could be done to mitigate the CPU load is to let the user choose between a better detection and lower CPU load when scanning such complex files.
     
  6. Carver

    Carver Registered Member

    Joined:
    Feb 5, 2006
    Posts:
    1,827
    Location:
    USA
    You can change the priority for NOD32.exe in Windows Task Manager/Processes. Right click on the process and Set priority to low.
     
Thread Status:
Not open for further replies.