having problems connecting to edonkey

Discussion in 'LnS English Forum' started by theshadow247, Feb 1, 2005.

Thread Status:
Not open for further replies.
  1. theshadow247

    theshadow247 Registered Member

    Joined:
    Nov 14, 2004
    Posts:
    323
    Location:
    ontario.canada
    hi.i tryed l.ns.in the past and had the same problem.as iam hving now.i posted here but got one reply that didnt work.ok my problem is after inporting the edonkey rie.into lns.it takes eny where for two to five minutes to connect.and even then on my ststus bar.it only shows users.112.and files 50.wich gives me very little sources.i guess my question is can eny one that uses edonkey tell me what they have there ports set to.i have mine set to 4661.to 4665.iam trying before i buy so i hope to work this out. o_O
     
  2. Notok

    Notok Registered Member

    Joined:
    May 28, 2004
    Posts:
    2,969
    Location:
    Portland, OR (USA)
    I also had to open a port for TCP 4662. The easiest way to do this is to clear the log in LnS, start up edonkey and try to connect, go back to the LnS log and right click on the alert and 'create rule'

    BTW, you might check out eMule. It's a better program IMO, and it is not bundled with any spyware like eDonkey is.
     
  3. Thomas M

    Thomas M Registered Member

    Joined:
    Jan 12, 2003
    Posts:
    355
    theshadow247,

    Try deactivating "TCP stateful packet Inspection" (SPI) in "Advanced options" of the "Option" menu in LNS. This allows more open connections.

    Of course turning off "SPI" means a strongly reduced security, but what is the motto of snowboarders and P2P-users:
    No risk - No fun ;)

    Thomas :)
     
  4. theshadow247

    theshadow247 Registered Member

    Joined:
    Nov 14, 2004
    Posts:
    323
    Location:
    ontario.canada
    thanks for the reply.Notok.i opened the port but its still the same.i have the same problem with emule.low amount of user's and files.and sources.i opened the port in emule and nothing.i think its my ports setting in edonkey and emule thats where the problem mite be.
     
  5. theshadow247

    theshadow247 Registered Member

    Joined:
    Nov 14, 2004
    Posts:
    323
    Location:
    ontario.canada
    hi.Thomas M.i get the same thing with the TCP stateful packet Inspection.activated or not.
     
  6. Thomas M

    Thomas M Registered Member

    Joined:
    Jan 12, 2003
    Posts:
    355
    Did you try a reboot of your system?
    You can read some more about it HERE

    Thomas :)
     
  7. Notok

    Notok Registered Member

    Joined:
    May 28, 2004
    Posts:
    2,969
    Location:
    Portland, OR (USA)
    Did you create the rule though the log or did you try to do it manually? It's a lot harder to get it to work unless you do it through the log, and you should select 'port 4662 server' (not client.)

    When you look in your log, does it show what's being blocked?
     
  8. theshadow247

    theshadow247 Registered Member

    Joined:
    Nov 14, 2004
    Posts:
    323
    Location:
    ontario.canada
    hi.Thomas M.ya did reboot.but its still the same thanks again.
     
  9. theshadow247

    theshadow247 Registered Member

    Joined:
    Nov 14, 2004
    Posts:
    323
    Location:
    ontario.canada
    hi.Notok.ok first off i uninstall l.n.s and cleaned my registry and then reinstall it.i imported the rie.file and cleared the log and started edonkey and the only thing that was blocked was net bios.edonkey connected but i still only get user's 112.files.50. o_O o_Oedit.ok after playing around.i found the blocked entery.i clicked on it and then clicked create rule at the bottom of the page.now what showes is.tcp allow port 4662.i cant see client or server.eny where.but now iam only showing user's 49.files unknown. :(
     
    Last edited: Feb 1, 2005
  10. Skank!

    Skank! Registered Member

    Joined:
    Jan 29, 2005
    Posts:
    31
    Location:
    New Zealand
    Posted some rules at PD101 in the LNS thread
     
  11. Notok

    Notok Registered Member

    Joined:
    May 28, 2004
    Posts:
    2,969
    Location:
    Portland, OR (USA)
    Bet are you getting a 'high id'? After connecting, go to the 'servers' tab (in eMule) and check the log (it will say if you have a 'low id' after connecting.) Unfortunately the number of files unknown for an arbitrary search doesn't tell me a lot.. but if you're getting a 'high id', that's all you should really need.
     
  12. theshadow247

    theshadow247 Registered Member

    Joined:
    Nov 14, 2004
    Posts:
    323
    Location:
    ontario.canada
    hi.notok.edonkey and emule have a low id.
     
  13. Notok

    Notok Registered Member

    Joined:
    May 28, 2004
    Posts:
    2,969
    Location:
    Portland, OR (USA)
    What do you see in the log when you try to connect?

    Regarding making the rule, when you select the entry in the log and create rule, it should bring up another small menu for 'allow...server & allow...client'

    Attached is the rule I created for eMule.. I just now added port 4661 to it. After you get it working you might also go into 'applications' and add emule to the list (so the port is only open when emule is active.) Make sure to hit 'save' and 'apply' after making any changes to the rule. You -may- still need to reboot to get that rule working properly.
     

    Attached Files:

  14. Skank!

    Skank! Registered Member

    Joined:
    Jan 29, 2005
    Posts:
    31
    Location:
    New Zealand
Thread Status:
Not open for further replies.