Has the SRWare (Iron browser) site been hijacked?

Discussion in 'other software & services' started by kwg, Mar 15, 2013.

Thread Status:
Not open for further replies.
  1. kwg

    kwg Registered Member

    Joined:
    Jun 30, 2007
    Posts:
    126
    (I won't include any URLs below.)

    SRWare's Iron browser is an implementation of the Chromium source code, as is the Google Chrome browser. Unlike Google Chrome, though, Iron claims not to include Google Chrome's user tracking. So Iron would seem a safe bet for someone who wanted a Chromium-based browser without the privacy concerns inherent in Google Chrome.

    However, when I downloaded the Iron installation program from the SRWare site today, Kaspersky quarantined the program and claimed that it was spyware.

    When I go to the forums on the SRWare site (click the "Forums" tab on the SRWare homepage), I am redirected after a few seconds to the Farmerama registration page. This redirection happens no matter which browser I use, even on computers that have never downloaded the Iron installation file.

    So, has the SRWare site been hijacked? Was the Iron installation file I downloaded from SRWare infected?

    Or has each of the computers I have used to access the SRWare forums somehow been infected? And was Kaspersky's detection of spyware a false positive?
     
  2. Daveski17

    Daveski17 Registered Member

    Joined:
    Nov 11, 2008
    Posts:
    8,028
    Location:
    Lloegyr
    I used to use Iron. I have just scanned the url of its official site (from DuckDuckGo) with both Dr Web & VirusTotal. Dr Web claims the link is clean but on VT out of 36 other predominantly clean site ratings (4 are unrated) only Sophos claims that it is malicious. However, when I paste the SRWare site into 'Down For Everyone Or Just Me' I get: Huh? http: //httpsdoesn't look like a site on the interwho. I have just taken the site off my NoScript whitelist & visited it. It looks fine to me. I see no evidence of strange scripts running on NoScript or RequestPolicy.

    Hmmmm ... curiouser & curiouser.
     
    Last edited: Mar 15, 2013
  3. kwg

    kwg Registered Member

    Joined:
    Jun 30, 2007
    Posts:
    126
    Thanks, Dave, for the help!

    The SRWare homepage appeared clean yesterday. I observed problems (redirection to another site) only in their forums. Interestingly, they seem to have moved their forums to new software just the day before.

    Today I cleared my browser cache and revisited the SRWare site and forums. The redirection from the forums to the Farmerama registration page continues.

    I don't see any announcement of a problem (or its resolution) on the site. However, there have been no posts to their forums during the last 15 hours, which suggests that there is a problem on their site, not just on my computers.
     
    Last edited: Mar 15, 2013
  4. Daveski17

    Daveski17 Registered Member

    Joined:
    Nov 11, 2008
    Posts:
    8,028
    Location:
    Lloegyr
    You're welcome kwg. I actually had a look at the forums but I didn't attempt to sign in. It's more likely to be some bug or gremlins in their software than malware in my opinion.
     
Loading...
Thread Status:
Not open for further replies.