Going bananas with local hosts - please help!

Discussion in 'Prevx Releases' started by jimwillsher, Feb 10, 2011.

Thread Status:
Not open for further replies.
  1. jimwillsher

    jimwillsher Registered Member

    Joined:
    Mar 4, 2009
    Posts:
    668
    Hello

    Please can somebody advise the best solution. I do a lot of web development, and on a daily basis I'm editing my HOSTS file (Win 7, wth PrevX .220).

    Today I'm getting driven to distraction. I'm experimenting with Joomla. I've installed Joomla onto my webserver, set up an Apache config, and added this to my hosts file:

    192.168.1.50 JoomlaPlay

    All well and good.

    I then launch Firefox and browse to JoomlaPlay. Immediately I get the "infected from local hosts" message. I can Fix (which removes the hosts entry - NOT what I want) or I can Ignore. Choosing Ignore has one single outcome - I can no longer browse ANY page in Firefox without getting a DNS lookup error, until I restart Firefox. So I restart Firefox, browse to JoomlaPlay and....same choices. So Ignore has done nothing.

    The only solution seems to be to disable SOL which seems a bit drastic. Surely there's a better way? Manually adding overrides seems to achieve nothing as the SOL sindo still appears.

    Many thanks,


    Jim

    PS Same with IE; Firefox was just my preference.
     
  2. PrevxHelp

    PrevxHelp Former Prevx Moderator

    Joined:
    Sep 14, 2008
    Posts:
    8,242
    Location:
    USA/UK
    Could you try adding an exception for the range of domains you're visiting and configure it to "Off" - for example:

    http*://*.google.com/*

    and move the slider bar completely to the left which will disable warnings for that range of websites.

    Let me know your results!
     
  3. jimwillsher

    jimwillsher Registered Member

    Joined:
    Mar 4, 2009
    Posts:
    668
    Many thanks for the reply.

    It actually seems to be working now, and I think I know why.

    Adding to hosts > getting the warning > choosing to ignore - doesn't work.

    Adding to hosts > getting the warning > choosing to ignore - adding entry manually to the PrevX settings - doesn't work.

    Adding to hosts > getting the warning > choosing to ignore - adding entry manually to the PrevX settings - disabling and re-enabling PrevX SOL protection - does work.




    Jim
     
Thread Status:
Not open for further replies.