Fun and games with Catalyst Control Centre

Discussion in 'other software & services' started by argus tuft, Aug 14, 2007.

Thread Status:
Not open for further replies.
  1. argus tuft

    argus tuft Registered Member

    Sep 20, 2006
    Hi all, I was having some problems getting some games to run smoothly, and thought that maybe updating my ATI display drivers may help.
    Following the procedure given at the ATI website, I uninstalled all ATI related stuff, rebooted, and then went to install the newer version.

    About 4/5ths of the way thru the install process, my pc froze, I couldn't even access task manager thru Ctrl + Alt + Delete. After giving it a good 10 minutes, I hard rebooted, uninstalled whatever the installer managed to do, rebooted, and started again.
    This time, the install seemed to go smoothly, until I tried to access CCC.
    I start CCC, and it almost immediately loads a thing called DW20.exe, which then terminates CCC, and produces a "report to M$" box.
    First thing I tried was a system restore back to the day before I installed the newer version, which also seemed to go fine, only CCC will still not run.

    Still having the original problem I set out to fix, I tried removing it once more, then I rebooted into safe mode, and attempted the install from there.
    This time, It refused to install, saying that directX8 wasn't installed. (I have directX 9.c) I tried to install again from safe mode, this time it complained about a driver being missing.

    I then booted back to normal windows, and tried yet again from there, but it said I needed administrative rights to install. I'm on an admin account. I again used system restore to get back to before I ever touched it, but CCC is still broken.

    Does anyone have any ideas? Anything else that I could try? I'm seriously looking at a complete reformat / fresh install, but wanted to avoid that if all possible.

    Thanks, argus
  2. eniqmah

    eniqmah Registered Member

    Jul 7, 2006
    You might want to try using driver cleaner ( Reboot, clean out the driver, install the new one. If that doesn't work, try installing the old drivers back and redo it in safemode.
  3. lucas1985

    lucas1985 Retired Moderator

    Nov 9, 2006
    France, May 1968
  4. lodore

    lodore Registered Member

    Jun 22, 2006
    i just download the display driver on its own and forget the CCC stuff
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.