FTP connection but no further

Discussion in 'ESET Smart Security' started by Dahzee, Aug 2, 2010.

Thread Status:
Not open for further replies.
  1. Dahzee

    Dahzee Registered Member

    Joined:
    Aug 2, 2010
    Posts:
    2
    Location:
    Hampshire (England)
    I am a complete novice and am having no luck establishing an FTP session with my website.

    SOLVED I had left Windows Firewall on, and when I turned ESET off it allowed my connection, but when they were both on I was unable to connect!

    I am using ESET Smart Security 4.2.35.0 on Windows XP

    I have tried online FTP tests and they say I am able to connect but
    my FTP software (Filezilla) tells me: "Connection attempt failed with "ECONNREFUSED - Connection refused by server"

    I have tried learning mode and various other things I have read on this forum, but I cannot get any further.

    What information do I need to give you in order for someone to steer me in the right direction?

    I know it is ESET that is causing this because if I turn it off a session is achieved instantly.

    Any help would be very grateful as I have completely run out of talent!

    Many thanks in advance

    Dahzee
     
    Last edited: Aug 6, 2010
  2. Cudni

    Cudni Global Moderator

    Joined:
    May 24, 2009
    Posts:
    6,956
    Location:
    Somethingshire
    update to latest version 4.2.58 , just in case. Are you using the correct password to login to ftp?
     
  3. tomi

    tomi Registered Member

    Joined:
    Mar 30, 2009
    Posts:
    29
    Try adding the remote IP address to the list of addresses excluded from active protection (IDS) in the zone setup.
     
  4. AJStevens

    AJStevens Registered Member

    Joined:
    Aug 27, 2008
    Posts:
    97
    Location:
    Surrey, UK
    Go to settings (F5), and go to:
    Antivirus and antispyware
    - Web access protection
    - - HTTP, HTTPS
    - - - Web browsers

    Look through the list and untick anything that isn't a web browser (Internet Explorer, Firefox, Opera, Safari, Chrome, etc.), including your FTP program, FileZilla, I'd wager it's been ticked in there.

    Do the same for:
    - Email client protection
    - - POP3, POP3S
    - - - Email clients

    Incase it's in there also/instead.

    It should work now. I've lost track of how many times I've had to do this check and it works 90% of the time.
     
  5. Dahzee

    Dahzee Registered Member

    Joined:
    Aug 2, 2010
    Posts:
    2
    Location:
    Hampshire (England)
    To Tomi,

    I think I have tried this but I am not sure if I am doing it in the right place.

    To AJ,

    I have checked the places you mentioned and Filezilla (or any other program that can perform FTP) isn't ticked.

    Any other thoughts as I have tried deleting the Filezilla stuff in the Zones and used Learning and Interactive to create new rules and it is still not giving me access.

    I am obviously thicker than I thought!

    I definitely definitely have FTP access when ESET is turned off!

    Any ideas?

    Thanks

    Dahzee
     
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.