Free space in partition 0

Discussion in 'Paragon Partition Manager Product Line' started by s660117, Apr 7, 2012.

Thread Status:
Not open for further replies.
  1. s660117

    s660117 Registered Member

    Mar 6, 2010
    I have very little knowledge of Partition Manager (I am running 9.0) and, as a result, have gotten into a situation I can't fix.
    I am running Windows Vista and have dual boot installed with Suse Linux.
    Before I did anything, my disk 0 was partitioned as follows -

    Primary Partition --
    Primary data partition
    Primary data partition
    Extended partition
    1st Linux partition
    2nd Linux partition
    3rd Linus partition
    Data partition
    Free space.

    The first thing I did was add 50 GB to the data partition to the left of the free space. Next, in an attempt to add additional space to the second Primary data partition, I swapped the data partition and free space at the end of the drive. I then had second thoughts and swapped the last two partitions back again.
    At this point, the only difference between the current state of the drive and the original one was that the last data partition before the free space had been increased by 50 GB.
    I then rebooted and was unable to get to either Windows or Linux. I tried to fix the boot manager, but without success.
    I next tried to restore the drive from a backup. I got a message that the partitiions on the backup did not match the partitions on the drive, but proceeded anyway. Once the disk was restored, I found that I was still unable to boot into Windows or Linux, even after attempting to redo grub.
    Thinking that my failure to boot was a result of the discrepancy encountered during restore, I then wiped the drive and redid the restore. At this point, I noticed that I had 55 MB of free space at the beginning of the drive. This partition did not appear when I invoked the restore in advanced mode: it just wasn't there in the display of backed up partitions. As a result, Windows was resident on the 2nd partion (after the free space and Recovery). I assume that I cannot boot into Windows because it is not in partition 1. A further complication is that when I attempt to restore grub, the process tells me that the Linux partion in in position 8, but when I attempt to boot into Linux, I am told that Linux is not found in position 7.
    A subsequent restore failed to correct the problem.
    So, I am left with a rogue free space partition in position 0 that I believe is the cause of my problem. It seems, from what I can see, that it is impossible to delete a free space partition, and, short of that, I simply don't know what to do.
    Thanks in advance,
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.