Fragmentation Issue w/Acronis

Discussion in 'Acronis Disk Director Suite' started by jwells22, Aug 18, 2006.

Thread Status:
Not open for further replies.
  1. jwells22

    jwells22 Registered Member

    Joined:
    Aug 18, 2006
    Posts:
    3
    I installed True Image, Disk Director and OSS on a clean install of WINXP. I then proceeded to create, re-size, delete partition, image, restore, etc. many times over (perhaps 50 operations) in order to get acquainted with the software. Now I've got a fragmentation issue. When I go into WinXP Disk Defragmenter and defrag the disk, it remains quite fragmented (17%). There are about 60 or 70 green slivers (unmovable files) and lots of white areas (free space). I've never seen this before, and it doesn't look good at all. Why does Acronis cause this and what is the solution? The install is only two weeks old.
     
  2. K0LO

    K0LO Registered Member

    Joined:
    Mar 9, 2006
    Posts:
    2,591
    Location:
    State College, Pennsylvania
    jwells22:

    Usually the unmovable files (green) are the paging file and the hibernation file. I've been able to defragment these by temporarily turning off hibernation and setting the pagefile to OFF. Then reboot and run the defragmenter. When it's done, run it again (the native defrag routine is not very aggressive).

    If you then have things looking better, go back and re-enable the pagefile and the hiberfile.

    I suspect this happens because of the resizing and moving of partitions. Although, I'm puzzled that your disk would remain badly fragmented after restoring an image. TI doesn't copy the pagefile or hiberfile, so I would think that each of these files would be re-allocated after imaging and start off as one fragment each. I'm at a loss to explain that one....

    Anyone else?
     
  3. jwells22

    jwells22 Registered Member

    Joined:
    Aug 18, 2006
    Posts:
    3
    Thanks K0lo for the response. So how do you set the page file to OFF? I assume you turn off hibernation by going to Power Options in Control Panel then going to the Hibernate tab and unchecking "Enable Hibernation", no?
     
  4. K0LO

    K0LO Registered Member

    Joined:
    Mar 9, 2006
    Posts:
    2,591
    Location:
    State College, Pennsylvania
    Correct for turning off hibernation.

    To turn off the paging file go to Control Panel > System > Advanced > Performance > Settings > Advanced > Virtual Memory > Change > and then select "No Paging File" for each of your drives if you have more than one drive. Reboot when done.

    When you're finished defragmenting, come back to the same place and set "System Managed Size" for the paging file. You can choose which drive to use for the paging file. By default, a new installation of Windows will choose the "C" drive but you can put the file elsewhere. (If you have more than one hard drive there may be some performance advantages to putting the paging file on a drive other than the one Windows is installed on).
     
  5. bodgy

    bodgy Registered Member

    Joined:
    Sep 22, 2005
    Posts:
    2,387
    Location:
    Qld.
    The quickest way to get to the system settings 'panel' is to press the Windows button on the keyboard and the 'pause/break' button at the same time.

    On some keyboards it is W+PrtScr button, but most are the former.

    Colin
     
  6. K0LO

    K0LO Registered Member

    Joined:
    Mar 9, 2006
    Posts:
    2,591
    Location:
    State College, Pennsylvania
    Colin:

    That is a great tip! I'll have to remember that one.

    Mark
     
Thread Status:
Not open for further replies.