Firewall not following rules

Discussion in 'ESET Smart Security' started by TrueWeb, Jul 16, 2009.

Thread Status:
Not open for further replies.
  1. TrueWeb

    TrueWeb Registered Member

    Joined:
    Jul 16, 2009
    Posts:
    4
    Hey Guys

    I have added rules to the firewall to allow connections using a certain program. However, in order to receive a remote connection using Anyplace Control I have to jump through the following hoops:

    1. Change firewall mode to interactive
    2. make the remote connection (no eset popups are displayed)
    3. change firewall mode back to "auto with exceptions"

    I can continue to connect/disconnect as many times as I want, provided that the current users stays logged in. After "fast user switching" is used, or the users logs off, or the computer is rebooted, I have to follow the steps again.

    I have Anyplace Control and ESS installed on almost a dozen systems, with no problems. I am having this problem on two different computers. Any ideas?


    Thanks in advance,
    Brian
     
  2. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Try switching to learning mode. I assume the remote port stays same and the local port changes. Does the rule allow the communication for all local ports?
     
  3. TrueWeb

    TrueWeb Registered Member

    Joined:
    Jul 16, 2009
    Posts:
    4
    Hey Marcos

    Took me a little while to get back to my client's office.

    The rule allows every local port and every remote port, both directions, TCP. I enable learning mode, and am able to connect. No rules are added. Once i log off, I am once again unable to connect. If I switch to learning mode or interactive mode i can connect again. This is happening on two machines. Both running Windows Vista. One is 32bit, the other is 64bit.

    Any more ideas?
     
  4. TrueWeb

    TrueWeb Registered Member

    Joined:
    Jul 16, 2009
    Posts:
    4
    Firewall rule won't work if application is given

    Hey Guys

    I'm still having problems with this thing. I have been playing around with it a lot. Here is the problem I am currently having:

    If I specify just a port (or series of ports) to open, the firewall rule will work. However, as soon as I specify an application, the rule is basically ignored. If I switch to interactive mode, the rule is followed. I can switch back to automatic mode with exceptions and the rule will continue to be followed until the system is reset.


    PLEASE HELP!
     
  5. mango

    mango Registered Member

    Joined:
    Sep 9, 2004
    Posts:
    82
    Re: Firewall rule won't work if application is given

    Having the same problem with the program Synergy, it uses port 24800.
    (sharing keyboard amd mouse between computers)

    Synergy client on one machine needs to connect to synergy host on other .

    Created rules to allow application through both directions, and to notify.
    With automatic mode with exceptions, the synergy client cant connect to the host.

    Switching to interactive the synergy rule pop ups and client connects.
    Switch back to automatic mode with exceptions it works until next boot.

    Seems the rule isnt followed in automatic mode with exceptions
     
  6. TrueWeb

    TrueWeb Registered Member

    Joined:
    Jul 16, 2009
    Posts:
    4
    Re: Firewall rule won't work if application is given

    Hey mango

    I just tried it your way, and my problems seem consistent with your's. I can create a rule for allowing both directions, TCP, on two ports, with an application specified, notify user. Using automatic mode with exceptions, the rule is ignored. If I switch to Interactive mode a popup is displayed declaring that the firewall is following my rule.

    A little help here guys....



    Thanks,
    Brian
     
Thread Status:
Not open for further replies.