Firefox's massive overhaul moves to beta

Discussion in 'other software & services' started by lotuseclat79, Mar 21, 2014.

  1. Brummelchen

    Brummelchen Registered Member

    Joined:
    Jan 3, 2009
    Posts:
    2,323
    ofc it MUST be higher, what do you expect when rising process? omg :rolleyes:

    processes= 1? go back to 52esr!

    has already begun, all ranting suckers are spamming each thread now - neither nor not helpful
    those should take any browser they like to - configure it and shut up.

    maybe some of you did not get much of rants theses days - i am reading it since weeks (as expected) and always same people are ranting about ****** mozilla and such words.

    enough is enough, right now! take your chances and quit!


    to read!
    -> http://forums.mozillazine.org/viewtopic.php?f=7&t=3033779
     
  2. paulderdash

    paulderdash Registered Member

    Joined:
    Dec 27, 2013
    Posts:
    2,563
    Location:
    The etherlands
    It doesn't inspire confidence that their other extension, Xmarks (which I used to be able to sync bookmarks to Chrome), stopped working in FF 56 already. I was told to try their beta version but it stuffed up my bookmarks. So ditched Xmarks and just using Firefox Sync now to sync bookmarks across Firefox profiles.

    I do use LastPass also, but as a backup only, because it is comaptible with more browsers than Roboform Everywhere, which is my primary password manager. Roboform's webextension has been in place since before FF 56 and works perfectly.

    I am a LastPass Premium (paid) user, which previously covered both, but they have changed this. I doubt I will retain Premium version of either now, maybe just LastPass free. Having two cloud password managers also doubles my 'exposure'.
     
    Last edited: Oct 4, 2017
  3. Brummelchen

    Brummelchen Registered Member

    Joined:
    Jan 3, 2009
    Posts:
    2,323
    yes, i also noticed complains in special for lastpass and its last extension builds - not only in this forum. but lastpass in general has issues, maybe they underrated the # of free users. but sorry, i cannot say anything to xmarks or sync. when i had the idea to serv myself firefox decided to brake this feature and make it closed source, maybe for security reason.

    btw anyone else with some light issues when using mouse gestures? not sure if firefox is that slow but sometimes i get the context menu after gesture action.
     
  4. summerheat

    summerheat Registered Member

    Joined:
    May 16, 2015
    Posts:
    1,158
    Quite frankly, your post is ... well ... surprising. You were using FF50 - a version that's already quite old (released in Nov 2016!), and countless issues (not only security-related) have been fixed in the meantime (we're now at FF56). Seriously? (Even if you use it in Sandboxie - if I recall correctly - this is careless, IMHO).

    Then you're disappointed about FF57. But you know that you're using a beta, and FF57 final will be released in mid-November, don't you? You're complaining that most of your extensions don't work in FF57. But since you didn't tell us which ones are affected nobody can tell if for some of them a webextension version is already available (e.g. in the respective development channel on AMO) or if possible alternatives exist. And again - FF57 will be released not earlier than in 6 weeks from now. A lot of add-ons - like Noscript or Lastpass - will be available as webextensions by then, perhaps also the ones you're missing now as the number of compatible add-ons is increasing steadily. And with respect to your specific requirements I already suggested in another thread to you to search here (download management), here (bookmarks) and here (tabs) for webextensions which might suit your needs. Have you?

    That multi-processing needs more RAM is not overly unexpected (although RAM usage is lower than for Google Chrome) and should not really be a problem for today's computers. That's a price you have to pay for a browser which is more stable and more secure. If you don't want that follow @Victek 's advice.
     
  5. Victek

    Victek Registered Member

    Joined:
    Nov 30, 2007
    Posts:
    5,582
    Location:
    USA
    Yes, the word in the LastPass forum is a compatible extension will be available when v57 is released. If they had gotten it ready sooner I would be experimenting with v57 now. As long as it's ready and works properly for v57 release it's not a problem, but it does make some people nervous.
     
    Last edited: Oct 4, 2017
  6. Rasheed187

    Rasheed187 Registered Member

    Joined:
    Jul 10, 2004
    Posts:
    9,869
    Location:
    The Netherlands
    Thanks, will check it out. Too high RAM usage is the reason why I can't make the switch to Vivaldi, it just gets on my nerves.
     
  7. Rasheed187

    Rasheed187 Registered Member

    Joined:
    Jul 10, 2004
    Posts:
    9,869
    Location:
    The Netherlands
    To clarify, I am indeed not too worried about security issues because I'm already quite good protected. But I did notice that FF 50 now has video playing problems, so I will have to upgrade. About FF 57, I hope eventually certain extensions will be ready, but FF should really offer certain features as a standard. And thanks for the tips about the extensions, but I don't believe they can be a replacement for the requested features. But cool that RAM usage is lower when compared to Chrome based browsers, and cool that the browsing engine is faster, so it's not all bad.
     
  8. JRViejo

    JRViejo Super Moderator

    Joined:
    Jul 9, 2008
    Posts:
    24,794
    Location:
    U.S.A.
    FYI. Firefox 57 Beta 6 released October 6, 2017. Available via Internal Updater (6.6 MB - 64-bit).

    The Firefox Beta page's Download button downloads Firefox Installer.exe (300 KB).

    The Download Firefox Beta in your language page downloads 57.0b6.exe's 32-bit & 64-bit versions.
     
  9. Rasheed187

    Rasheed187 Registered Member

    Joined:
    Jul 10, 2004
    Posts:
    9,869
    Location:
    The Netherlands
  10. inka

    inka Registered Member

    Joined:
    Oct 21, 2009
    Posts:
    425
    this pref may enable you to overcome that undesirable resizing behavior:

    browser.enable_automatic_image_resizing = false
     
  11. NiteRanger

    NiteRanger Registered Member

    Joined:
    Nov 15, 2016
    Posts:
    427
    Location:
    Far East
    2 questions. Anyone knows

    1) How's its battery consumption vs Chrome browser for laptop users?
    2) Is its scrolling, pinch-and-zoom for touchscreen as smooth as Chrome browser?

    Thanks
     
  12. Brummelchen

    Brummelchen Registered Member

    Joined:
    Jan 3, 2009
    Posts:
    2,323
  13. JRViejo

    JRViejo Super Moderator

    Joined:
    Jul 9, 2008
    Posts:
    24,794
    Location:
    U.S.A.
    FYI. Firefox 57 Beta 7 released October 10, 2017. Available via Internal Updater (7.0 MB - 64-bit).

    The Firefox Beta page's Download button downloads Firefox Installer.exe (300 KB).

    The Download Firefox Beta in your language page downloads 57.0b7.exe's 32-bit & 64-bit versions.
     
  14. Brummelchen

    Brummelchen Registered Member

    Joined:
    Jan 3, 2009
    Posts:
    2,323
  15. Victek

    Victek Registered Member

    Joined:
    Nov 30, 2007
    Posts:
    5,582
    Location:
    USA
  16. JRViejo

    JRViejo Super Moderator

    Joined:
    Jul 9, 2008
    Posts:
    24,794
    Location:
    U.S.A.
    FYI. Firefox 57 Beta 8 released October 13, 2017. Available via Internal Updater (6.7 MB - 64-bit).

    The Firefox Beta page's Download button downloads Firefox Installer.exe (300 KB).

    The Download Firefox Beta in your language page downloads 57.0b8.exe's 32-bit & 64-bit versions.
     
  17. Rasheed187

    Rasheed187 Registered Member

    Joined:
    Jul 10, 2004
    Posts:
    9,869
    Location:
    The Netherlands
    Thanks, but that doesn't fix the problem. Pics need to be resized only under certain conditions, and that's currently not possible in FF.
     
  18. IvoShoen

    IvoShoen Registered Member

    Joined:
    Jan 2, 2008
    Posts:
    636
  19. Victek

    Victek Registered Member

    Joined:
    Nov 30, 2007
    Posts:
    5,582
    Location:
    USA
    Can you be specific about the bugs you were seeing in the LastPass beta?
     
  20. IvoShoen

    IvoShoen Registered Member

    Joined:
    Jan 2, 2008
    Posts:
    636
    I had to keep logging in every time I started Firefox, and even many times while ff was already running. It just wouldn't stay logged in, the icon was black or yellow most of the time. For now I'll just use Bitwarden. I imported my data from LastPass and it works great.
     
  21. The Seeker

    The Seeker Registered Member

    Joined:
    Oct 24, 2005
    Posts:
    1,177
    Location:
    Adelaide
    Are you blocking third-party cookies? I found this caused issues for me in the past.
     
  22. Krusty

    Krusty Registered Member

    Joined:
    Feb 3, 2012
    Posts:
    4,857
    Location:
    Among the gum trees
    Also, LastPass doesn't like it if you delete cookies when your browser closes. One reason I found an alternative.
     
  23. IvoShoen

    IvoShoen Registered Member

    Joined:
    Jan 2, 2008
    Posts:
    636
    I have not been blocking third-party cookies or deleting them. Bitwarden works better for now.
     
  24. JRViejo

    JRViejo Super Moderator

    Joined:
    Jul 9, 2008
    Posts:
    24,794
    Location:
    U.S.A.
    FYI. Firefox 57 Beta 9 released October 17, 2017. Available via Internal Updater (7.0 MB - 64-bit).

    The Firefox Beta page's Download button downloads Firefox Installer.exe (300 KB).

    The Download Firefox Beta in your language page downloads 57.0b9.exe's 32-bit & 64-bit versions.
     
  25. Trooper

    Trooper Registered Member

    Joined:
    Jan 26, 2005
    Posts:
    3,711
    Just installed thanks!

    After not being on Firefox in years, this is looking pretty good. Was a diehard FF guy for a long time, but moved onto Chrome.

    Question - Is there anything I can do to get uBlock Origin installed? I remember an addon from years ago that would allow you to do so even if it was not compatible. But I am so far removed from the FF world I can't remember how to do this.

    Thanks.
     
Loading...