Firefox addons

Discussion in 'other software & services' started by Rico, Aug 28, 2017.

  1. JRViejo

    JRViejo Super Moderator

    Joined:
    Jul 9, 2008
    Posts:
    43,490
    Location:
    U.S.A.
    FYI. Update Regarding Add-ons in Firefox - Last Updated: 00:54 EDT May 5 2019
     
  2. Rico

    Rico Registered Member

    Joined:
    Aug 19, 2004
    Posts:
    1,965
    Location:
    Texas
    @mary7 the fix in studies 1548973 was completed see post #363

    Still Get:
    upload_2019-5-5_12-11-54.png

    Early on when this first happened, I "deleted" HTTPSeverywhere, & attempted to re-install
     
  3. TomAZ

    TomAZ Registered Member

    Joined:
    Feb 27, 2010
    Posts:
    1,128
    Location:
    USA
    How.where do you access: about studies?
     
  4. bjm_

    bjm_ Registered Member

    Joined:
    May 22, 2009
    Posts:
    3,389
    Location:
    .
    address bar
    4956.png
     
  5. Victek

    Victek Registered Member

    Joined:
    Nov 30, 2007
    Posts:
    5,985
    Location:
    USA
    In the Firefox address bar type

    about:studies

    If the fix is installed you should see this


    Active studies
    • p
      prefflip-push-performance-1491171•Active
      This study sets dom.push.alwaysConnect to true.
    • h
      hotfix-update-xpi-signing-intermediate-bug-1548973•Active
      This is a hotfix that updates an intermediate certificate used for signing add-ons. It is one of the mechanisms used to fix bug 1548973.


    Completed studies

    • h
      hotfix-reset-xpi-verification-timestamp-1548973•Complete
      This study sets app.update.lastUpdateTime.xpi-signature-verification to 1556945257.
     
  6. JRViejo

    JRViejo Super Moderator

    Joined:
    Jul 9, 2008
    Posts:
    43,490
    Location:
    U.S.A.
    FYI. What my about:studies showed after enabling it (they were all active upon restart). This morning they were all completed. I have disabled it.

    2019-05-05_103513.png
     
  7. Buddel

    Buddel Registered Member

    Joined:
    Apr 28, 2015
    Posts:
    1,115
    I wasn't willing to wait for a fix, so I downloaded v66.0.4 from the Mozilla ftp server. All add-ons are back.:)
     
  8. BoerenkoolMetWorst

    BoerenkoolMetWorst Registered Member

    Joined:
    Dec 22, 2009
    Posts:
    4,286
    Location:
    Outer space
    Disabling the signing requirement is not advised because of security and also because it may conflict with the upcoming fix. If you don't want to enable Studies, you can install them manually:
    https://nixnet.xyz/
     
  9. ichito

    ichito Registered Member

    Joined:
    Jan 14, 2011
    Posts:
    1,858
    Location:
    Poland - Cracow
    It works in Firefox (52.9 ESR) on my Vista succesfuly from years :) I need it due to using of Cool Previews that is already abandoned and not reachable on official addons storage so now I'm already prepared to this issue :)
     
  10. Minimalist

    Minimalist Registered Member

    Joined:
    Jan 6, 2014
    Posts:
    12,733
    Location:
    Slovenia, EU
    Check if you have app.normandy.enabled in about:config set to false. If you have set it to true and restart FF. Then you can enable studies and setting will stay enabled.
     
  11. Rico

    Rico Registered Member

    Joined:
    Aug 19, 2004
    Posts:
    1,965
    Location:
    Texas
    I thought I saw (perhaps wrong two studies 1548973 & X, apply), my post #363 shows 1548973 completed, is another study need be completed before fix?
     
  12. Minimalist

    Minimalist Registered Member

    Joined:
    Jan 6, 2014
    Posts:
    12,733
    Location:
    Slovenia, EU
    Check post #381 a screenshot. There are two studies that have to be completed. I didn't get the second one so far.
     
  13. Daveski17

    Daveski17 Registered Member

    Joined:
    Nov 11, 2008
    Posts:
    9,159
    Location:
    Lloegyr
    Just happened to me on Ubuntu. Mac is OK so far.
     
  14. Rico

    Rico Registered Member

    Joined:
    Aug 19, 2004
    Posts:
    1,965
    Location:
    Texas
  15. Daveski17

    Daveski17 Registered Member

    Joined:
    Nov 11, 2008
    Posts:
    9,159
    Location:
    Lloegyr
    Way too much excitement on a Sunday evening! :argh:
     
  16. Krusty

    Krusty Registered Member

    Joined:
    Feb 3, 2012
    Posts:
    7,416
    Location:
    Among the gum trees
    I just received the .04 update and all my extesions are working again. Thank's for the heads-up though.
     
  17. ZMsiXone

    ZMsiXone Registered Member

    Joined:
    Mar 30, 2017
    Posts:
    297
    Location:
    EUROPE/poland/germany
    same here: after the update (to .04) all my extensions are back.. ... and after few minutes of testing everything seems to work fine again.
     
  18. bo elam

    bo elam Registered Member

    Joined:
    Jun 15, 2010
    Posts:
    5,512
    Location:
    Nicaragua
    Updating to Firefox 66.0.4 fixed the extensions problem. I didnt have to do nothing but do the update. NoScript (my only addon) and the theme I use, were enabled after restarting Firefox after the update.

    Bo
     
  19. TomAZ

    TomAZ Registered Member

    Joined:
    Feb 27, 2010
    Posts:
    1,128
    Location:
    USA
    Okay. . . please bear with me -- it sounds like I need more help than many of you.. I suppose it's possibly due to my 'Legacy' hardware/software setup, but not sureo_O I'm running Firefox 52.0.2 of an XP SP3 box. (BTW, I've tried upgrading Firefox to a more current version on more than one occasion, but for some reason, it won't let me do that even though some of the newer versions indicate they are still XP compatible).

    Interestingly, until yesterday, everything worked just fine -- including all of my extensions So here's the deal:

    1) When I try to run about:studies, I get a big popup saying: The Address Isn't Valid (the URL isn't valid and cannot be loaded).

    2) Also, I don't know if all of the fixes have been distributed, but haven't had anything corrected here yet. Also, don't know if that's because I'm not able to load about:studies (BTW. . . I can load about:config, but not about:studies)

    Anyway, not sure what to do now, but I'm VERY frustrated!!! If anyone can offer any help or has suggestions, anything would be greatly appreciated.
     
  20. Krusty

    Krusty Registered Member

    Joined:
    Feb 3, 2012
    Posts:
    7,416
    Location:
    Among the gum trees
    Does this help, Tom?

    https://community.norton.com/en/comment/8135101#comment-8135101

    Note, the about:config setting mentioned towards the bottom.
     
    Last edited: May 6, 2019
  21. TomAZ

    TomAZ Registered Member

    Joined:
    Feb 27, 2010
    Posts:
    1,128
    Location:
    USA
    Thanks so much, Krusty. Haven't tried this yet, but sure will. What I don't totally understand is that if FF has the ability to disable everything, why don't they have the ability to re-enable it again?
     
  22. Krusty

    Krusty Registered Member

    Joined:
    Feb 3, 2012
    Posts:
    7,416
    Location:
    Among the gum trees
    I don't completely understand it, but because this related to a security certificate, I guess unless that certificate is renewed before it expires this is what happens. In the case of an EOL product I guess that means you're out of luck.

    Until Firefox is updated for my Linux Mint machine I've had to change the about:config setting for my extensions to work. As soon as 66.0.4 is released I can disable that setting.
     
    Last edited: May 6, 2019
  23. TomAZ

    TomAZ Registered Member

    Joined:
    Feb 27, 2010
    Posts:
    1,128
    Location:
    USA
    Exactly what did you change in your about:config settings. Will I need to change any of the other "xpinstall..." settings? And do the extensions just start working again -- or do you have to re-enable them?
     
  24. Krusty

    Krusty Registered Member

    Joined:
    Feb 3, 2012
    Posts:
    7,416
    Location:
    Among the gum trees
    I only searched for xpinstall.signatures.required and double-clicked the setting to change the value from TRUE to FALSE . After that the extensions worked again, but when I check my extensions they show as "[name of extension] could not be verified for use in Firefox. Proceed with caution".
     
  25. TomAZ

    TomAZ Registered Member

    Joined:
    Feb 27, 2010
    Posts:
    1,128
    Location:
    USA
    Just tried it and unfortunately it didn't work for me. It still says those extensions could not be verified for use in Firefox and that they have been disabled.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.