Filtrage logiciel

Discussion in 'LnS French Forum' started by horisis, Jan 31, 2008.

Thread Status:
Not open for further replies.
  1. horisis

    horisis Registered Member

    Joined:
    Jan 31, 2008
    Posts:
    2
    Location:
    Sydney
    Bonjour,
    Premier post pour moi sur ce forum.
    J'ai installe une version d'essai de LnS 2.06 sur un systeme Vista tout propre tout neuf. J'etais jusqu'ici un utilisateur heureux, voire un admirateur, de Tiny firewall 2005 pro (firewall, HIPS complet, Light, ....) .... divorce force, non sans une certaine amertume, par le manque de compatibilite Vista.
    Bref.
    LnS est extremement seduisant : ultra-light, interface epure, tres configurable, et enfin un soft qui ne melange pas firewall avec un morceau de HIPS a moitie fini. Ce qui laisse la place pour installer un vrai HIPS a cote.
    Bref.
    Apres quelques tests, le probleme est le suivant :
    Je cree une regle pour internet explorer dans Internet filtering, en autorisant la connexion TCP vers les ports distants 80, 8080, 443. Je precise dans le sous-menu application que cette regle doit etre activee pour internet explorer uniquement (je place IE dans le cadre de gauche, en laissant toutes les autres applications a droite). J'ouvre internet explorer : la regle s'active. Normal. Je peux ainsi naviguer sur internet.
    Mais : la regle semble autoriser n'importe quelle application, tant q'IE reste ouvert, meme inactif dans son coin. En d'autre terme, tant qu'IE est ouvert, les ports distants 80, 8080, 443, sont accessible a n'importe quelle application (outlook, acrobat, media player, .....) !!! La regle a donc ete activee par IE, mais est incapable de differencier les packets venant d'IE des autres applications.
    Cela me semble representer un big probleme. Cela est-il normal ? C'est un bug sur ma configuration ? Y a t-il moyen de contourner ce probleme (pouvoir selectionner precisement les ports auxquels une application peut se connecter, par ex autoriser IE vers port 80 sans autoriser outlook vers port 80) ?
    En dehors de cela, tout semble tourner nickel. Le seul truc bizarre : la case "connecte" sur la fenetre d'acceuil n'est jamais cochee ; une adresse ip valide est pourtant indiquee, avec calcul du temps de connection et des quantites enchangees.

    Merci pour vos avis.
     
  2. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Bonjour,

    Ce fonctionnement est normal.

    Le Filtrage Internet est un filtrage bas niveau et se situe très près de la carte réseau. Il s'agit d'un packet filter, et à ce niveau les paquets ne sont pas liés à une application en particulier.

    L'association d'une règle à une application permet juste de ne pas laisser une règle active si l'application qui s'en sert n'est pas connectée à Internet dans le filtrage logiciel. Ca ne permet pas de vérifier que le paquet correspond bien à l'application.

    Pour des ports communs en mode client comme 80, l'intérêt est assez limité.
    Pour des ports utilisés très peu de manière ponctuelle par une application cette fonction reste assez utile, pour ne pas laisser une règle active 100% du temps, alors qu'elle ne sert que 1% du temps.
    En revanche pour des ports ouverts en mode serveur, l'intérêt est grand car une seule application à la fois peut ouvrir ce genre de port, et donc vous êtes sûr que quand la règle est activée, c'est bien une application autorisée du filtrage logiciel qui va être la seule à écouter ce port.

    Si vous souhaitez indiquer précisément les ports utilisés par les applications, alors il faut le faire directement dans le filtrage logiciel en double-cliquant sur une application (et en étant en mode avancé). Là vous pouvez indiquer les ports autorisés ou interdits.
    Typiquement pour interdire Outlook à utiliser le port 80, il suffit de mettre !80.

    La case connecté à internet, doit normalement être cochée quand tout est bien configuré. Si ce n'est pas le cas, c'est que vous avez sans doute une adresse IP particulière qui ne sert en général pas à la connexion (192.168.0.1, 10.0.x.y, 169.254...). Si c'est normal que votre connexion vers internet utilise ce genre d'adresse IP alors dans les options avancées vous pouvez enlever cette adresse IP de la liste d'exclusion.
    Si ce n'est pas normal que Look 'n' Stop détecte cette adresse IP, alors c'est que l'interface réseau dans les options n'est pas correctement choisie.

    Cordialement,

    Frédéric
     
  3. horisis

    horisis Registered Member

    Joined:
    Jan 31, 2008
    Posts:
    2
    Location:
    Sydney
    Merci pour votre reponse rapide !
    Tests refaits (c'etait pourtant pas faute d'y avoir passe du temps la premiere fois) ..... les options au niveau du filtrage applications me permettent bien de restreindre les ports distants pour chaque application. Je crus un instant que seule la selection des ports locaux etait possible ..... allez savoir ...... neuneu en action.
    Bref, merci encore. LnS est bel et bien pil poil au poil nickel ..... Me voila parti pour acheter une licence ........
    Merveilleux forum, au passage, plein de ressources que j'utilise regulierement.
     
Thread Status:
Not open for further replies.