file scan gets "insufficient memory" message

Discussion in 'ESET NOD32 Antivirus' started by enf1945, Nov 20, 2010.

Thread Status:
Not open for further replies.
  1. enf1945

    enf1945 Registered Member

    Joined:
    Nov 20, 2010
    Posts:
    2
    btw i have plenty of memory 2 gigs . system only using 400 megs
    Windows XP

    but during file scan you get filenamexyz.exe NSIS script.nsi - error - insufficient memory

    it doesnt happen on all files.

    this was done with an on demand scan.

    thanks
     
  2. FanJ

    FanJ Updates Team

    Joined:
    Feb 9, 2002
    Posts:
    3,246
  3. 3GUSER

    3GUSER Registered Member

    Joined:
    Jan 10, 2010
    Posts:
    812

    Make sure Windows Environment variables actually are correct . They can be found in Control Panel -> System -> (System Protection)
    Capture.PNG

    In Vista and Windows 7 - if you use User Account Control - enable it and re-create the folders X:\Windows\Temp and X:\Users\<username>\AppData\Local\Temp

    Reboot and try again
     
  4. enf1945

    enf1945 Registered Member

    Joined:
    Nov 20, 2010
    Posts:
    2
    I do have those two entries but i have Windows XP .

    do i have to do anything ?

    also for Path for the Temp file entry i have :

    c:\Program Files\NVIDIA Corporation\PhysX\Common;%systemroot%\system32;%systemroot%;%systemroot%\system32\wbem;C:\Program Files\Microsoft Network Monitor 3;C:\Program Files\QuickTime\QTSystem;C:\Program Files\Support Tools;C:\WINDOWS\system32\WindowsPowerShell\v1.0
     
  5. 3GUSER

    3GUSER Registered Member

    Joined:
    Jan 10, 2010
    Posts:
    812
    In Windows XP the temp folders are:
    X:\Windows\Temp
    and X:\Documents and Settings\<username>\Application Data\Local\Temp

    You may also check the Temp folders permissions

    Try deleting the folders manually and re-create them (using your own admin account).
     
  6. andw

    andw Registered Member

    Joined:
    Nov 29, 2010
    Posts:
    1
    Path to temporary folder - can this setting be changed in NOD32?
    I'm using SSD as system (Win7 x64, NOD32 v4) volume and try to minimize writes to "c:\windows\temp\" folder. Changing TEMP/TMP environment variables seems to be a solution, but I want to change only NOD32 appearance.
     
  7. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,415
    This is the only solution. I guess that the oper. system or other applications write more frequently to the temp folder.
     
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.