[ExtFS v9.3.89] [OSX v10.9] mount options ignored

Discussion in 'NTFS for Mac & ExtFS for Mac' started by metaworx, Nov 14, 2013.

  1. metaworx

    metaworx Registered Member

    Joined:
    Nov 14, 2013
    Posts:
    5
    Location:
    Switzerland
    hi everybody

    i already filled a support request for the following, but i just wanted to share it here as it migth be an obstacle for others as well:

    if i mount a drive with ext4, the mount options are not handled corrected. it looks like this on my system:

    Code:
    martins-mbp:~ mdr$ mount
    /dev/disk0s2 on / (hfs, local, journaled)
    devfs on /dev (devfs, local, nobrowse)
    /dev/disk0s4 on /Volumes/Untitled (ufsd_ExtFS, local, noowners)
    /dev/disk0s5 on /store (ufsd_ExtFS, local, noowners)
    /dev/disk0s6 on /Volumes/home (ufsd_ExtFS, local, noowners)
    map -hosts on /net (autofs, nosuid, automounted, nobrowse)
    map auto_home on /home (autofs, automounted, nobrowse)
    /dev/disk1s3 on /Volumes/metaworx 1TB (hfs, local, nodev, nosuid, journaled, noowners)
    
    while /dev/disk0s4 and /dev/disk0s6 are automounted by OSX/ExtFS, the partition on /dev/disk0s5 is mounted at system-start:

    Code:
    martins-mbp:~ mdr$ cat /etc/fstab
    #
    # Warning - this file should only be modified with vifs(8)
    #
    # Failure to do so is unsupported and may be destructive.
    #
    LABEL=store	/store		ufsd_ExtFS		local,noatime
    #LABEL=home	/Users		ufsd_ExtFS		rw,auto
    
    but it acutally makes no difference if the volume is mounted by the system automagically, during boot by fstab or manually with "mount -t ufsd_ExtFS -o xxxx /dev/disk0sX /mnt": the options are in any case ignored and standard option set is applied: "ufsd_ExtFS, local, noowners".

    now sepcfically the last option is no good, as the owners of the underlying filesystem should definitifly be concidere (specially if you have your home directory on on of the ext4-partitions in order to shar it with linux!).

    also tha noatime would be relevant - in case ExtFS is actually updating atime ...

    is there a way to make ExtFS to respect mount options or at least respecting the owners-flag?

    best regards,
    martin rüegg.
     
  2. metaworx

    metaworx Registered Member

    Joined:
    Nov 14, 2013
    Posts:
    5
    Location:
    Switzerland
    hello paragon support team,

    did by chance anyone happen to read this post? is there any intention to change the driver in order to recognize the mentioned options?

    best regards,
    martin rüegg.
     
  3. HarrySlomka

    HarrySlomka Registered Member

    Joined:
    Dec 4, 2013
    Posts:
    1
    Hello,

    I think I've got the same or least a similar Problem.
    Using OSX 10.9 Mavericks and ExtFS 9.3.89. Also tried with ExtFS 9.3.118 provided here. (NTFS for Mac v.11.0.112 is also installed)

    I cannot browse the files on the ext4 Partition.
    When I open up a finder-info window for respective partition it says:

    Code:
    Last opened 1 Jan 1970 01:00
    Finder keeps hanging/crashing when opening this partition (I have to force quit / relaunch). I am not allowed to attach files so here is a link to a zip that contains some of the related crashlogs:

    CrashLogs.zip


    mount:

    Code:
    homebase:~ paranoiduser$ mount
    /dev/disk0s2 on / (hfs, local, journaled)
    devfs on /dev (devfs, local, nobrowse)
    /dev/disk0s4 on /Volumes/Windows (ufsd_NTFS, local, noowners)
    map -hosts on /net (autofs, nosuid, automounted, nobrowse)
    map auto_home on /home (autofs, automounted, nobrowse)
    /dev/disk0s7 on /Volumes/Data (hfs, local, journaled)
    /dev/disk1s1 on /Volumes/UNTITLED (msdos, local, nodev, nosuid, noowners)
    gtp fdisk

    Code:
    GPT fdisk (gdisk) version 0.8.8
    
    Warning: Devices opened with shared lock will not have their
    partition table automatically reloaded!
    Partition table scan:
      MBR: protective
      BSD: not present
      APM: not present
      GPT: present
    
    Found valid GPT with protective MBR; using GPT.
    
    Command (? for help): p
    Disk /dev/disk0: 977105060 sectors, 465.9 GiB
    Logical sector size: 512 bytes
    Disk identifier (GUID): C787624D-3AF0-4DBC-8E0B-89714B784AD4
    Partition table holds up to 128 entries
    First usable sector is 34, last usable sector is 977105026
    Partitions will be aligned on 8-sector boundaries
    Total free space is 264897 sectors (129.3 MiB)
    
    Number  Start (sector)    End (sector)  Size       Code  Name
       1              40          409639   200.0 MiB   EF00  EFI System Partition
       2          409640       129315887   61.5 GiB    AF00  Customer
       3       129316864       129579007   128.0 MiB   0C01  Microsoft reserved part
       4       129579008       286089215   74.6 GiB    0700  Windows
       5       286089216       374241559   42.0 GiB    0700  Linux
       6       374243328       409397247   16.8 GiB    0700  SWAP
       7       409397248       976842879   270.6 GiB   AF00  Data
    


    Cheers
    b
     
  4. endro

    endro Registered Member

    Joined:
    Apr 15, 2014
    Posts:
    2
    Hi ,
    I just install extFS (trial version) on my mini mac (mavericks osx10.9).
    connect to my linux external hdd (filesystem :ext3 )
    first connection, mac can read my files well. copy paste worked as expected.

    BUT, i fail to connect since 2nd connection, and there a massage "Disk Mount Problem". The massage said:
    "Untitled (/Volumes/Untitled) can not be mounted. There might be a problem with some files on this device or disk. This happen if you remove the device or disk before all files have been written to it.
    Please, use Disk Utility to verify and repair this volume."

    What happen here?
    Is this case common? Should I follow the suggestion to verify and repair the hdd?

    please help me.
     
Loading...