External KeyPad Jumps to into NumLock Mode since...

Discussion in 'Prevx Releases' started by VPNAVY, Mar 10, 2012.

Thread Status:
Not open for further replies.
  1. VPNAVY

    VPNAVY Registered Member

    Joined:
    Mar 10, 2012
    Posts:
    4
    I am not saying it was because of upgrading to Webroot SecureAnywhere Essentials but I never noticed it prior. I read about the wireless keyboard issue but not wired. Just figured I would throw this out as a possibility?

    OK - I have tried this with two different external Microsoft Keyboards.

    1. I will be using my keyboard and bouncing between keys and keypad. I normally just use the DEL key on the KeyPad for the most part. All of a sudden, I will hit the DEL key and a period comes up as if it changed into NumLock mode. As a matter of fact, all the KeyPad keys work as they should as if I had it in NumLock Mode without the NumLock indicator being lit on keyboard. I tried hitting the NumLock key to get it back to normal but nothing changes - it is as though it is stuck in NumLock mode. I might add - when I do hit NumLock - the indicator will come on and when I hit it again - the NumLock indicator light goes out but it seems to still be in NumLock Mode.

    2. I thought it was a tired keyboard so bought a new one (Microsoft Natural to Microsoft Keyboard Pro) and after a while - it does the same exact thing.

    3. I changed USB ports with the same result after a little use.

    4. I found that rebooting corrects the problem for a while. I also found that by putting my laptop into sleep mode and waking it up - clears the problem for a while.

    5. I ran a complete virus scan, etc. - nothing found.

    Now, if I just ignore it for an hour or so the Keypad will start working properly - could it be Webroot is hitting the server's and updating? I am at a loss.
     
  2. VPNAVY

    VPNAVY Registered Member

    Joined:
    Mar 10, 2012
    Posts:
    4
    BUMP!
     
  3. Techfox1976

    Techfox1976 Registered Member

    Joined:
    Jul 22, 2010
    Posts:
    749
    I seem to recall somewhere about the ID Shield needing to choose to engage or not-engage Num Lock as part of its protection, so if the foreground window is protected by it and it's not a laptop keyboard, Num Lock will be on. You can always check with Webroot directly at http://community.webroot.com/ as well.
     
  4. VPNAVY

    VPNAVY Registered Member

    Joined:
    Mar 10, 2012
    Posts:
    4
    Thanks Techfox1976. I just posted a message and will let ya know what I find out.

    Again - thanks!
     
  5. VPNAVY

    VPNAVY Registered Member

    Joined:
    Mar 10, 2012
    Posts:
    4
    Techfox1976 - Well, so far I got a reply from a Moderator pointing me to my keyboard driver's (and not WebRoot). Like my daughter would say - oh well!:D

    UPDATE! I just noticed something - when my keyboard goes into my "Magical NumLock Mode" - my WebRoot "Foreground Window Protected" icon is on. When it the "Foreground WIndow Protected" icon goes away - my "Magical NumLock Mode" problems goes away. I knew it was something to do with WebRoot!

    So, I just left a posting asking how to disable that puppy!


    FINAL UPDATE! Apparently, it is a known feature (to the techies anyway) that the Identity Shield's Keyboard Protection feature is the reason. The ONLY solution is to disable the ID Shield Protection for those apps (i.e., Browser!!!!, etc.) to stop the NumLock problem which defeats the neat protection feature. Anyway, WebRoot is currently looking into the overall implications. Heck, my "implication" is I spent money on a new keyboard because I thought my perfectly working one was broke!
     
    Last edited: Mar 13, 2012
Thread Status:
Not open for further replies.