EXPLORER.EXE wants connections from Internet

Discussion in 'other firewalls' started by ~*Nat*~, Jul 15, 2006.

Thread Status:
Not open for further replies.
  1. ~*Nat*~

    ~*Nat*~ Registered Member

    Joined:
    Jul 9, 2004
    Posts:
    8,129
    Location:
    Germany/Ohio-USA ~ between two worlds
    Ok. I downloaded an UPGRADE of ZoneAlarm (free) yesterday, right.

    Then all sudden the ZA security Alert pops up telling me

    Windows Explorer wants to accept connections from the Internet.

    Application: EXPLORER.EXE


    I'd like to say that I've had ZA for many years, but I can't remember
    this thing asking for connection rights FROM the internet.

    Oh and I SEEM to be able to surf fine so far, while this thing just waits for my 'answer'. :cautious:


    So, as usual I don't know what to do.
    Allow or Deny ?

    o_O :doubt:
     
  2. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Hi ~*Nat*~,
    You should block/deny this.

    Do you allow explorer.exe outbound connections?
     
  3. ~*Nat*~

    ~*Nat*~ Registered Member

    Joined:
    Jul 9, 2004
    Posts:
    8,129
    Location:
    Germany/Ohio-USA ~ between two worlds
    Hi Stem, :)

    I appreciate your help. I DENIED it as you said I should.

    And yes, under ZA's programs, Windows explorer (Explorer.exe) is allowed
    to access the internet.

    This was done "automatically" when I did a fresh install once if I remember right.
     
  4. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Hi ~*Nat*~,
    Explorer.exe does not need internet connections. I would say you should change this to block/deny.
     
  5. ~*Nat*~

    ~*Nat*~ Registered Member

    Joined:
    Jul 9, 2004
    Posts:
    8,129
    Location:
    Germany/Ohio-USA ~ between two worlds
    Really ? I never allowed it to connect by myself. It's just there, and allowed.
    Strange.
    Alright, I'll deny access to the internet also.

    Thank You !
     
  6. ~*Nat*~

    ~*Nat*~ Registered Member

    Joined:
    Jul 9, 2004
    Posts:
    8,129
    Location:
    Germany/Ohio-USA ~ between two worlds
    Well I tried Windows Explorer (Explorer.exe) to block internet and trusted zone access.

    And I had a feeling it wouldn't work, because it's part of the system.


    I get a pop up warning that if the settings to System Programs are changed
    to custom (like deny/block/...it can cause serious problems.

    Hmmmm...
     
  7. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Hi ~*Nat*~,
    You can block explorer.exe from the internet without any problems. (I myself have always blocked this, with no ill effect).
    You can allow explorer.exe access to the trusted zone
     
  8. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Hi ~*Nat*~,
    I have just installed ZA, to show you:-
     

    Attached Files:

  9. ~*Nat*~

    ~*Nat*~ Registered Member

    Joined:
    Jul 9, 2004
    Posts:
    8,129
    Location:
    Germany/Ohio-USA ~ between two worlds
    Stem, I blocked it to the internet. I got a warning, but I did it anyway.
    I only allow to the trusted zone, like you said.

    Hope all goes well. :eek: :p

    Thanks again! :)
     
  10. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Dont worry,.. it is best to keep internet connections to applications that really need them. All will be fine

    Your very welcome.
     
  11. ThunderZ

    ThunderZ Registered Member

    Joined:
    May 1, 2006
    Posts:
    2,459
    Location:
    North central Ohio, U.S.A.
    It amazes me how many apps. seem to be requesting to accept connections. With few exceptions I have them all blocked regardless of the ZA warning. Those I do not have blocked are set to ask then I only allow as needed.
     
    Last edited by a moderator: Jul 15, 2006
Loading...
Thread Status:
Not open for further replies.