ewido shuts down during scan

Discussion in 'ewido anti-spyware forum' started by LoneWolf, Jun 24, 2006.

Thread Status:
Not open for further replies.
  1. LoneWolf

    LoneWolf Registered Member

    Joined:
    Jan 2, 2006
    Posts:
    3,408
    anyone else having this problem? had 3.5 ,uninstalled and installed ewido4 w/no problems now when i do a scan ewido will start but will shut down completly including the guard before even scanning halfway.no other new software installed
     
  2. vinzenz.ewido

    vinzenz.ewido former ewido team

    Joined:
    Dec 9, 2005
    Posts:
    425
    Location:
    Brno, Czech Republic
    Hi,

    The guard is not shutting down (I presume) only the icon disappears since it is displayed via the ewido main program.

    Please try to scan with one of the following options (scan settings) disabled.
    - "Use heuristics..."
    - "Scan inside compressed executables..."
    - "Scan inside archives and setup files..."

    Please report if the scan can be completed without that ewido shutsdown by itself.

    Thank you.

    BR
     
  3. hangman

    hangman Registered Member

    Joined:
    Mar 21, 2003
    Posts:
    11
    Location:
    South Florida/USA
    I too am having the same problem,just DL'd 4.0 and when I try to scan My computer the program just shuts down after scanning about 25-30% of the total hard drive space.
    When the program shuts down the icon is still in the system tray but if I mouse over it, the icon vanishes!!
    Can anyone tell Me what's going on with this before i decide to upgrade to the paid version??

    Thanks for Your time...
    ...hangman

    edit:
    After further review it seems that the "scan inside archive and setup files" is the problem...
    I shut down all 3 settings and then re-enabled each one 1 at a time to isolate the rogue setting.

    currently running;
    WinXP sp1
    Linksys WRT54GS router\firewall
    Spybot
    Spyware blaster
    AVG 7.1 Pro
    Adaware SE Pro

    If there is any other info I can provide please let Me know

    Thanks...
    ...hangman
     
    Last edited: Jul 5, 2006
  4. as1m

    as1m Registered Member

    Joined:
    Jul 9, 2006
    Posts:
    23
    Hi,

    I would just like 2 know if there was a resolution to this problem as I have the same issue. I serched the forum and found this. As mentioned in the posts I unchecked the "scan within archives and setup files" and the scanner does complete its task. With this option checked the scanner GUI just dissapears (along with the sys tray icon) before completion.

    I suppose as long as the resident shield is on, things should be fine even without scanning within archives and setup files, because the moment an infected archive is opened ewido will notify (I hope).

    However I still feel that the software should function properly and to its fullest extent, so could the ewido moderators please confirm if this is a fix in progress.

    Thanks.
     
  5. peter.ewido

    peter.ewido former ewido team

    Joined:
    Nov 10, 2003
    Posts:
    737
    Location:
    Brno, Czech Republic
    We need to know which file is causing the crash first. Without that, we can't fix it :( Could you perhaps try to isolate the file by only scanning smaller parts of your hard disk? Thank you very much :)
     
    Last edited: Aug 11, 2006
  6. as1m

    as1m Registered Member

    Joined:
    Jul 9, 2006
    Posts:
    23
    Yes that does make sense I aplogise.

    The good news is that I know which folder / partiton its crashing on as I keep all my backup apps & software there. Prior to me havibng that folder ewido was scanning fine.

    So I will try to scan each file individualy to see whch one is the culprit and I'll report back.

    Thanks.
     
  7. as1m

    as1m Registered Member

    Joined:
    Jul 9, 2006
    Posts:
    23
    Hi,

    The problem file is an epson printer driver which is an executable archive (download below). Ewido shuts down whilst scanning if it is saved at a depth of more than 2 folders.:blink:

    E.g.

    epson18706.exe___________scan OK
    folder1\epson18706.exe__________scan OK
    folder1\folder2\epson18706.exe__________scan OK
    folder1\folder2\folder3\epson18706.exe_________Ewido shuts down:(

    I could send you the file, or better I can tell you where to download it from:

    http://esupport.epson-europe.com/Fi...5DC8A33994EAF40F38F0F69EA94FAC78376A81B18350C

    Thanks.
     
  8. peter.ewido

    peter.ewido former ewido team

    Joined:
    Nov 10, 2003
    Posts:
    737
    Location:
    Brno, Czech Republic
    I tried to reproduce it but it didn't work :(
    Can you please tell me the exact path? Thanks!
     
  9. vinzenz.ewido

    vinzenz.ewido former ewido team

    Joined:
    Dec 9, 2005
    Posts:
    425
    Location:
    Brno, Czech Republic

    No need for the exact path. I know how to reproduce it, but currently don't where it happens exactly. :'(

    Thank you as1m for helping us to find it. :)

    BR
    Vinzenz
     
  10. as1m

    as1m Registered Member

    Joined:
    Jul 9, 2006
    Posts:
    23
    Hi,

    The file was H:\Apps & Software\epson\epson18706eu.exe

    When I cut and paste the file into H:\epson18706eu.exe or even
    H:\Apps & Software\epson18706eu.exe then it scans fine

    Thanks.

    PS. As a test, I created "Folder_1". Within this I created "Folder_2", and within this I created "Folder_3" (all on my desktop). I placed epson18706eu.exe inside "Folder_3". thus the path from desktop is "Folder_1\Folder_2\Folder_3\epson18706eu.exe"

    If you point to Folder_1 and scan with Ewido from context menu, the scanner will disappear, as will the sys tray icon. Well it does on my machine.

    Anything else just let us know.

    Thanks
     
    Last edited: Aug 11, 2006
  11. vinzenz.ewido

    vinzenz.ewido former ewido team

    Joined:
    Dec 9, 2005
    Posts:
    425
    Location:
    Brno, Czech Republic
    How I already said. We already know how to reproduce. Thanks.

    Regards,
    Vinzenz
     
  12. as1m

    as1m Registered Member

    Joined:
    Jul 9, 2006
    Posts:
    23
    Sorry Vinzenz but I didn't understand this part of ur sentance:

    "but currently don't where it happens exactly"

    But since u allready know how to reproduce, I'll leave it in ur capable hands.

    Thanks.
     
  13. vinzenz.ewido

    vinzenz.ewido former ewido team

    Joined:
    Dec 9, 2005
    Posts:
    425
    Location:
    Brno, Czech Republic
    Hi,

    I just meant that we didn't know where in our program it happens ;)

    But now we have located it.

    Regards,
    Vinzenz
     
  14. darkfirew

    darkfirew Registered Member

    Joined:
    Aug 13, 2006
    Posts:
    2
    Hello, I am having the same problem. The scan shuts down and the system tray icon disappears. I do not believe I have the same file that the other person has.

    What should i do?
     
  15. peter.ewido

    peter.ewido former ewido team

    Joined:
    Nov 10, 2003
    Posts:
    737
    Location:
    Brno, Czech Republic
    I'm pretty sure your crash is caused by the same bug, I will keep you informed on this matter :)
     
  16. darkfirew

    darkfirew Registered Member

    Joined:
    Aug 13, 2006
    Posts:
    2
    Funny thing is I tried running the program twice in safe mode and it shut down as I said.

    Then I ran it in normal mode, and it completed it's scan. So I rebooted and ran the can again in safe mode, and it completed it's scan. So, now I've had a good two out of four scans worked.

    Thanks
     
  17. peter.ewido

    peter.ewido former ewido team

    Joined:
    Nov 10, 2003
    Posts:
    737
    Location:
    Brno, Czech Republic
    FYI: We found the bug, it's already fixed. The fixed version will be released together with the next program update in about two weeks.
     
Thread Status:
Not open for further replies.