Etrange problème en wifi

Discussion in 'LnS French Forum' started by M?gaT?, Mar 29, 2005.

Thread Status:
Not open for further replies.
  1. M?gaT?

    M?gaT? Guest

    Salut tout le monde,

    Je suis tout nouvel utilisateur de LnS et, après tous ceux que j'ai pu tester, je dois dire que j'en suis super content.
    MAIS...j'ai quand même un problème étrange avec...ou plutôt deux :

    1. Au démarrage de la machine (plutôt d'une session), je suis obligé d'arrêter LnS afin d'établir une connexion Internet, sinon rien ne passe. Et le plus "marrant", c'est que je peux le redémarrer ensuite et tout se passe pour le mieux...un peu chiant !
    2. Au bout d'un moment (10-15 mn), il me bloque à nouveau toute communication. Dans le journal, j'ai un bloquage apparamment du à une suite de paquets de type Ethernet:888E provenant de mon routeur (connexion wifi) ?? (toute dernière règle "bloque tout le reste")

    J'ai beau chercher à droite, à gauche, je ne comprends pas le premier comportement et ne trouve rien sur la signification des données envoyées par le routeur : sont elles envoyées en permanence et bloquées seulement au bout de 10 à 15 mn, est-ce mon routeur qui les envoi au bout d'un moment ?? Faut dire que ça ne fait que 2 jours que je fonctionne en wifi...ça peut tout aussi bien provenir de là !

    Si quelqu'un peut me donner des pistes, je lui en serais fort reconnaissant !

    Salut,

    Christophe

    PS : je viens de stopper LnS qui m'empêche d'envoyer ce post :eek:(
     
  2. scoubfgh

    scoubfgh Registered Member

    Joined:
    Feb 28, 2004
    Posts:
    24
    Bonjour,

    Je rencontre le même problème avec un routeur Linksys WRT54GS. Lors du démarrage c'est très lent et je dois réparer ma connexion WIFI pour me connecter. Ensuite assez régulièrement la connexion internet ne se fait plus alors que la connexion WIFI est donnée comme active par l'icone correspondante. Lorsque je répare cette connexion à l'aide des options de l'icone cela fonctionne à nouveau pour un temps plus ou moins long. J'ai pensé au firewall et depuis que je l'ai stoppé plus de problèmes.

    Le firewall du routeur est activé, est-il suffisant et si non comment paramétrer LnS pour que cela fonctionne ?

    Merci d'avance pour votre aide.

    Frank
     
  3. JF

    JF LnS Support

    Joined:
    Jan 12, 2003
    Posts:
    294
    Bonjour,

    Les solutions de sécurité WPA ou WPA2 (Wireless Protected Access) pour connexions WiFi se basent sur le protocole EAP (Extensible Authentication Protocol - Protocole d'authentification étendue) qui repose lui même sur des trames Ethernet spéciales dont le type est 0x888E.
    (cf chapître 7.8 de http://standards.ieee.org/getieee802/download/802.1X-2001.pdf )

    Donc il faut sans doute autoriser ces trames Ethernet de type 0x888E dans votre cas pour que le protocole EAP puisse s'éxécuter.

    La technique la plus simple avec Look 'n' Stop consiste à autoriser toutes les trames Ethernet de type 'Autre' (autres que IP et ARP) à l'aide d'une règle de filtrage Internet. Voir la zone 'Ethernet Type' de la fenêtre d'édition de règles du filtrage Internet.

    Une technique plus compliquée mais plus ciblée consiste à ajouter une règle autorisant les trames Ethernet dont le type est précisémment 0x888E.
    La fenêtre standard d'édition de règles ne permet pas d'éditer une telle règle. Il faut pour cela installer le plugin d'édition de règles brute.
    http://www.looknstop.com/plugin/ PluginEditRawRule.dll
    Cette page explique comment installer les plugins.
    http://www.looknstop.com/Fr/plugin.htm
    et celle ci parle plus particulièrement des plugins d'édition de règles
    http://www.looknstop.com/Fr/plugin_ruleedition_use.htm

    Quand le plugin est installé, il reste à créer la règle autorisant les trames Ethernet de type 0x888E.
    Pour simplifier les opérations, il suffit d'importer cette règle: http://looknstop.soft4ever.com/Rules/WiFiRouteur_ETH_Type_0x888E.rie

    Cette règle autorise les trames échangées entre les adresses Ethernet 01:02:03:04:05:06 et 0A:0B:0C:0D:0E:0F.
    Il faut remplacer ces adresses par celle du PC et du routeur WiFi.
    Positionner "Value Display" sur "Hexa - Byte split" pour adopter le type d'affichage classique pour une adresse Ethernet. Placer "Field" sur 1 pour modifier la 1ère adresse puis sur 2 pour la 2ème (peu importe l'ordre PC/Routeur)

    Si vous préférez autoriser toutes les trames Ethernet de type 0x888E, quelles que soient les adresses MAC, vous pouvez ignorer Field 1 et Field 2 en positionnant "Criteria" sur NA (Not Applicable).

    Une précision: je n'ai pas pu tester cette règle brute en grandeur réelle.

    Dernier point: un sujet analogue a été discuté sur le forum anglais.
    https://www.wilderssecurity.com/showthread.php?p=360673#post360673

    Cordialement,
    JF
     

    Attached Files:

  4. scoubfgh

    scoubfgh Registered Member

    Joined:
    Feb 28, 2004
    Posts:
    24
    Merci beaucoup pour votre réponse. J'ai donc tenté en important la règle que vous citez et je pensais que c'était bon, mais ce matin même problème et pourtant la règle est présente et active (je l'avais sauvegardé hier soir).

    Peut-être ai-je mal rempli les adresses car je ne suis pas sur, à ce propos comment les connaitre dans le format LnS ?

    De plus quand je laisse cocher l'option TCP stateful packet inspection cela bloque mon lecteur de news.

    Merci d'avance, pour l'instant j'en suis réduis à laisser le filtrage internet inactif et faire confiance au firewall du routeur.

    Frank
     
  5. JF

    JF LnS Support

    Joined:
    Jan 12, 2003
    Posts:
    294
    Bonjour,

    Le plus simple est de rentrer les adresses MAC (Ethernet) dans ce format: 01:02:03:04:05:06 (hexadécimal).

    Pour ça, il faut positionner Display Value sur Hexa Byte Split dans le plugin d'édition de règles brutes.

    Cordialement,
    JF
     
  6. scoubfgh

    scoubfgh Registered Member

    Joined:
    Feb 28, 2004
    Posts:
    24
    Pour ça votre message précédent était suffisament clair mais comment connaitre les adresses du PC et du routeur.

    Pour le PC c'est bien l'adresse correspondant à la carte WIFI que je coche dans les options de Lns ?

    Et pour le routeur quand je le configure je tape 192.168.1.1 comment transformer cette adresse en MAC si c'est la bonne ?

    Encore merci.

    Frank
     
  7. JF

    JF LnS Support

    Joined:
    Jan 12, 2003
    Posts:
    294
    Bonjour,

    Une façon de récupérer les adresses Ethernet source et destination des trames Ethernet 0x888E bloquées est de double-cliquer sur une ligne du journal correspondant à cette trame bloquée.
    Les adresses Ethernet apparaissent dans le contenu du paquet affiché.

    Cordialement,
    JF
     
  8. scoubfgh

    scoubfgh Registered Member

    Joined:
    Feb 28, 2004
    Posts:
    24
    Pour les adresses j'ai vérifié en utilisant votre conseil j'avais bien configuré. Ensuite comme cela ne laisse toujours pas passer les trames Ethernet j'ai suivi votre idée de laisser passer toutes les trames en ignorant Field 1 et 2 mais j'ai toujours des trames bloquées dans le journal.

    Je suis donc dans une impasse pour l'instant, je vais tenter de regarder sur le forum anglais comme vous l'indiquez.

    Je vous tiens au courant.

    Merci pour tout.

    Frank
     
  9. scoubfgh

    scoubfgh Registered Member

    Joined:
    Feb 28, 2004
    Posts:
    24
    Je vous tiens donc au courant de mes aventures. J'ai donc repris à zéro avec la règle proposé par JF. Elle fonctionne si je ne renseigne pas les adresses mac du PC et du routeur. En effet quand je place les adresses dans les champs nommés field 1 et 2 les trames Pc vers internet sont autorisés mais les trames internet vers PC sont bloqués.

    Cela a également réglé mon problème concernant l'option TCP stateful et mon lecteur de news.

    Merci encore à JF pour son aide rapide et précieuse.

    Frank
     
Thread Status:
Not open for further replies.