ESS v4 Blocking WMP12 Remote Control

Discussion in 'ESET Smart Security' started by MasterTB, Nov 21, 2009.

Thread Status:
Not open for further replies.
  1. MasterTB

    MasterTB Registered Member

    Joined:
    Jun 19, 2007
    Posts:
    547
    Location:
    Paran?, Argentina
    I have a home network and unless I completely disable ESS's Firewall I cannot use WMP12 Remote Control feature.

    The machines simply don't see each others WMP to controll.

    The issue Is with Windows 7 and it has been checked. Using the Windows firewall works like a charm.

    Edit: The firewall log says it is blocking ICSLAP Outgoing Requests (UNPnP) to the WMP and From the WMP

    ok, there is no mistake here, it is a deliberate rule in ESS that prevents the comunication.
    WHY ON EARTH WOULD YOU PUT THAT RULE THERE? ARE YOU TRYING TO MAKE US ALL ANGRY AT YOU?
    there is a default rule in the firewall that says "BLOCK OUTGOING (AND INCOMING) ICSLAP (UNPnP) CONNECTIONS" but it is not limited to untrusted zones, NO it is a GENERAL BLOCK ALL RULE FOR ICSLAP...

    where is the danger that you made the rule block ALL TRUSTED AND UNTRUSTED? WHY NOT LIMIT IT TO UNTRUSTED AT LEAST?


    I really don't understand you guys.
     
    Last edited: Nov 22, 2009
  2. RyanH

    RyanH Eset Staff Account

    Joined:
    Nov 9, 2009
    Posts:
    64
    Hey MasterTB,

    Please do the following:

    1. Open the main program window by clicking 'Start' -> 'All Programs' -> 'ESET' -> 'ESET Smart Security'.

    2. Press the F5 key to open the Advanced Setup window.

    3. From the Advanced Setup tree on the left, Click 'Personal firewall' , and then select 'Interactive mode' from the Filtering mode drop-down menu.

    4. From the advanced setup tree, click 'Personal Firewall' -> 'Rules and zones'. Click the 'Setup...' button in the Trusted zone section and then choose 'Allow sharing'. Click 'OK'.

    5. Click 'Personal Firewall' -> 'IDS and advanced options'. In the 'Allowed services' section, make sure all services are selected. Click 'OK'.
     
  3. MasterTB

    MasterTB Registered Member

    Joined:
    Jun 19, 2007
    Posts:
    547
    Location:
    Paran?, Argentina
    Hi, thanks for posting. That was all done before I posted this.
    The only solution was to uncheck the rule "Block Outgoing ICSLAP..." from the preset rules on the firewall.

    That's why I'm so frustrated (to say it politely) I'm not a novice to firewalls and/or to ESS.

    I was also a beta tester for version 3.0 and 4.0 so I think I'm pretty familiar with it.
     
  4. MasterTB

    MasterTB Registered Member

    Joined:
    Jun 19, 2007
    Posts:
    547
    Location:
    Paran?, Argentina
    An Update on the matter, Updated ESS to Ver. 4.0.474.0 and the problem persists.
    Why don't you limit the block ICSLAP outgoing rule to only the Internet?
     
Thread Status:
Not open for further replies.