ESS Firewall blocks my LAN transfers

Discussion in 'ESET Smart Security' started by dkazaz, Sep 28, 2008.

Thread Status:
Not open for further replies.
  1. dkazaz

    dkazaz Registered Member

    Joined:
    May 6, 2006
    Posts:
    11
    File transfers between my two vista PCs are killed by the ESS firewall (they start, slow down to a crawl and after a min they stop completely with an error message about the network not being available).

    Disabling the firewall instantly solves the problem, but since my desktop is also connected to the internet it is not a good idea.

    Is there a way to configure it to not filter any transfers to LAN addresses?
    I defined the LAN address range I use as part of the trusted zone but it made no difference...

    Is there a way to set it so it doesn't affect these connections?
     
  2. Kosak

    Kosak Registered Member

    Joined:
    Jul 25, 2007
    Posts:
    711
    Location:
    Slovakia
    Hello,

    did you try interactive mode?

    Regards
     
  3. dkazaz

    dkazaz Registered Member

    Joined:
    May 6, 2006
    Posts:
    11
    Yes, I'm in interactive mode and have set up a custom rule to allow all applications all ports and all protocols for the 2 Local addresses in my LAN.

    It makes no difference - I'm starting to think I need to find some way to completely disable it for those addresses otherwise ESET needs to fix the bug in the firewall
     
  4. dkazaz

    dkazaz Registered Member

    Joined:
    May 6, 2006
    Posts:
    11
    Can anyone please help?

    This is pretty much making ESS completely useless for me - I may have to go back to NOD 32 and use windows firewall, which despite being an inferior product at least performs to a minimum standard.

    A firewall shouldn't kill my LAN transfers, its just unacceptable.
     
  5. funkydude

    funkydude Registered Member

    Joined:
    Apr 5, 2004
    Posts:
    6,856
    Did you per chance restrict sharing?

    Setup > Personal Firewall > Change the protection mode of your computer in the network > Allow sharing
     
  6. dkazaz

    dkazaz Registered Member

    Joined:
    May 6, 2006
    Posts:
    11
    Yes, I did that too as well. The weird thing is that I downloaded and installed the latest ESS and that 'cured' the problem for a day but the next day it was back! This is totally strange but I assume it may have been an update or an applicaton of new settings with the reboot.

    I have no doubt ESS is at fault because when I turn it off the problem goes away. I am wondering however if Windows Vista also plays a part because the problem does not occur under XP.
     
  7. dkazaz

    dkazaz Registered Member

    Joined:
    May 6, 2006
    Posts:
    11
    Re: ESS Firewall blocks my LAN transfers / Incorrect TCP checksum

    OK, I've tracked to problem down to the "Incorrect TCP checksum" bug. I thought this had been resolved in previous releases, but perhaps a recent release broke it again?
     
  8. dkazaz

    dkazaz Registered Member

    Joined:
    May 6, 2006
    Posts:
    11
    I seem to have resolved the issue by disabling IPv6 from network properties - it seems ESS is unable to cope with IPv6 datagrams and this was making it kill the connection....
     
Thread Status:
Not open for further replies.