ESS blocks all games on Steam

Discussion in 'ESET Smart Security' started by ghoti, Apr 1, 2008.

Thread Status:
Not open for further replies.
  1. ghoti

    ghoti Registered Member

    Joined:
    Apr 1, 2008
    Posts:
    3
  2. shansmi

    shansmi Registered Member

    Joined:
    Feb 19, 2008
    Posts:
    130
    you will need to do one of two things:

    Put your firewall in interactive mode and then allow the traffic and be sure to save your choice so it will build a custom rule or

    add the game rules all manaully

    I have this all working on my PC with no issues in interactive mode... I was playing the free games from NVidia but they are delivered by Steam....
     
  3. ghoti

    ghoti Registered Member

    Joined:
    Apr 1, 2008
    Posts:
    3
    That's what I thought. The thing is, it's been working fine for months before earlier today when it suddenly blocked everything. Is there a way to add custom rules to the "auto" mode? I don't like the firewall asking me about everything like Norman and Sunbelt do :(
     
  4. shansmi

    shansmi Registered Member

    Joined:
    Feb 19, 2008
    Posts:
    130
    that is not what I said do or at least what I meant to say do... do it just to see what rules get added... You would only need to look at the inbound rules and add them into the firewall once it is back in Auto mode....

    and by the way, the firewall asking for permission only lasts for a little while if all your default apps are installed and tested immediately after an ESS install with the firewall in interactive mode... I can do a complete re-install of ESS and have all my defaults working within 30 minutes...now it only asks if I add something new....

    after that usually I allow but do not save my response if it is a new application just to see what all it is trying to do....once I figure all that out, I allow and save on second launch......
     
  5. ghoti

    ghoti Registered Member

    Joined:
    Apr 1, 2008
    Posts:
    3
    Allright will try, thanks!
     
  6. Excelsior

    Excelsior Registered Member

    Joined:
    Apr 7, 2008
    Posts:
    6
    I am unable to connect to the steam client at all since installing Smart Security. It was an upgrade from NOD32. I have tried disabling both, adding rules and everything short of uninstalling ESS. There have been no other changes on my computer.
     
  7. Excelsior

    Excelsior Registered Member

    Joined:
    Apr 7, 2008
    Posts:
    6
    In playing around today, I think I figured a way around it.

    1) I disabled the firewall, still could not connect.
    2) Downloaded Steam client and installed it again, it connected.
    3) Turned on firewall and now now it can connect without issues.

    Very odd!
     
  8. Wardy

    Wardy Registered Member

    Joined:
    Aug 27, 2006
    Posts:
    16
    I have exactly the same problem.

    Worked fine for months, got an update and now even interactive mode can't fix it.

    Will try to re-install steam and see what happens.....
     
  9. Wardy

    Wardy Registered Member

    Joined:
    Aug 27, 2006
    Posts:
    16
    Yep, re-installing steam fixes this......

    bit of a job to re-download all my games though :rolleyes:

    Not sure if it's Steam or ESS as both appear to have had an update since I last used them together.......
     
  10. MasterTB

    MasterTB Registered Member

    Joined:
    Jun 19, 2007
    Posts:
    547
    Location:
    Paran?, Argentina
    You say it worked for months and now after an update it is not working anymore, did ESS ask you to allow the updated exe when it was run for the first time after the update?? because if you mistakenly denied the change then you are the one who blocked it.
    BTW: there is no way to add rules in automatic mode. In this mode the firewall temporarily creates the rules it need for every program every time it is run and then automaticly deletes them.
    If you want rules, you have to run the firewall in Interactive Mode and then it will prompt you everytime there is a connection for which no rules have been added so you can create them.
     
  11. Wardy

    Wardy Registered Member

    Joined:
    Aug 27, 2006
    Posts:
    16
    OK for the benefit of clarity, as per my first post

    I use ESS in automatic mode, around the 10th I launched steam, it briefly flashed up the updating dialogue box but then failed to connect. No other programs appeared to suffer the same loss of connection, only Steam. All previous updates worked fine, both Steam & ESS.

    Switching to interactive mode and manually creating the rule to allow comunications in both directions made no difference, steam couldn't connect. I know you can't create rules in automatic mode.

    At no point did I manually deny access.

    Downloading and reinstalling Steam cured the problem, auto mode worked fine first time. It did mean however I lost my save points and was downloading games for 2 days straight.

    Something odd happened and others also suffered the same problem as myself, and at the same time which points to something other than user error.
     
Thread Status:
Not open for further replies.