Eset + W7 + dotNET one click download

Discussion in 'ESET Smart Security' started by bodgy, Oct 25, 2009.

Thread Status:
Not open for further replies.
  1. bodgy

    bodgy Registered Member

    Joined:
    Sep 22, 2005
    Posts:
    2,387
    Location:
    Qld.
    Windows 7 Ultimate 64 bit RTm 7600.
    ESS 4.0.437.0 and 467

    I have a CAD program that uses the dotNet infrastructure and auto updates via the Microsoft 'one-click' function.

    Every update that occurs, ESS needs to be assured that the program can be opened - it happily accepts the download.

    If the firewall gets too many entries, somewhere between the W7, ESS and dotNet the W7 debugger utility is invoked, even though the program actually opens correctly. Once the W7 debug option has appeared, the choices are search the internet for a solution or close the program.

    I've found deleting the multiple entries in Zones and Rules setup, allows the program to open without instanitaing the W7 debug function.

    I have tried making th eprogram and it's folders an exception so as not to be checked, and I've even exempted the website server address, however this makes no difference.

    This behaviour does not manifest itself in XPpro SP3 - there are no problems at all.

    The program being downloaded is DeX, an Electronics CAD program from Kov.com

    Is there a work around to prevent ESS asking for permission to allow DeX to run after every upgrade, or alternatively to exempt the program from being tracked.

    I don't particularly want to change from ineractive mode to automatic, as I like to pretend I'm in control of my computer.

    Colin
     
  2. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    You have already posted this problem elsewhere. The thing is the application's executable is detected as Win32/Statik unwanted application which means it's only detected if you have chosen to detect unwanted applications. A temporary workaround would either be disabling unwanted applications in the web protection setup or adding the url to the list of addressed excluded from content filtering.
     
  3. bodgy

    bodgy Registered Member

    Joined:
    Sep 22, 2005
    Posts:
    2,387
    Location:
    Qld.
    Not wishing to be pedantic but, not quite the same problem, which is why I made it two posts.

    This particular problem has been since I installed W7 RTM back in early September. As one of the beta testers for DeX (before it became a public beta), I have been installing the various versions since February of this year.

    My other post problem has only occured since last Friday, and on reflection might be due to the download Server having changed.

    I'll try adding the URL to excluded content filtering.

    It seems to be an annoying side effect of the MS one-click system, is that a new contents folder is created on every download. I think this is the reason ESS thinks a new install has occured.

    Thanks

    Colin
     
Thread Status:
Not open for further replies.