ESET Smart Security Blocks Thunderbird Webmail

Discussion in 'ESET Smart Security' started by jjn361, Sep 7, 2008.

Thread Status:
Not open for further replies.
  1. jjn361

    jjn361 Registered Member

    Joined:
    Sep 4, 2008
    Posts:
    9
    I am having a problem with my new laptop and ESET Smart Security blocking my Hotmail webmail through Thunderbird and was wondering if anyone else had experienced similar problems and knew a fix for it.

    I have a new Dell XPS laptop running Windows Vista Ultimate. When I first got it, I installed both Thunderbird and ESET Smart Security on it with no problems. To access Hotmail through Thunderbird both the webmail extenstion (1.3.2) and the Hotmail extension (1.2.18 ) must be installed. For about 4 weeks this worked beautifully with ESET Smart Security. But then I had a catastophic Vista failure and was forced to reset the machine back to factory settings, in other words, back to square one.

    But in rebuilding the machine, ESET will now no longer allow Thunderbird to access my Hotmail webmail. I have two different accounts coming into Thunderbird. My work e-mail can move in and out with no difficulties, so it's not a question of allowing Thunderbird through the firewall. My Hotmail can send out, but it will not even look for it when you ask for it to download the hotmail. In the bottom status bar you see 'Connected to local host...' for about 1 second and then it simply disappears. No error or anything.

    The settings for webmail through Thunderbird are Pop3 - port 110, SMTP - port 25 and IMAP - port 143. All are running.

    I've tried a few things. If I go into services and set ESET to manual instead of automatic and then reboot, Thunderbird works fine. Until you restart ESET. If you completely uninstall ESET, Thunderbird works fine. When you download the hotmail webmail, you get the same 'Connecting to local host...' in the lower status bar, but this then actually asks for a password for the account. Reinstall it, and Thunderbird will only access one of the two accounts and again doesn't even seen to recognize that webmail is there.

    It's definitely something having to do with ESET Smart Security, not Thunderbird.

    I'm getting quite frustrated, and I really don't want to remove Smart Security because it's a good product, but I'm starting to get to that point. But first I wanted to ask some of you much more knowledgeable users if you were aware of a fix for this problem. I've seen other people on line who have this exact problem and not one of them had a solution suggested to them to resolve it.

    Thanks to any and all who can help!
     
  2. Jenee

    Jenee Registered Member

    Joined:
    Dec 27, 2007
    Posts:
    185
    In Advanced Setup, under Pop3, are the relevant ports listed for email checking? You should have 110 and the other port you have set up for accessing the Hotmail account.
    Under the heading for Email Clients, is Thunderbird listed and ticked.
    Under Personal Firewall, Rules & Zones, does Thunderbird have access.
    If Thunderbird does have access and all the above is ok, make sure you are running in Interactive Mode, remove Thunderbird from the Rules & Zone list so that the next time you open Thunderbird, you should get a popup from ESS which will then allow you to give access to Thunderbird and the rules will be setup again.
     
  3. jjn361

    jjn361 Registered Member

    Joined:
    Sep 4, 2008
    Posts:
    9
    Yes, POP3 is specified at port 110.
    This is already done as well.
    Yes, it does.
    I did this as well, several times in fact and over several installations of ESET Smart Security. This doesn't change anything and the webmail access of Thunderbird still does nothing while my other account has access through Thunderbird with no difficulties.

    Thank you for your suggestions...now you see why I'm somewhat confused. It should be working fine...
     
  4. Jenee

    Jenee Registered Member

    Joined:
    Dec 27, 2007
    Posts:
    185
    Quote
    "Yes, POP3 is specified at port 110."

    I believe you need another port for the Hotmail account.
    I have a Gmail account which I setup to access through Thunderbird but it has a different port to the normal Pop3 port 110.
    Can you check the settings in Thunderbird for the Hotmail account and see which port number it is using. It will be under Account Settings/Server Settings.
     
  5. jjn361

    jjn361 Registered Member

    Joined:
    Sep 4, 2008
    Posts:
    9
    Thanks for the reply...

    I did check the Thunderbird settings and it is set to 110 (which is considered the Thunderbird default). This matches the ESET settings.
     
  6. jjn361

    jjn361 Registered Member

    Joined:
    Sep 4, 2008
    Posts:
    9
    In the end I solved my own problem with the help of a very knowledgeable friend, so I thought I'd post it here in case anyone else has any difficulties. In the end, I removed ESET Smart Security and put on the Comodo Firewall (3.0.25.378 ) and ESET anti-virus Nod32 (3.0.669.0).

    This did not solve the problem, so obviously the issue is the ESET AV portion of Smart Security. It was then suggested that I edit the host files in windows\system 32\drivers\etc. I commented out the last line (by adding the # sign at the beginning of the line) as follows:

    # Copyright (c) 1993-2006 Microsoft Corp.
    #
    # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
    #
    # This file contains the mappings of IP addresses to host names. Each
    # entry should be kept on an individual line. The IP address should
    # be placed in the first column followed by the corresponding host name.
    # The IP address and the host name should be separated by at least one
    # space.
    #
    # Additionally, comments (such as these) may be inserted on individual
    # lines or following the machine name denoted by a '#' symbol.
    #
    # For example:
    #
    # 102.54.94.97 rhino.acme.com # source server
    # 38.25.63.10 x.acme.com # x client host

    127.0.0.1 localhost
    #::1 localhost

    Now, IPv6 is unchecked on this computer, but still this seems to have made the difference.

    I also have the webmail for Hotmail going through POP 8110 and for my work mail going through 110 and this is acceptable to ESET AV.

    I haven't had any problems since. But it was an 'if it ain't broke don't fix it' moment, so I swapped out my Smart Security license for a Nod32 license and I'm just going to leave the machine set up this way. But it could very well work with Smart Security installed as well as it was the AV portion that appeared to be causing all the problems.
     
  7. FauxMaven

    FauxMaven Registered Member

    Joined:
    May 22, 2008
    Posts:
    11
    When I provided the "fix" for the Thunderbird/Hotmail extension problem described in the previous post, I tested the HOSTS file modification on
    • a home-built computer installed with Vista from a Microsoft-sourced image
    • with IPv6 is enabled
    My "solution" was based upon previous experience in getting Visual Studio 2008 + IIS components working correctly when NOD32 3.x kernel service was started. I would appreciate ESET actually responding with an explanation of why this "fix" actually works.
     
Thread Status:
Not open for further replies.