ESET Smart Security and Wake On Lan feature

Discussion in 'ESET Smart Security' started by vannguyen0, Jun 4, 2008.

Thread Status:
Not open for further replies.
  1. vannguyen0

    vannguyen0 Registered Member

    Joined:
    Jun 4, 2008
    Posts:
    1
    Prior to installing ESET Smart Security on my computer, I was able to wake my computer up remotely. But after installing it, my computer will not wake up remotely (wake on lan feature). Is there a port number I need to let through? Has anyone else gotten wake on lan to work with ESET Smart Security installed?

    Thanks in advance.
     
  2. TBubba

    TBubba Registered Member

    Joined:
    Jul 16, 2008
    Posts:
    4
    I haven't managed it, ESET Smart Security breaks my Wake On Lan feature also (Vista 64, 780i, Q6600). My guess is that ESET is using the PassThru driver (or technology similar to) mentioned in Microsoft's KB932633 article. Does anyone at ESET read these forums and if so, when does ESET plan to address this?
     
  3. mickhardy

    mickhardy Registered Member

    Joined:
    May 16, 2005
    Posts:
    140
    Location:
    Australia
    I have WOL - actually WOI - fully operational on Vista 32 with ESS installed on both computers.

    How does ESS affect a computer which is shut down?
     
  4. TBubba

    TBubba Registered Member

    Joined:
    Jul 16, 2008
    Posts:
    4
    First, lets make sure we're talking about the same thing: waking a computer from the sleep state, not the (soft) off state. Waking a computer from the (soft) off state is a hardware issue that shouldn't be related to any software on the system.

    I start Vista, log in, then put the computer to sleep. The computer goes to sleep normally. However, with ESS installed it will not wake up when magic packets are sent to it. I've tried Internet forwarded and LAN broadcasts magic packets with no luck. A network monitor running while Vista 64 is awake confirms the packet is correct and being received. If I uninstall ESS, the problem immediately corrects itself.

    Now, digging deeper, I looked at the Hidden Devices in Device Manager. This show a "MAC Bridge Miniport" and a "MAC Bridge Miniport - Eset Personal Firewall Miniport" as well as other "Eset Personal Firewall Miniport" entries. Since I've already discovered having my NIC under a Bridge in Vista breaks my sleep state WOL, ESS's use of bridging (hidden or not) is likely the reason WOL isn't working for me.

    As an aside, does your system work with WOL from sleep state?
     
  5. mickhardy

    mickhardy Registered Member

    Joined:
    May 16, 2005
    Posts:
    140
    Location:
    Australia
    Yes, both my work computer and my home computer can be woken from soft off (S5) and from Sleep. Both computers are running ESS V3.0.667 on Vista 32. I just fully tested both configurations.

    I don't have Wake from Internet enabled at work but I just tested WOL across the LAN and it worked fine. I had a lot of trouble with my home router forgetting the ARP entry after a few minutes in the Sleep state but eventually managed to add a static ARP entry. I haven't had any issues with WOL since doing this from either Sleep, which is automatic after an hour or S5, which is the normal state for my home computer.

    When testing at work, I used WakeOnLanMonitor from Depicus and ESS correctly identified the traffic and created a new rule. I let my computer sleep for five minutes while I grabbed a coffee and it woke up instantly from Sleep. I repeated the process a couple of times to be sure.

    Work computer is an ASUS P5B-Plus with an Atheros Gigabit LAN Adapter and driver V2.4.3.17

    Home computer is an ASUS P5K-E/Wifi with a Marvell88E8056® PCI-E Gigabit LAN controller and driver V10.61.2.3

    Hope this helps.
     
  6. dojigiri

    dojigiri Registered Member

    Joined:
    Aug 17, 2008
    Posts:
    3
    Hello mickhardy, could you please help me - how did you managed to get the WOL from S5 work with the Asus P5K-E/Wifi? I have the same mobo and I cannot get it work.

    Which exact values do you have enabled in the Bios, under the Power/APM Configuration? I have enabled "Power on by external modems" and "Power on by PCIE devices" (and this is the single value I should have enabled I think, as I believe that the Marvel LAN card is connected to the PCI-E). The value "Power on by PCI devices" I have set to disabled, because if enabled, the system starts immediately after powering down.
    The network seems to be active after powering down (e.g. when connected to router, the led lights), but WOL works not.

    I try to send the magic packet using the same Depicus WakeOnLan tool as you said you use, I tried with both Local (which sends broadcast 255.255.255.255) or Internet (sends bc to the local subnet, e.g. 192.168.0.255), I tried with ports 7,9. I tried first through router (all computers are connected together with router) and even direct connection between the two comuters, no difference, the computer with the P5K-E mobo does not wake up.

    (I have one another computer with GA-P35-DQ6 which I also want to wake on remotely, and I also cannot get it work, so it can be I'm doing something entirely wrong, but I cannot figure how to solve this)
     
  7. mickhardy

    mickhardy Registered Member

    Joined:
    May 16, 2005
    Posts:
    140
    Location:
    Australia
    I wrote a long reply but the page expired and I lost the lot. "Power on by PCI-E devices" is the only BIOS setting you need.

    It sounds like you're nearly there. I reckon your router will be the problem as not all routers can broadcast. I actually forward Port 7 to a static IP address on my internal LAN. I had to create a static ARP entry in the router or WOL would only work for a few minutes after shutting down before the router's ARP cache cleared.

    Use WakeOnLanMonitor from Depicus to monitor the magic packet with the computer on. You can't proceed until you get that working.

    There are a heap of sites dedicated to WOL and the many different issues are too complicated for this forum. ESS does not block WOL and I don't think it could ever affect it. You will need an ESS rule for WakeOnLanMonitor but not for WOL itself.

    When set to Local Subnet, the IP address and subnet mask are irrelevant because it always broadcasts to the 255.255.255.255 special limited to LAN broadcast address. If your router does not support broadcast, the packet will be dropped.

    With nearly every router, you should be able to set up port forwarding but you will need to specify the exact IP, using the Internet Option and calculate your subnet mask. Depicus have a good help page on how to calculate this.

    Remember that not all routers can broadcast. If you can borrow a cheap switch, you can test broadcasting without the router to see if this is the issue.

    EDIT: Connecting two computers directly will never work unless you have a special cross over Network cable.
     
    Last edited: Aug 17, 2008
  8. dojigiri

    dojigiri Registered Member

    Joined:
    Aug 17, 2008
    Posts:
    3
    Thanks for your help, I came a little bit further. I tried the WakeOnLan monitor and the packets are coming even through the router (I try first with the global broadcast for local network 255.255.255.255).

    The strange thing I experienced yesterday is, that the computer can be woken on LAN when it it in hibernation mode (suspend to disk, S4 - when I put WinXP into hibernation, saving RAM contents to the disk = when I use Start/Turn Off Computer/Hibernate), which I tried last time, but still does not wake up from soft off (S5) mode (= when I use Start/Turn Off Computer/Turn Off).
    (according to this suspend state definitions: http://en.wikipedia.org/wiki/Advanced_Configuration_and_Power_Interface)
    So, you are really able to wake up from S5 mode (turn off), not only hibernation?

    I believed before, that this is the same (= hibernation and turning off) only with the difference that in hibernation the contents of RAM is written to the disk file hiberfil.sys and the boot loader is "reconfigured" to resume from hibernate, but obviously there is some more magic that the system does when it turns the computer off after hibernate - e.g. I'm also able to wake the computer from hibernation when I move USB mouse, but this is not possible after normal Turn Off (in S5).

    I also thought it can be some bios bug, so I updated bios from version 0503 to 1102 but still no difference.

    Btw. which values do you have under bios Power menu? I have there following:
    Suspend mode: S3 only
    Repost Video on S3 Resume: Disabled
    ACPI 2.0 Support: Disabled
    ACPI APIC Support: Enabled

    Maybe I should try to enable the ACPI 2.0 today, this I didn't test so far.
     
  9. mickhardy

    mickhardy Registered Member

    Joined:
    May 16, 2005
    Posts:
    140
    Location:
    Australia
    It's great your magic packets are being received. You must be almost there. I remember having initial problems waking from S5 but waking from Sleep was functional. I can't remember what I changed but I'm pretty sure it was within the Vista OS. I've just woken it up to double check. ;) You are using the Wired LAN, not the Wireless LAN?

    My computer wakes from S5. It is not hibernating. It is completely off with power only to the LAN and Keyboard. It progresses through the full boot process.

    I'm running Windows Vista and select Orb -> Arrow -> Shutdown but I've also changed the Orb -> Power Off button to be shutdown rather than sleep. I would use sleep but it has a really annoying flashing blue LED that is way too bright for night time.

    The settings below I wrote down this morning but I can't check the BIOS remotely for the ones I can't remember.
    Suspend mode: Can't remember but will check tonight
    Repost Video on S3 Resume: Can't remember but will check tonight
    ACPI 2.0 Support: Disabled
    ACPI APIC Support: Enabled
    I also have
    Power on by PS/2 Keyboard set to Space Bar
    and
    Power on by PCI-E Enabled

    Everything else in that Power On list is disabled.

    Have you upgraded your LAN drivers from the Marvel site? The ASUS ones are way behind. This may have been what fixed the WOL from S5. At first only WOL from Sleep was working for me.

    In Device Manager under the LAN Adaptor, I have Wake From Shutdown ON and Wake Up Capabilities set to Magic Packet. On the Power Management tab, I have Allow Turn Off and Allow Wake Up as per screen shots.

    Marvell.jpg
    Marbell2.jpg
     
  10. mickhardy

    mickhardy Registered Member

    Joined:
    May 16, 2005
    Posts:
    140
    Location:
    Australia
    My Marvel Drivers are version 10.61.2.3

    Marvell Driver.jpg

    Showing Shutdown from Vista - not sleep and not hibernate

    Shutdown.jpg
     
  11. dojigiri

    dojigiri Registered Member

    Joined:
    Aug 17, 2008
    Posts:
    3
    Yes, this was the problem. I have found it just a few minutes ago by myself (and I came here to write the response that it is running and I've seen that you already gave the solution here).

    I had the value "Wake From Shutdown" set to OFF, which caused that the system was not able to wake from S5. Now it works :), only when the system is shut down from Windows though (so it does not work e.g. when I restart the system and press the case button to soft-off), but this is already good enough.
    (btw., I have Win XP installed there, with SP3, but the values under network adapter configuration are nearly the same)


    Thank you very much for your help :)
     
  12. mickhardy

    mickhardy Registered Member

    Joined:
    May 16, 2005
    Posts:
    140
    Location:
    Australia
    No worries. Glad to help where I can.

    You will never be able to use WOL if the computer wasn't shut down from Windows. This is by design. I also have the computer set to Powered On after Power Failure to get around this potential issue.

    So, in summary, ESS does not break WOL at your end either. Cool!
     
  13. TBubba

    TBubba Registered Member

    Joined:
    Jul 16, 2008
    Posts:
    4
    Just wanted to follow up on this. When I had ESS installed, WOL was broken for my nForce NICs. I purchased a PCIe Marvell NIC, installed and configured it, and my computer now handles WOL correctly (limited testing).

    Thanks for the replies Mickhardy, they gave me hope to go on (cue sweeping, dramatic music). :D
     
Thread Status:
Not open for further replies.