Eset GUI has stopped working

Discussion in 'ESET Smart Security' started by kaboro, Jan 31, 2012.

Thread Status:
Not open for further replies.
  1. kaboro

    kaboro Registered Member

    Joined:
    Jul 28, 2009
    Posts:
    14
    Using Win7 64bit.
    Happens when i try to do a custom scan. I get the "Eset GUI has stopped working" message and the tray icon disappears shortly.
    When i restart Eset from the start menu, the custom scan is already running.
    Under normal conditions when i stop a custom scan and try to do another custom scan, the previous custom selections are still there.
    Now i noticed when i do that, the new custom scan window is the default one, the previous selections are not memorized, and the gui crashes if i make a selection and start the scan.
    An antivirus that crashes is quite rare...
    This happened after upgrading to version 5 a couple days ago.
    The problem is intermittent too, doesnt happen everytime.
     
    Last edited: Jan 31, 2012
  2. dwomack

    dwomack Eset Staff Account

    Joined:
    Mar 2, 2011
    Posts:
    588
  3. kaboro

    kaboro Registered Member

    Joined:
    Jul 28, 2009
    Posts:
    14
    Uninstalled, restarted pc, re-installed, doing same thing.
    If i select custom scan and select a drive, it will work ok.
    If i remove certain folders from within the drive, it will crash when i start the scan.
    I couldnt find a correlation between specific folders and the crash.
    I wonder if i can trust an antivirus that isnt even stable.
     
    Last edited: Feb 2, 2012
  4. dwomack

    dwomack Eset Staff Account

    Joined:
    Mar 2, 2011
    Posts:
    588
    OK so I'll take that as a no. When uninstalling normally and reinstalling the program doesn't work, you will need to run the MANUAL UNINSTALLER TOOL in Safe Mode to clear out the files that are causing the issue.
     
  5. kaboro

    kaboro Registered Member

    Joined:
    Jul 28, 2009
    Posts:
    14
    Ok i tried that too.
    Windows safe mode, used the Eset uninstaller, successfully removed the eset antivirus.
    Restarted Windows in normal mode, installed smart security 5, same problem: When i uncheck too many files/folders from the custom scan, i get "eset gui has stopped working", then the scan window closes and the taskbar icon vanishes, even though the scan is running.

    If do a custom scan and select the whole drive, it works fine.
    If i uncheck just a few files/folders from the scanlist, it works fine.
    Soon as i uncheck a larger number of files and probably bigger folders, it will crash.
     
  6. Cudni

    Cudni Global Moderator

    Joined:
    May 24, 2009
    Posts:
    6,956
    Location:
    Somethingshire
    can you post a screenshot or list what files and their locations are you exluding? Also check windows event viewer logs for errors or warnings
     
  7. hogndog

    hogndog Registered Member

    Joined:
    Jun 9, 2007
    Posts:
    628
    Location:
    In His Service
    In your options whats the setting for the size of the folders you've elected to scan. Some of these antivirus scanners won't scan, say for instance anything over 20 MB.. o_O
     
  8. kaboro

    kaboro Registered Member

    Joined:
    Jul 28, 2009
    Posts:
    14
    I played quite a bit with excluding different files and folders and i couldnt find any rule, other than that it tends to happen when there are sufficient many files excluded, and from different folders.
    I checked the windows event viewer and i got that:

    Faulting application name: egui.exe, version 5.0.94.0
    Faulting module name: MSVCR80.dll, version 8.0.50727.6195
    Exception code: 0xc000000d

    Thats from the details window:

    - System

    - Provider

    [ Name] Application Error

    - EventID 1000

    [ Qualifiers] 0

    Level 2

    Task 100

    Keywords 0x80000000000000

    - TimeCreated

    [ SystemTime] 2012-02-15T04:23:58.000000000Z

    EventRecordID 21322

    Channel Application

    Computer QW226

    Security


    - EventData

    egui.exe
    5.0.94.0
    4e7b012d
    MSVCR80.dll
    8.0.50727.6195
    4dcdd833
    c000000d
    0000000000086a5b
    dd0
    01cceb56b85131a5
    C:\Program Files\ESET\ESET Smart Security\egui.exe
    C:\Windows\WinSxS\amd64_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.6195_none_88e41e092fab0294\MSVCR80.dll
    e0867cf2-578c-11e1-a4bd-f46d04acf53c


    EDIT: i ran sfc /scannow and it did not find any problems with the system files.
     
    Last edited: Feb 15, 2012
  9. agoretsky

    agoretsky Eset Staff Account

    Joined:
    Apr 4, 2006
    Posts:
    4,032
    Location:
    California
  10. kaboro

    kaboro Registered Member

    Joined:
    Jul 28, 2009
    Posts:
    14
    This is weird, when i mouse over the Eset icon, it says version 5.0.95.0, the "About" window says i have version 5.0.95.0.
    Then i go and provoke the gui crash and check the windows event viewer, and in there it says that the faulting application is egui.exe version 5.0.94.0.
    After using the Eset uninstaller i clean installed using the eset_smart_installer.exe from the eset site, when i mouse over it, says file version 5.0.15.1.
    I will try the download you provided, see what gives.
    Thank you for your replies.
     
  11. kaboro

    kaboro Registered Member

    Joined:
    Jul 28, 2009
    Posts:
    14
    Used eset uninstaller in safe mode, then downloaded using your link and installed, updated definitions and left the settings at default, except the pre-release update check.

    Tried a custom scan on C: drive, from which i unchecked a few folders in C:\Downloads, namely the folder containing downloaded mmo clients, and some zip files containing downloaded game updates. Then unchecked installed mmo folders from C:\Program Files (x86), namely Rift, Ryzom and Sony.

    Custom scan crashed the gui again as usual.
    The windows event viewer message was different this time though, egui.exe was not mentioned as the faulting application anymore:

    Log Name: Application
    Source: WMI
    Event ID: 10
    Level: Error


    - EventData

    //./root/CIMV2
    SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 99
    0x80041003




    Then i increased the settings (turned on advanced heuristics and runtime packers) and tried this again, it crashed and the event viewer did point out egui.exe ver 5.0.94.0 as the faulting app.

    - EventData

    egui.exe
    5.0.94.0
    4e7b012d
    MSVCR80.dll
    8.0.50727.6195
    4dcdd833
    c000000d
    0000000000086a5b
    bf0
    01ccee44d49a73fd
    C:\Program Files\ESET\ESET Smart Security\egui.exe
    C:\Windows\WinSxS\amd64_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.6195_none_88e41e092fab0294\MSVCR80.dll
    fb4ca5b5-5a3a-11e1-b0f2-f46d04acf53c

    So the gui crashes (and sometimes manages to restart by itself normally) but the event view logs are different when i use different settings.
    Also the gui version in the event viewer is not the same as the ess version.
     
    Last edited: Feb 18, 2012
Thread Status:
Not open for further replies.