ESET Firewall and epfwwfp Driver

Discussion in 'Other ESET Home Products Beta' started by zizoshx13, Aug 28, 2012.

Thread Status:
Not open for further replies.
  1. zizoshx13

    zizoshx13 Registered Member

    Joined:
    May 7, 2011
    Posts:
    5
    Location:
    Earth
    Hello everyone,

    I got a problem with Firewall on ESET Smart Security 5 and RC 6 too.

    http://i.imgur.com/zpyAZ.jpg

    but it seems working in ESET Setup shown as enabled, and a problem with a driver epfwwfp.

    http://i.imgur.com/iHS4p.jpg

    Windows 7 Ultimate SP1 32bit (x86).

    Regards...
     

    Attached Files:

    Last edited: Aug 28, 2012
  2. zizoshx13

    zizoshx13 Registered Member

    Joined:
    May 7, 2011
    Posts:
    5
    Location:
    Earth
    OMG, 3 days and nobody answered me, what a great support -.-

    or you can't solve this problem, This problem in both Ver 5 and 6 :gack:
     
  3. P_R_

    P_R_ Eset Staff Account

    Joined:
    Jul 25, 2012
    Posts:
    62
    Location:
    Slovakia
    Hello,

    I would recommend you to submit a ticket to ESET support directly from ESET Smart Security -> Help and support -> Customer Care support request (recommended)...

    SysInspector log would be very helpful (it is automatically created and submited with a new ticket ).

    P.R.
     
  4. zizoshx13

    zizoshx13 Registered Member

    Joined:
    May 7, 2011
    Posts:
    5
    Location:
    Earth
    Thanks for reply, i think that's a better way instead of making threads in a dead forum.
     
  5. zerotox

    zerotox Registered Member

    Joined:
    Jul 16, 2009
    Posts:
    417
    Please keep us posted about the development on this issue as I have exactly the same problem. Uninstall in safe mode with eset's separate unistall tool didn't help.
     
  6. zerotox

    zerotox Registered Member

    Joined:
    Jul 16, 2009
    Posts:
    417
    Hello, guys! Any development here - the problem with the WFP driver is what's stopping me from using ESS instead of the AV only.
     
  7. The Red Moon

    The Red Moon Registered Member

    Joined:
    May 17, 2012
    Posts:
    3,871
    Just a long shot but have you tried re-installing ESS.?
    Ive had a similar problem myself in the past and it was an out of date driver.But i simply removed it and the product replaced it itself.Its just a idea.
    Regards.:thumb: :thumb: :thumb:
     
  8. zerotox

    zerotox Registered Member

    Joined:
    Jul 16, 2009
    Posts:
    417
    Thank you for taking time to reply! I updated my network card drivers, uninstalled ESET with their dedicated uninstall tool in safe mode, then reinstalled but the problem stays the same, and like the OP stated - it's both in version 5 and 6. I really don't know what to do. I'm even considering eventual incompatibility of ESET with my network card.
     
  9. The Red Moon

    The Red Moon Registered Member

    Joined:
    May 17, 2012
    Posts:
    3,871
    Are there any remnant drivers from a previous install left over?
    Sorry i cant be more help.It was so long ago when i last had this problem.
    Hope it works out.:thumb: :thumb:
     
  10. zerotox

    zerotox Registered Member

    Joined:
    Jul 16, 2009
    Posts:
    417
    No, besides uninstalling in safe mode, I thoroughly checked for left-over drivers in system32/drivers as well as in non plug-and-play drivers in device manager. I meticulously checked the registry as well for any left-over keys.
    Thank you for your time and help anyway!
     
  11. The Red Moon

    The Red Moon Registered Member

    Joined:
    May 17, 2012
    Posts:
    3,871
    The only other thing i could suggest to you is perhaps going back to an earlier image or restore point to see if that helps you.
    Best of luck to you anyway.:thumb:
     
  12. zerotox

    zerotox Registered Member

    Joined:
    Jul 16, 2009
    Posts:
    417
    I noticed something that I would like you to help me clarify. At work we are running Eset Endpoint AV 5.0.2126.0 and when I checked the non-plug and play drivers it shows epfwwfpr driver not epfwwfp as when I installed the home version. And no problem of any sort with epfwwfpr driver of any sort. Can someone explain why the difference with these drivers?
     
  13. P_R_

    P_R_ Eset Staff Account

    Joined:
    Jul 25, 2012
    Posts:
    62
    Location:
    Slovakia
    Hello,

    epfwwfp.sys is used in ESET Smart Security (ESET Endpoint Security) and epfwwfpr.sys is used in ESET NOD32 Antivirus (ESET Endpoint Antivirus).
     
  14. zerotox

    zerotox Registered Member

    Joined:
    Jul 16, 2009
    Posts:
    417
    Thank you very much for responding. In fact even though there are these reports in ESET's events "an error occurred while starting firewall services/proxy server", is it really a problem? Because the firewall is working despite the error messages, I've tried it. And are these error messages connected with the WFP problems?
     
  15. P_R_

    P_R_ Eset Staff Account

    Joined:
    Jul 25, 2012
    Posts:
    62
    Location:
    Slovakia
  16. zerotox

    zerotox Registered Member

    Joined:
    Jul 16, 2009
    Posts:
    417
    Yes, I have done this twice - uninstalled with your uninstaller in safe mode and did a fresh install. The result is the same. I have ESS 5.0 installed on a XP laptop with no such issues. Probably WFP in Windows 7 is the culprit.
     
  17. P_R_

    P_R_ Eset Staff Account

    Joined:
    Jul 25, 2012
    Posts:
    62
    Location:
    Slovakia
    Hello,

    could you please send me SysInspector log from affected machine with ESET installed?

    Thank you.
     
  18. zerotox

    zerotox Registered Member

    Joined:
    Jul 16, 2009
    Posts:
    417
    I thank you for your time and help. For the time being I have uninstalled it but when I get it back I'll send you a log. Unfortunately after waiting for some time for any development on this thread, I switched AVs.
     
  19. P_R_

    P_R_ Eset Staff Account

    Joined:
    Jul 25, 2012
    Posts:
    62
    Location:
    Slovakia
    Hello,

    sorry to hear that.

    Thank you that you are willing to resolve this situation, I hope we will be successful.

    Regards,
     
  20. zerotox

    zerotox Registered Member

    Joined:
    Jul 16, 2009
    Posts:
    417
    An update - I installed the AV version - ESET NOD32 6 RC and no problem whatsoever with the epfwwfpr.sys driver, no error messages in the Events log. Seems only the epfwwfp.sys driver of the Smart Security version makes problems and in the Device Manager non-plug and play drivers it is marked with a "!" as not working or installed correctly.
     
  21. zizoshx13

    zizoshx13 Registered Member

    Joined:
    May 7, 2011
    Posts:
    5
    Location:
    Earth
    Finally someone replied, we have done everything you can imagine, but we got the same error only in Win7, Win XP working fine with me.
     
Thread Status:
Not open for further replies.