Eset Crippling Web Browsing While Running uTorrent

Discussion in 'ESET Smart Security' started by livedead13, Aug 3, 2008.

Thread Status:
Not open for further replies.
  1. livedead13

    livedead13 Registered Member

    Aug 3, 2008
    ESET Smart Security is crippling my web browsing while running uTorrent. web pages load extremely slow, if at all.

    i did NOT have this issue before installing ESS. and if i kill the ekrn.exe process, web browsing returns to normal, so it's definitely ESS.

    this is NOT a bandwidth issue, as this happens even when there is no traffic, and i have plenty of bandwidth anyway. i have limited the maximum number of connections with no helpful results, but i shouldn't have to do that anyway, as i have absolutely no issues when ESS is not running.

    also, any handling of .exe files within Windows Explorer is extremely slow with ESS running. even simply right-clicking an .exe file will cause Explorer to hang for several seconds before displaying the context menu. moving, copying and opening .exe files all cause the same issue.

    again, if i kill the ekrn.exe process, everything is noraml.

    so does anyone have any suggestions or fixes?

    i'm using ESS 3.0.669.0 and Windows XP SP3.

  2. frank_jarle

    frank_jarle Registered Member

    Aug 5, 2008
    Its not much to go after here, first off:

    - What is your Internet connection speed (Down/up)
    - How many files are you downloading with uTorrent
    - How many files are you sharing with uTorrent
    - How many connection is allowed in uTorrent
    - What is the computer specs

    I have been using ESS on my XP32 for long time together with Azureuz and never had any problem , even if i max out the connection, but then im not sharing nor downloading many files at one go, pluss i dont have more then max 4 connection as any time.

    I wouldnt be so fast to blame ESS, i have the Explorer issue at my corporate laptop, right click on a file but sometimes its taking up to 15-20sec before i see the context office we dont use ESS, i believe its rather a windows service of some kind.

  3. TimaN

    TimaN Registered Member

    Aug 22, 2005
    Tulsa, OK
    Livedead13, I can relate to your issue. I used to have NOD32 and while utorrent was running (even when not downloading/sharing) it was practically impossible to browse internet. I uninstalled NOD32 and everything is back to normal. Other issues with NOD escalated to a point that I’m with different anti-virus now.
  4. livedead13

    livedead13 Registered Member

    Aug 3, 2008
    ^^^ glad to see i'm not the only one. there are some other similar threads around here as well, though none with any solution.

    bump... for some support. i'm a paying customer. not demo'ing.
    - 1 MB/s down, 2 Mb/s up
    - doesn't matter. happens with 1 or 20.
    - doesn't matter. happens when leeching or seeding any amount of torrents.
    - lessening the connections doesn't have an effect.
    - XP Pro SP3, Firefox 3, uTorrent 1.7.7, AMD Athlon 64 X2 4000+, 2GB ram, 500GB Sata2 hd, GeForce 7800 GTX display, nForce 590 SLI chipset
    as i stated before, if i disable everything through ESS, both issues still occur. if i kill the process entirely through task manager, the problems go away. and i didn't have these issues before i installed ESET.

    i've tried disabling ESS at startup by using msconfig, and the problems go away. but then i noticed that Skpe is not able to connect, which is strange that the firewall is blocking it when it's not even on. if i re-enable ESS at startup, Skype is able to connect again, and of course the other issues come back.

    in the event viewer, i get error 4226 like crazy when both uTorrent and ESS are running together. i didn't get the errors before i installed ESS, and they don't happen when the ekrn.exe process is killed.

    also, the internet browsing/utorrent issue didn't happen straight away after installing ESS. it didn't start happening until recently, which i should have mentioned in the original post. right now, everything is running smoothly, though i'm still getting 4226 errors, but there is no noticeable decrease in performance. this is after my computer has been up and running for about a day. if i need to reboot, or shut down, the problem happens all over again, and sometime resolves itself within a few hours, sometimes it takes more than a day or two.

    after i noticed this issue was happening for a while, i downloaded the latest version of ESS and installed it. the installation went fine. though it didn't help the issues.

    there have been no other changes to the system. this is a fairly fresh install, and all my other software was installed right after XP finished installing.
    Last edited: Aug 8, 2008
  5. martinth

    martinth Registered Member

    Aug 10, 2008
    It's a simple fix.

    Right Click ESET SS Sytem tray Icon.
    Go to Advanced Setup

    Go to HTTP, and open the tree.
    Then go to Web Browsers
    Uncheck uTorrent.

    Click Okay, restart computer.
  6. livedead13

    livedead13 Registered Member

    Aug 3, 2008
    thanks for the reply.

    uTorrent was not checked, so that's not the problem.

    are there any official ESET people on this board that would care to respond?
  7. agoretsky

    agoretsky Eset Staff Account

    Apr 4, 2006

    Have you tried excluding the µTorrent and Skype Phone programs from being scanned by the real-time virus protection component as well as the firewall component? If so, did that make any difference?


    Aryeh Goretsky
  8. sakin

    sakin Registered Member

    Jan 12, 2008
    I believe it may lie with utorrent, I just got utorrent and have the same thing. Used to use azureus, anyway as people have said it is super slow when trying to browse with utorrent open, not necessarily downloading either. I can have nothing active in utorrent and still get the slowness. I have a feeling that its just utorrent because of this. Also when utorrent is on for around 5-10 minutes, I can browse much like before I opened utorrent, mayhaps its because utorrent is doing a bunch of stuff when its first opened, but idk.
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.